Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 05:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите разобраться с ошибкой  (Прочитано 8010 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
1С:Предприятие 8.2 (8.2.18.61) Торговля для ЧП базовая
Подскажите пожалуйста что не так?При проведении документов выскакивает такая ошибка:

Функция НехватаетТовара(тзПартийНоменклатуры)
   
   Если тзПартийНоменклатуры.Количество() > 0 Тогда
      КоличествоКСписанию = тзПартийНоменклатуры[0].Количество;
      КоличествоОстаток = тзПартийНоменклатуры.Итог("КоличествоОстаток");
      Если КоличествоКСписанию > КоличествоОстаток Тогда
         Сообщить("Регистр Партии товаров на складах:
               |Номенклатура: " + тзПартийНоменклатуры[0].Номенклатура.Наименование + "
               |Характеристика: " + тзПартийНоменклатуры[0].ХарактеристикаНоменклатуры.Наименование + "
               |Серия: " + тзПартийНоменклатуры[0].СерияНоменклатуры.Наименование + "
               |Склад: " + тзПартийНоменклатуры[0].Склад.Наименование + "
               |товара на складе недостаточно, необходимо: " + Строка(КоличествоКСписанию) + " имеется: " + Строка(КоличествоОстаток), СтатусСообщения.Важное);
         Возврат Истина;
      Иначе
         Возврат Ложь;
      КонецЕсли;
   КонецЕсли;
   
КонецФункции // НехватаетТовара()



{ОбщийМодуль.УправлениеЗапасамиПартионныйУчет.Модуль(340)}: Операции сравнения на больше-меньше допустимы только для значений совпадающих примитивных типов (Булево, Число, Строка, Дата)
  Если КоличествоКСписанию > КоличествоОстаток Тогда


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
он же вам пишет {ОбщийМодуль.УправлениеЗапасамиПартионныйУчет.Модуль(340)}: Операции сравнения на больше-меньше допустимы только для значений совпадающих примитивных типов (Булево, Число, Строка, Дата)
  Если КоличествоКСписанию > КоличествоОстаток Тогда
проверьте в отладчике чему равно КоличествоКСписанию и КоличествоКСписанию, скорее всего отдно из значений Null, и его надо привести к нулю

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
он же вам пишет {ОбщийМодуль.УправлениеЗапасамиПартионныйУчет.Модуль(340)}: Операции сравнения на больше-меньше допустимы только для значений совпадающих примитивных типов (Булево, Число, Строка, Дата)
  Если КоличествоКСписанию > КоличествоОстаток Тогда
проверьте в отладчике чему равно КоличествоКСписанию и КоличествоКСписанию, скорее всего отдно из значений Null, и его надо привести к нулю

Везде есть значения,только в Количестве переменная не определена

КоличествоКСписанию = тзПартийНоменклатуры[0].Количество;

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
он же вам пишет {ОбщийМодуль.УправлениеЗапасамиПартионныйУчет.Модуль(340)}: Операции сравнения на больше-меньше допустимы только для значений совпадающих примитивных типов (Булево, Число, Строка, Дата)
  Если КоличествоКСписанию > КоличествоОстаток Тогда
проверьте в отладчике чему равно КоличествоКСписанию и КоличествоКСписанию, скорее всего отдно из значений Null, и его надо привести к нулю

Везде есть значения,только в Количестве переменная не определена

КоличествоКСписанию = тзПартийНоменклатуры[0].Количество;

Если ЗначениеЗаполенено(КоличествоКСписанию) Тогда
    //сравнение...

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Спасибо всем кто откликнулся!Ошибка была недопустимая для 1С-ников,забыли написать естьNULL в запросе.В обновлениях исправили наверное.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4290
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5546
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5880
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4360
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1975
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 222
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal