Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 00:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ссылка на документ  (Прочитано 7349 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vogde

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-24
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет.  В отчете (дополнительная внешняя обработка)  необходимо чтобы в поле Документ выдавалась ссылка на этот документ.

Вот код, подскажите где ошибка?
Код: e1cv8 [Выделить]


Процедура КнопкаВыполнитьНажатие(Кнопка)

Макет = ПолучитьМакет("Основной");
ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
ОбластьИтого = Макет.ПолучитьОбласть("Итого");

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
   | УслугиСМКОстаткиИОбороты.Поставщик.Ссылка КАК Поставщик,
   | УслугиСМКОстаткиИОбороты.ДокументПоставщика.Ссылка КАК ДокументПоставщика,
   | УслугиСМКОстаткиИОбороты.Регистратор,
   | УслугиСМКОстаткиИОбороты.СуммаДокументаНачальныйОстаток КАК СуммаДокументаНачальныйОстаток,
   | УслугиСМКОстаткиИОбороты.СуммаДокументаПриход КАК СуммаДокументаПриход,
   | УслугиСМКОстаткиИОбороты.СуммаДокументаРасход КАК СуммаДокументаРасход,
   | УслугиСМКОстаткиИОбороты.СуммаДокументаКонечныйОстаток КАК СуммаДокументаКонечныйОстаток
   |ИЗ
   | РегистрНакопления.УслугиСМК.ОстаткиИОбороты ( &НачалоПериода, &КонецПериода, Авто,  ,Поставщик = &Поставщик) КАК УслугиСМКОстаткиИОбороты
   |ИТОГИ
   | СУММА(СуммаДокументаНачальныйОстаток),
   | СУММА(СуммаДокументаПриход),
   | СУММА(СуммаДокументаРасход),
   | СУММА(СуммаДокументаКонечныйОстаток)
   |ПО
   | ОБЩИЕ,
   | Поставщик,
   | ДокументПоставщика";
   
Если Не ЗначениеЗаполнено(Контрагент) Тогда

Запрос.Текст = СтрЗаменить(Запрос.Текст,"Поставщик = &Поставщик","");

КонецЕсли;

Запрос.УстановитьПараметр("НачалоПериода", НачалоПериода);
Запрос.УстановитьПараметр("КонецПериода", КонецПериода);
Запрос.УстановитьПараметр("Поставщик", Контрагент);

Выборка = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);

// Общие итоги

ИтогоНаНачало = 0;
ИтогоПриход = 0;
ИтогоРасход = 0;
ИтогоНаКонец =0;

ЭлементыФормы.Результат.Очистить();
ЭлементыФормы.Результат.Вывести(ОбластьЗаголовок);
ЭлементыФормы.Результат.Вывести(ОбластьШапка);

Пока Выборка.Следующий() Цикл

ИтогоНаНачало = Выборка.СуммаДокументаНачальныйОстаток;
ИтогоПриход = Выборка.СуммаДокументаПриход;
ИтогоРасход = Выборка.СуммаДокументаРасход;
ИтогоНаКонец = Выборка.СуммаДокументаКонечныйОстаток;

ВыборкаПоставщик = Выборка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);

ЭлементыФормы.Результат.НачатьАвтогруппировкуСтрок();
    // Поставщик
Пока ВыборкаПоставщик.Следующий() Цикл

ОбластьСтрока.Параметры.ПоставщикДокумент = ВыборкаПоставщик.Поставщик;
ОбластьСтрока.Параметры.Реализация = " ";
ОбластьСтрока.Параметры.НаНачало = ВыборкаПоставщик.СуммаДокументаНачальныйОстаток;
ОбластьСтрока.Параметры.Приход = ВыборкаПоставщик.СуммаДокументаПриход;
ОбластьСтрока.Параметры.Расход = ВыборкаПоставщик.СуммаДокументаРасход;
ОбластьСтрока.Параметры.НаКонец = ВыборкаПоставщик.СуммаДокументаКонечныйОстаток;

    Элементыформы.Результат.Вывести(ОбластьСтрока,1,"Поставщик");

// ДокументПоставщика

ВыборкаДокументПоставки = ВыборкаПоставщик.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);

Пока ВыборкаДокументПоставки.Следующий() Цикл

ОбластьСтрока.Параметры.ПоставщикДокумент = ВыборкаДокументПоставки.ДокументПоставщика;
ОбластьСтрока.Параметры.Реализация = " ";
ОбластьСтрока.Параметры.НаНачало = ВыборкаДокументПоставки.СуммаДокументаНачальныйОстаток;
ОбластьСтрока.Параметры.Приход = ВыборкаДокументПоставки.СуммаДокументаПриход;
ОбластьСтрока.Параметры.Расход = " ";
ОбластьСтрока.Параметры.НаКонец = ВыборкаДокументПоставки.СуммаДокументаКонечныйОстаток;

ЭлементыФормы.Результат.Вывести(ОбластьСтрока,2,"Документ");

// Реализация

ВыборкаРеализация = ВыборкаДокументПоставки.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);

Пока ВыборкаРеализация.Следующий() Цикл

Если ЗначениеЗаполнено (ВыборкаРеализация.Регистратор) И ТипЗнч(ВыборкаРеализация.Регистратор) = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
 
ОбластьСтрока.Параметры.ПоставщикДокумент = " ";
ОбластьСтрока.Параметры.Реализация = Строка(ВыборкаРеализация.Регистратор.Контрагент)+ ": " + ВыборкаРеализация.Регистратор;
ОбластьСтрока.Параметры.НаНачало = " ";
ОбластьСтрока.Параметры.Приход = " ";
ОбластьСтрока.Параметры.Расход = ВыборкаРеализация.СуммаДокументаРасход;
ОбластьСтрока.Параметры.НаКонец = " ";

ЭлементыФормы.Результат.Вывести(ОбластьСтрока,3,"Реализация");

КонецЕсли;

КонецЦикла;


КонецЦикла; 
КонецЦикла;
КонецЦикла;    

ЭлементыФормы.Результат.ЗакончитьАвтогруппировкуСтрок();

ОбластьИтого.Параметры.НаНачало = ИтогоНаНачало;
ОбластьИтого.Параметры.Приход = ИтогоПриход;
ОбластьИтого.Параметры.Расход = ИтогоРасход;
ОбластьИтого.Параметры.НаКонец = ИтогоНаКонец;

ЭлементыФормы.Результат.Вывести(ОбластьИтого);


КонецПроцедуры




Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
А что не работает то?
Выводиться строка вместо ссылки? Смотри в сторону свойств параметра макета - тип значения
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Vogde

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-24
  • Сайт: 
  • Профессия: Ученик 1С
Установил ТипЗначения      ДокументСсылка.нужный документ ,     Но все равно ссылка не выдается

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
А как ты проверил выводиться ссылка или нет?
Добавлено: 19 Июл 2013, 11:05

Нужно у макета поставить свойство только просмотр
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Vogde

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-24
  • Сайт: 
  • Профессия: Ученик 1С
А как ты проверил выводиться ссылка или нет?
Добавлено: 19 Июл 2013, 11:05

Нужно у макета поставить свойство только просмотр

1 Когда создаешь отчет через конструктор, в запущенном приложении наводя на это поле по двойному клику можно перейти на отображенный документ. В моем случае этой возможности не предоставляется.

2 подскажите как выставить это свойство

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
В свойствах табличного поля "Результат"
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Vogde

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-24
  • Сайт: 
  • Профессия: Ученик 1С
Денис извини что сразу не поблагодарил за помощь! Спасибо большое все заработало:zebzdr:


Теги:
 

не находить контрагента (Выбрать * Из Документ ГДЕ контрагент = "имя контрагента")

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 239
Последний ответ 23 Окт 2017, 23:14
от Ivan94
Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4405
Последний ответ 25 Ноя 2008, 10:43
от DDD
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9353
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3922
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
Как программно открыть документ программно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 19052
Последний ответ 10 Ноя 2010, 14:08
от Lexius

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 215
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal