Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 сен 2021, 00:58

Как выбрать данные из регистра накопления

Автор bkmz_1_, 18 июл 2013, 23:02

0 Пользователей и 1 гость просматривают эту тему.

bkmz_1_

Делаю вот так:

&НаКлиенте
Процедура АвтоПриИзменении(Элемент)
   Авто = Объект.Авто;
   Выборка(Авто);
КонецПроцедуры

&НаСервере
Процедура Выборка(Авто)
   Фильтр = Новый Структура;
   Фильтр.Вставить("Авто", Авто);
    Дата = ТекущаяДата();
   Сообщить(Авто);
   ТаблицаОстатков = РегистрыНакопления.ТопливаВБаке.Остатки(Дата, Фильтр, "Авто", "Литров");
    Для каждого СтрокаТаблицы из ТаблицаОстатков цикл
        Объект.Остаток = СтрокаТаблицы.Литров;
    КонецЦикла;
КонецПроцедуры


Получаю ошибку



Не пойму что не так

Если Эту строчку:

Фильтр.Вставить("Авто", Авто);

пишу так

Фильтр.Вставить("Авто", "ВАЗ 2107");

то все работает.

Переменная авто не пустая. Я ее вывожу легко в сообщении
Чем ленивее человек, тем больше его труд похож на подвиг

GRADUS

Попробуй так:
&НаКлиенте
Процедура АвтоПриИзменении(Элемент)
   Авто = Объект.Авто;
   Выборка(Авто);
КонецПроцедуры

&НаСервере
Процедура Выборка(Авто)
   Фильтр = Новый Структура;
   Фильтр.Вставить("Авто", СокрЛП(Авто));
    Дата = ТекущаяДата();
   Сообщить(Авто);
   ТаблицаОстатков = РегистрыНакопления.ТопливаВБаке.Остатки(Дата, Фильтр, "Авто", "Литров");
    Для каждого СтрокаТаблицы из ТаблицаОстатков цикл
        Объект.Остаток = СтрокаТаблицы.Литров;
    КонецЦикла;
КонецПроцедуры


Ошибка скорее всего при записи регистра, а точнее в типе измерения регистра. Тип должен быть не строка, а ссылка на справочник авто.

bkmz_1_

Сработало. Правда я не совсем понял что было не так. В регистре накопления измерение в котором хранится название автомобиля должно быть ссылка на справочник с авто?
Чем ленивее человек, тем больше его труд похож на подвиг

GRADUS

Цитата: bkmz_1_ от 18 июл 2013, 23:31
В регистре накопления измерение в котором хранится название автомобиля должно быть ссылка на справочник с авто?

Да !!!
Ты сравнивал 2 разных типа ссылку и строку. "СокрЛП()" привел ссылку к строке и убрал лишние пробелы. строка = строка.

bkmz_1_

Чем ленивее человек, тем больше его труд похож на подвиг

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск