Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 21:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите пожалуйста!  (Прочитано 1999 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alex_Us

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-26
  • Сайт: 
  • Профессия: Ученик 1С
Для отчета сделаны движения в регистре накопления, вот код, но данные все равно не выводятся, а выводится только одно поле сумма и все(( почему? что не так???


ТаблицаДвижений = Новый ТаблицаЗначений;
 СтрокаДвижений = ТаблицаДвижений.Добавить();
 
 Для Каждого Содержание Из Услуги Цикл
 СтрокаДвижений.Содержание = Содержание;
 КонецЦикла;
 
  Для Каждого Исполнитель Из Исполнители Цикл
  СтрокаДвижений.Исполнитель = Исполнитель;
  КонецЦикла;
 
 СтрокаДвижений.СуммаДокумента = СуммаДокумента;
 СтрокаДвижений.ПроцентИсполнителя = Контрагент.ПроцентОплаты;
 СтрокаДвижений.СуммаПоПроценту = СтрокаДвижений.СуммаДокумента * СтрокаДвижений.ПроцентИсполнителя;
 



   
 //обход всей таблицы
Для Каждого СтрокаДвижений Из ТаблицаДвижений Цикл
 // регистр УчетЗарплаты
   Движения.УчетЗарплаты.Очистить();
   Движение = Движения.УчетЗарплаты.Добавить();
   Движение.Период = Дата;
   Движение.ОказаннаяУслуга = Содержание;
   Движение.Исполнитель = Исполнитель;
   Движение.СуммаДокумента = СуммаДокумента;
   Движение.ПроцентИсполнителя = Контрагент.ПроцентОплаты;
   Движение.СуммаПоПроценту =  Движение.СуммаДокумента * Движение.ПроцентИсполнителя;

КонецЦикла;


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Для Каждого СтрокаДвижений Из ТаблицаДвижений Цикл
 // регистр УчетЗарплаты
   Движения.УчетЗарплаты.Очистить();
   Движение = Движения.УчетЗарплаты.Добавить();
   Движение.Период = Дата;
   Движение.ОказаннаяУслуга = Содержание;
   Движение.Исполнитель = Исполнитель;
   Движение.СуммаДокумента = СуммаДокумента;
   Движение.ПроцентИсполнителя = Контрагент.ПроцентОплаты;
   Движение.СуммаПоПроценту =  Движение.СуммаДокумента * Движение.ПроцентИсполнителя;

КонецЦикла;

Вы имели в виду
Движение.ОказаннаяУслуга = СтрокаДвижений.Содержание;
и так для каждого присвоения!

Добавлено: 16 Июл 2013, 13:14

Для Каждого Содержание Из Услуги Цикл
 СтрокаДвижений.Содержание = Содержание;
 КонецЦикла;
 
  Для Каждого Исполнитель Из Исполнители Цикл
  СтрокаДвижений.Исполнитель = Исполнитель;
  КонецЦикла;
Не совсем понятны эти цыклы! В результате у вас в значении последнее значение!

Помогли, отблагодари!

Оффлайн Alex_Us

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-26
  • Сайт: 
  • Профессия: Ученик 1С
да вот и не могу в отчет вывести все правильно... выводится только сумма документа((( остальные поля никак(((
Добавлено: 17 Июл 2013, 06:16

просто у меня данные Содержание и Исполнитель в разных табличных частях... вот и надо мне как то объединить все в один отчет...

Последний раз редактировалось: Alex_Us; 17 Июл 2013, 06:16. Причина: Объединение сообщений

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Неужели запустить отладку дольше, чем создать тему на форме? :dfbsdfbsdf:

Ну вот откуда мы знаем что такое "Услуги" или "Исполнители" ?

Если отчет верный, то в Услугах и Исполнителях последняя строча пустая, из-за этого и не пашет.

Чтобы работало, напиши в 2-ух циклах:
Если ЗначениеЗаполнено(СтрокаДвижений.содержание) Тогда
Прервать;
КонецЕсли;

А то, что ниже это в первый класс

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
:ooifh:
Добавлено: 17 Июл 2013, 11:52

так вы делайте отчет! а не прописывайте движения в регистр!
Помогли, отблагодари!


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4304
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5565
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5903
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4399
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1987
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
73 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 329
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal