Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 18:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Чтение текстового файла с ftp сервера  (Прочитано 8808 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Soulidium

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2012-11-04
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите как прочитать текстовый файл который находится на ftp сервере?
Остановился на этапе поиска текстовых файлов.

СерверФТП.УстановитьТекущийКаталог(КаталогRS+"/out");
ФайлыTXT = СерверФТП.НайтиФайлы(СерверФТП.ТекущийКаталог(),"*.txt");
Для Каждого Файл Из ФайлыTXT Цикл
       ВремФайл = ПолучитьИмяВременногоФайла("txt");
       СерверФТП.Получить(Файл.Имя,ВремФайл);

..................................................................................

КонецЦикла;


Оффлайн Soulidium

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2012-11-04
  • Сайт: 
  • Профессия: Ученик 1С
Так вот тоже не получается...
СерверФТП.УстановитьТекущийКаталог(КаталогRS+"/out");
ФайлыTXT = СерверФТП.НайтиФайлы(СерверФТП.ТекущийКаталог(),"*.txt");
Для Каждого Файл Из ФайлыTXT Цикл
    ТекстДок = Новый ТекстовыйДокумент;
    ТекстДок.Прочитать("ftp://***.***.***.***/out/"+Файл.Имя);
КонецЦикла;
Текст ошибки:

{Обработка.ЧтениеФайла.Форма.Форма.Форма(44)}: Ошибка при вызове метода контекста (Прочитать)
ТекстДок.Прочитать("ftp://***.***.***.***/out/"+Файл.Имя);
по причине:
Файл не обнаружен 'file://ftp://***.***.***.***/out/file.txt

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
А что не получается в первом варианте?

СерверФТП.УстановитьТекущийКаталог(КаталогRS+"/out");
ФайлыTXT = СерверФТП.НайтиФайлы(СерверФТП.ТекущийКаталог(),"*.txt");
Чтение = Новый ЧтениеТекста;
Для Каждого Файл Из ФайлыTXT Цикл
       ВремФайл = ПолучитьИмяВременногоФайла("txt");
       СерверФТП.Получить(Файл.Имя,ВремФайл);
       Чтение.Открыть(ВремФайл);

       СтрокаТекст = Чтение.Прочитать();
                       
КонецЦикла;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Soulidium

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2012-11-04
  • Сайт: 
  • Профессия: Ученик 1С
А что не получается в первом варианте?
Проблема в том, что я не знал что делать дальше. Не знал про "ЧтениеТекста":) Спасибо!

Оффлайн Soulidium

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2012-11-04
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите кто нибудь как решить проблему. В цикле перебираю файлы c ftp, разбиваю на строки и заношу строки в массив (то что массив затирается каждый раз уже понял, исправлю :)) Дело в том, что на этапе считывания 2го файла начинается ругань на 14ю строку СерверФТП.Получить(Файлtxt.Имя,ВремФайл); А 1й файл считывается нормально, дальше происходит, то что нужно...

Текст ошибки:
{Обработка.ЧтениеФайла.Форма.Форма.Форма(365)}: Ошибка при вызове метода контекста (Получить)
                  СерверФТП.Получить(Файлtxt.Имя,ВремФайл);
по причине:
Ошибка работы с Интернет:  ftp://***.***.***.***:****FTP: couldn't retrieve (RETR failed) the specified file

********************************************************
1 Если ФайлыTXT.Количество() > 0 Тогда
2 Чтение = Новый ЧтениеТекста;
3 Для Каждого Файлtxt Из ФайлыTXT Цикл
4 Запрос = Новый Запрос;
5 Запрос.Текст = "ВЫБРАТЬ
6                | ДокументыСозданий_ИзмененийСрезПоследних.НомерДокумента
7                |ИЗ
8                | РегистрСведений.ДокументыСозданий_Изменений.СрезПоследних(&Дата, НомерДокумента = &НомерДокумента) КАК ДокументыСозданий_ИзмененийСрезПоследних";
9 Запрос.УстановитьПараметр("Дата",ТекущаяДата());
10 Запрос.УстановитьПараметр("НомерДокумента",Файлtxt.ИмяБезРасширения);
11 Результат = Запрос.Выполнить().Выбрать();
12 Если НЕ Результат.Количество() > 0 Тогда
13 ВремФайл = ПолучитьИмяВременногоФайла("txt");
14 СерверФТП.Получить(Файлtxt.Имя,ВремФайл);
15    Чтение.Открыть(ВремФайл);
16 Массив = Новый Массив;
17 Массив.Добавить(Файлtxt.ИмяБезРасширения);
18 СтрокаТекст = Чтение.ПрочитатьСтроку();
19 Пока СтрокаТекст <> Неопределено Цикл
20 Массив.Добавить(СтрокаТекст);
21 СтрокаТекст = Чтение.ПрочитатьСтроку();
22 КонецЦикла;
23 Иначе
24 Массив = 0;
25 КонецЕсли;
26 СерверФТП.УстановитьТекущийКаталог(КаталогRS+"/in");
27 ТекстДок = Новый ТекстовыйДокумент;
28 Файл = ПолучитьИмяВременногоФайла("txt");
29 ТекстДок.Записать(Файл);
30 СерверФТП.Записать(Файл,Файлtxt.ИмяБезРасширения+"+"+".txt");
31 КонецЦикла;
32 КонецЕсли;
********************************************************

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
СерверФТП.Записать(Файл,Файлtxt.ИмяБезРасширения+"+"+".txt");
Чтение.Закрыть();
КонецЦикла;
Добавлено: 17 Июл 2013, 15:17

Возможно у тебя соединение рвется с фтп по таймауту или из за связи
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Последний раз редактировалось: Dethmontt; 17 Июл 2013, 15:17. Причина: Объединение сообщений

Оффлайн Soulidium

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2012-11-04
  • Сайт: 
  • Профессия: Ученик 1С
Не получается :dfbsdfbsdf: Так же ошибка...
Добавлено: 17 Июл 2013, 15:19

СерверФТП.Записать(Файл,Файлtxt.ИмяБезРасширения+"+"+".txt");
Чтение.Закрыть();
КонецЦикла;
Добавлено: 17 Июл 2013, 15:17

Возможно у тебя соединение рвется с фтп по таймауту или из за связи
Попробую задержку поставить в цикле...
Добавлено: 17 Июл 2013, 15:22

Попробую задержку поставить в цикле...
И с задержкой не получается :fdbsdfbsd:

Добавлено: 17 Июл 2013, 15:24

Возможно у тебя соединение рвется с фтп по таймауту или из за связи
Так к слову, ftp у меня компьютере.


Добавлено: 17 Июл 2013, 15:36

Есть идея загрузить файл на Диск и потом уже с Диска, при помощи ТекстовыйДокумент, считывать файл построчно в массив. Но идея с засорением диска не очень нравится... 

Последний раз редактировалось: Soulidium; 17 Июл 2013, 15:36. Причина: Объединение сообщений


Теги:
 

Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9216
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Ошибка КД "Файла не существует"

Автор arkanruРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1211
Последний ответ 31 Авг 2015, 11:19
от arkanru
Cоздание Excel afqkf по оформлению из другого файла Excel

Автор bugsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2841
Последний ответ 23 Авг 2011, 14:26
от bugs
Получить полный HTTP код с сервера, Именно полный!

Автор Shining ninjaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2153
Последний ответ 12 Авг 2011, 15:23
от Shining ninja
Задание типа файла при сохранении таб.документа "Сохранить копию" во внешний фа

Автор Marta_LiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4313
Последний ответ 22 Дек 2011, 15:34
от sergeevds

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 235
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal