Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как прописать код?  (Прочитано 2198 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Евгений27

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-07-12
  • Сайт: 
  • Профессия: Программист 1С
Теперь когда открывается сама форма ,Юридические данные присутствуют, после того как нажмешь и отожмешь флажок данные юр.лицо убираются .Как сделать так, что когда нажимаешь кнопку создать контрагента были только данные физ.лицо,а если планирует покупать как юр.лицо, то нажал сам флажок и данные появились ?

Сам код прописан вот так

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Элементы.НаименованиеОрганизации.Видимость = Объект.ЮрИлиФиз;
    Элементы.ГенеральныйДиректор.Видимость = Объект.ЮрИлиФиз;
    Элементы.ЮридическийАдрес.Видимость = Объект.ЮрИлиФиз;
    Элементы.ФактическийАдрес.Видимость = Объект.ЮрИлиФиз;
    Элементы.КонтактныйТелефон.Видимость = Объект.ЮрИлиФиз;
    Элементы.ЭлектроннаяПочтаОрганизации.Видимость = Объект.ЮрИлиФиз;
    Элементы.ОКПО.Видимость = Объект.ЮрИлиФиз;
    Элементы.ИНН.Видимость = Объект.ЮрИлиФиз;
    Элементы.КПП.Видимость = Объект.ЮрИлиФиз;
    Элементы.ОГРН.Видимость = Объект.ЮрИлиФиз;
    Элементы.КСчет.Видимость = Объект.ЮрИлиФиз;
    Элементы.РСчет.Видимость = Объект.ЮрИлиФиз;
КонецПроцедуры
Процедура ЮрИлиФизПриИзменении(Элемент)
    Элементы.НаименованиеОрганизации.Видимость = Объект.ЮрИлиФиз;
    Элементы.ГенеральныйДиректор.Видимость = Объект.ЮрИлиФиз;
    Элементы.ЮридическийАдрес.Видимость = Объект.ЮрИлиФиз;
    Элементы.ФактическийАдрес.Видимость = Объект.ЮрИлиФиз;
    Элементы.КонтактныйТелефон.Видимость = Объект.ЮрИлиФиз;
    Элементы.ЭлектроннаяПочтаОрганизации.Видимость = Объект.ЮрИлиФиз;
    Элементы.ОКПО.Видимость = Объект.ЮрИлиФиз;
    Элементы.ИНН.Видимость = Объект.ЮрИлиФиз;
    Элементы.КПП.Видимость = Объект.ЮрИлиФиз;
    Элементы.ОГРН.Видимость = Объект.ЮрИлиФиз;
    Элементы.КСчет.Видимость = Объект.ЮрИлиФиз;
    Элементы.РСчет.Видимость = Объект.ЮрИлиФиз;
   КонецПроцедуры


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
а ЮрИлиФиз какой тип данных?
Добавлено: 12 Июл 2013, 20:39

&НаКлиенте
Процедура ПриОткрытии(Отказ)
УправлениеВидимостью();
КонецПроцедуры

&НаКлиенте
Процедура ЮрИлиФизПриИзменении(Элемент)
УправлениеВидимостью();
КонецПроцедуры

&НаКлиенте
Процедура УправлениеВидимостью()
Если Объект.ЮрФизЛицо = ПредопределенноеЗначение("Перечисление.ЮрФизЛицо.ЮрЛицо") Тогда
Элементы.НаименованиеОрганизации.Видимость = Истина;
//и т.д.
ИначеЕсли Объект.ЮрФизЛицо = ПредопределенноеЗначение("Перечисление.ЮрФизЛицо.ФизЛицо") Тогда
Элементы.НаименованиеОрганизации.Видимость = Ложь;
//и т.д.
КонецЕсли;
КонецПроцедуры

Последний раз редактировалось: Besart; 12 Июл 2013, 20:39. Причина: Объединение сообщений


Теги:
 

Как прописать условие по документу регистратору при запросе из регистра.

Автор Александр_ЯрославльРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 1800
Последний ответ 14 Сен 2016, 13:07
от SGIRG
Функция в общем модуле: как прописать и как обратиться?

Автор ConstantusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1282
Последний ответ 04 Сен 2015, 13:45
от ferrari314
Помогите прописать простую задачу

Автор ЭльшадРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 17
Просмотров: 2467
Последний ответ 18 Янв 2015, 17:33
от SitnovaMarina
как прописать отбор в обработке обмена

Автор RaideresРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 785
Последний ответ 23 Май 2016, 11:14
от Rasty
Прописать доверенность в ТОРГ-12

Автор maksa2005Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6355
Последний ответ 26 Фев 2013, 18:17
от Yura063

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 231
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal