Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 19:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Чат  (Прочитано 2986 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Михалыч94

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-07-04
  • Сайт: 
  • Профессия: Ученик 1С
Чат
« Первое сообщение: 05 Июл 2013, 07:43 »
Скажите, пожалуйста. Как сделать так чтобы мы выбирали человека в поле выбора, писали сообщение в поле ввода и когда выводили его в поле списка было видно какой именно человек написал.


Процедура КнопкаВыполнитьНажатие(Кнопка)
   // Вставить содержимое обработчика.
КонецПроцедуры

Процедура Кнопка1Нажатие(Элемент)
   Перем ИмяКлиента;
   ИмяКлиента="";
   Сообщить("Вошёл в чат");
КонецПроцедуры 
Процедура Кнопка2Нажатие(Элемент)
   Перем ИмяАдресата;
   ИмяАдресата="";
   ИмяАдресата="Сева";
   Сообщить("Клиент присоединился");
КонецПроцедуры
Процедура Кнопка3Нажатие(Элемент)
Перем Сообщ;
//Сообщ="";
//Сообщ=ПолеВвода2;
//Сообщ.ЗагрузитьЗначение(ПолеВвода2.ЗагрузитьЗначения());

ПолеСписка1.Добавить(ПолеВвода2);
КонецПроцедуры                               
   
СписокВыбора = Новый СписокЗначений;
сп = Новый СписокЗначений();
сп.Добавить("Катя");
сп.Добавить("Володя");
сп.Добавить("Оля");
сп.Добавить("Сева");
ЭлементыФормы.ПолеВыбора1.СписокВыбора = сп;
список = Новый СписокЗначений();
список.Добавить("77.73.67.210");
ЭлементыФормы.ПолеВыбора3.СписокВыбора = список;
ПолеВвода2 = Новый СписокЗначений;
 


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Re: Чат
« Ответ #1: 05 Июл 2013, 08:11 »
Создайте регистр накопления! Записывайте туда сообщения! А у получателя будет выборка всех сообщений по пользователю.
Помогли, отблагодари!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
71 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 352
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal