Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 03:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Поиск по коду справочника по первому символу  (Прочитано 5990 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн spapin

  • Стас
  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-20
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день. Подскажите мне необходимо найти по коду справочника первый символ. Например все элементы справочника, у которых код начинается с "F000..."


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Берете код, если числовой переводите в строку и под условие
Если Найти(Строка(Код),ТоЧтоНадоНайти) = 1 Тогда
    //Тут все что дальше надо, если найдет!
КонецЕсли;
Это все в цикл по всем элементам.
Помогли, отблагодари!

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Как то так:

"ВЫБРАТЬ
| Номенклатура.Ссылка
|ИЗ
| Справочник.Номенклатура КАК Номенклатура
|ГДЕ
| Номенклатура.Код ПОДОБНО ""F000%"""

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
ДА! Совсем забыл про ПОДОБНО!!! )))
Помогли, отблагодари!

Оффлайн spapin

  • Стас
  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-20
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо, сделал так:
ВыборкаЯчеек = Справочники.МестаХранения.Выбрать();
Пока ВыборкаЯчеек.Следующий() Цикл
Объект = ВыборкаЯчеек.ПолучитьОбъект();
код = ВыборкаЯчеек.Код;
   Если Лев(код,1) = ("F") Тогда
Сообщить("Нашёл!!" + код);
Объект.УстановитьПометкуУдаления(Истина,Ложь);
   КонецЕсли;
КонецЦикла;

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Если База на Скуле то лучше воспользуйся советом MuI_I_Ika!
Помогли, отблагодари!

Оффлайн spapin

  • Стас
  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-20
  • Сайт: 
  • Профессия: Ученик 1С
Запрос меньше ресурсов будет потреблять или быстрее будет выполняться?

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Помогли, отблагодари!

Оффлайн spapin

  • Стас
  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-20
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите еще момент как удалить запись регистра сведений(строку)?
Выбсклад = Справочники.Склады.НайтиПоКоду("000000004");
Запрос = Новый Запрос( "ВЫБРАТЬ
                       | МестаХраненияНоменклатуры.Склад.Ссылка,
                       | МестаХраненияНоменклатуры.МестоХранения КАК МестоХранения
                       |ИЗ
                       | РегистрСведений.МестаХраненияНоменклатуры КАК МестаХраненияНоменклатуры
                       |ГДЕ
                       | МестаХраненияНоменклатуры.Склад = &выбСклад");
  Запрос.УстановитьПараметр("выбСклад", выбСклад);
 
  выборка = Запрос.Выполнить().Выбрать();
 
  Пока выборка.Следующий() Цикл
  //сообщить("" + выборка.СкладСсылка);
  Объект = выборка.МестоХранения.получитьОбъект();
  Попытка                           
  Объект.Удалить();
  Исключение
  КонецПопытки;
КонецЦикла; 


Тут я удалил просто место хранения :(
Добавлено: 04 Июл 2013, 18:56

Вроде так
Выбсклад = Справочники.Склады.НайтиПоКоду("000000004");
Запрос = Новый Запрос( "ВЫБРАТЬ
                       | МестаХраненияНоменклатуры.Склад.Ссылка,
                       | МестаХраненияНоменклатуры.МестоХранения КАК МестоХранения
                       |ИЗ
                       | РегистрСведений.МестаХраненияНоменклатуры КАК МестаХраненияНоменклатуры
                       |ГДЕ
                       | МестаХраненияНоменклатуры.Склад = &выбСклад");
  Запрос.УстановитьПараметр("выбСклад", выбСклад);
 
  выборка = Запрос.Выполнить().Выбрать();
 
  Пока выборка.Следующий() Цикл
НаборЗаписей = РегистрыСведений.МестаХраненияНоменклатуры.СоздатьНаборЗаписей();
        НаборЗаписей.Отбор.Склад.Установить(выбСклад);
   
        НаборЗаписей.Очистить();
        НаборЗаписей.Записать();
КонецЦикла; 

Последний раз редактировалось: spapin; 04 Июл 2013, 18:56. Причина: Объединение сообщений

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Подскажите еще момент как удалить запись регистра сведений(строку)?
Выбсклад = Справочники.Склады.НайтиПоКоду("000000004");
Запрос = Новый Запрос( "ВЫБРАТЬ
                       | МестаХраненияНоменклатуры.Склад.Ссылка,
                       | МестаХраненияНоменклатуры.МестоХранения КАК МестоХранения
                       |ИЗ
                       | РегистрСведений.МестаХраненияНоменклатуры КАК МестаХраненияНоменклатуры
                       |ГДЕ
                       | МестаХраненияНоменклатуры.Склад = &выбСклад");
  Запрос.УстановитьПараметр("выбСклад", выбСклад);
 
  выборка = Запрос.Выполнить().Выбрать();
 
  Пока выборка.Следующий() Цикл
  //сообщить("" + выборка.СкладСсылка);
  Объект = выборка.МестоХранения.получитьОбъект();
  Попытка                           
  Объект.Удалить();
  Исключение
  КонецПопытки;
КонецЦикла; 


Тут я удалил просто место хранения :(
Добавлено: 04 Июл 2013, 18:56

Вроде так
Выбсклад = Справочники.Склады.НайтиПоКоду("000000004");
Запрос = Новый Запрос( "ВЫБРАТЬ
                       | МестаХраненияНоменклатуры.Склад.Ссылка,
                       | МестаХраненияНоменклатуры.МестоХранения КАК МестоХранения
                       |ИЗ
                       | РегистрСведений.МестаХраненияНоменклатуры КАК МестаХраненияНоменклатуры
                       |ГДЕ
                       | МестаХраненияНоменклатуры.Склад = &выбСклад");
  Запрос.УстановитьПараметр("выбСклад", выбСклад);
 
  выборка = Запрос.Выполнить().Выбрать();
 
  Пока выборка.Следующий() Цикл
НаборЗаписей = РегистрыСведений.МестаХраненияНоменклатуры.СоздатьНаборЗаписей();
        НаборЗаписей.Отбор.Склад.Установить(выбСклад);
   
        НаборЗаписей.Очистить();
        НаборЗаписей.Записать();
КонецЦикла; 

НаборЗаписей.Очистить();

Чего чистишь то?


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6501
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4203
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 639
Последний ответ 10 Май 2017, 20:44
от ilnur75
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2048
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 272
Последний ответ 12 Окт 2017, 14:02
от wise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 122
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal