Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Май 2018, 15:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сравнение количества материала  (Прочитано 3615 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vogde

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-24
  • Сайт: 
  • Профессия: Ученик 1С
Всем хорошего дня! В очередной раз я прошу вашей помощи. Суть вопроса такова: В документе Оказание Услуги при заполнении поля Количество необходимо создать программно сравнение количества материала на складе и введенного количества.

Я создал в общем модуле функцию по выборке остатков материала из регистра накопления, (хотел из отчета " Материал" но что не получилось). Вот она:
Код: e1cv8 [Выделить]

 Функция КоличествоМатериала(АктуальнаяДата,ЭлементНоменклатуры)Экспорт
Отбор = Новый Структура("Номенклатура",ЭлементНоменклатуры);
ЗначениеРесурсов = РегистрыНакопления.ОстаткиМатериалов.Остатки(АктуальнаяДата,Отбор);
Возврат ЗначениеРесурсов.Количество;
 КонецФункции

И в модуле формы обработку выбора:
Код: e1cv8 [Выделить]

Процедура ПереченьНоменклатурыКоличествоОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
Если ВыбранноеЗначение > РаботаСОтчетами.КоличествоМатериала(Объект.Дата) Тогда
Предупреждение("На складе не хватает материала");
Возврат;
КонецЕсли;
КонецПроцедуры

 Но нужных мне результатов не достиг. Подскажите где ошибки? И правильный ли алгоритм действий?


Оффлайн Soulidium

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2012-11-04
  • Сайт: 
  • Профессия: Ученик 1С
При вызове передаётся 1 параметр, передай элемент номенклатуры.

Оффлайн Vogde

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-24
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите как это правильно сделать. Еще не совсем понимаю как строится код

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Процедура ПереченьНоменклатурыКоличествоОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    Если ВыбранноеЗначение > РаботаСОтчетами.КоличествоМатериала(Объект.Дата, ЭлементыФормы.ТабЧасть.ТекущиеДанные.Номенклатура) Тогда
        Предупреждение("На складе не хватает материала");
        Возврат;
    КонецЕсли;
КонецПроцедуры

На вашем месте я бы выбрал количество из регистра накопления запросом, а не использовал объектную модель

Оффлайн Soulidium

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2012-11-04
  • Сайт: 
  • Профессия: Ученик 1С
Код: e1cv8 [Выделить]

 Функция КоличествоМатериала(АктуальнаяДата,ЭлементНоменклатуры)Экспорт
Отбор = Новый Структура("Номенклатура",ЭлементНоменклатуры);
ЗначениеРесурсов = РегистрыНакопления.ОстаткиМатериалов.Остатки(АктуальнаяДата,Отбор);
Возврат ЗначениеРесурсов.Количество;
 КонецФункции

Код: e1cv8 [Выделить]

Процедура ПереченьНоменклатурыКоличествоОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
        //Вот здесь при вызове функции вы передаёте только дату, передайте ЭлементНоменклатуры который вы добавляете в отбор в функцию выше
Если ВыбранноеЗначение > РаботаСОтчетами.КоличествоМатериала(Объект.Дата)  Тогда
Предупреждение("На складе не хватает материала");
Возврат;
КонецЕсли;
КонецПроцедуры


Оффлайн Vogde

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-24
  • Сайт: 
  • Профессия: Ученик 1С
Всем большое спасибо за советы и помощь


Теги:
 

Нюансы применения ПСН при условии увеличения количества транспортных средств в отношении транспортных услуг

Автор newsРаздел Новости

Ответов: 0
Просмотров: 675
Последний ответ 30 Мар 2015, 12:28
от news
Почему сравнение на пустую строку разное для равно и не равно?

Автор mankingРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2133
Последний ответ 06 Ноя 2015, 09:02
от Vladimir_Sh
Сумма ЕНВД зависит от количества отработанных дней только в квартале, когда компания стала на учет

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1233
Последний ответ 11 Ноя 2014, 12:33
от news
Управляемые формы, Розница 2.2. Добавление общего количества товара (шт.) по документу. Реально ли?

Автор dmitry_krРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 106
Последний ответ 16 Май 2018, 04:25
от AIFrame
Подсчет количества ремонта (сколько строк в табличной части документа)

Автор GoldMenРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8925
Последний ответ 18 Сен 2012, 10:06
от GoldMen

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Сравнение товарных остатков между двумя базами

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
oleg-x
65 Сообщений
alex0402
62 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
38 Сообщений
KOI8-R
33 Сообщений
buketov.av buketov.av
28 Сообщений
Alter
21 Сообщений
Анюта17
19 Сообщений
alexandr_ll
19 Сообщений

* Кто онлайн

  • Точка Гостей: 313
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal