Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 16:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выбор из ТЧ справочника в поле ТЧ документа  (Прочитано 3882 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rnshar

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Начинающий просит о помощи...
Путем проб и ошибок написал код заполняющий поле Тема ТЧ документа.

&НаКлиенте
Процедура ПрограммаТемаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
   
   СтандартнаяОбработка = Ложь;
   //Список=Элемент.СписокВыбора;
   ТС=Элементы.Программа.ТекущиеДанные;
   сп= МояОбработкаВыбораГруппы(ТС.ТГруппа);           
    ТС.Тема=ВыбратьИзСписка(Сп,Элементы.ПрограммаТема);
КонецПроцедуры                                             
 
&НаСервереБезКонтекста
Функция МояОбработкаВыбораГруппы(ИскомыйЭлемент)
   Список= Новый СписокЗначений;
   ук=Справочники.ПрограммаОбучения.НайтиПоНаименованию(ИскомыйЭлемент.Программа);
   Для Каждого ТекущаяСтрока Из Ук.ТЧПрограммаОбучения Цикл
      Список.Добавить(ТекущаяСтрока.ТемаЗанятий);
   КонецЦикла; 
   Возврат Список;
КонецФункции

Все работает - выбирает и запоминает в поле, однако только если в свойствах реквизита ТЧ Тема указать строка -80(длина реквизита справочника). При попытке записать реквизит Тема как СправочникСсылка.ТемыЗанятий, чтобы хранить не само значение справочника, а ссылку на него- в поле не сохраняется эта ссылка.
Желание не праздное, ведь если в справочнике изменить значение реквизита в ТЧ документа автоматом оно не исправится...


Оффлайн wise

  • ****
  • Сообщений: 430
  • РЕПУТАЦИЯ: 58
  • КПД: 13%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
в поле не сохраняется эта ссылка.
ЧТО говорит ОТЛАДЧИК ?
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Rnshar

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Отладчик молчит, даже не ругается - а поле остается незаполненным, хотя список показывает правильно и дает из него выбрать...
А может список значений заполняется не ссылками а значениями?
Добавлено: 01 Июл 2013, 10:04

Попробовал изменить строчку       
   Список.Добавить(ТекущаяСтрока.ТемаЗанятий);   
на
   Список.Добавить(ТекущаяСтрока.ТемаЗанятий.Ссылка);

результат тот же

Оффлайн wise

  • ****
  • Сообщений: 430
  • РЕПУТАЦИЯ: 58
  • КПД: 13%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(2)ТипЗнч(ТС.Тема) = ??
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Rnshar

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-20
  • Сайт: 
  • Профессия: Ученик 1С
В конфигурации на закладке данные реквизит ТЧ Тема - СправочникСсылка.ТемыЗанятий
в представлении поля на форме - Объект.Программа.Тема
команда    Сообщить(ТипЗнч(ТС.Тема));
выдает Темы Занятий - Синоним Наименования Справочника ТемыЗанятий...

Оффлайн wise

  • ****
  • Сообщений: 430
  • РЕПУТАЦИЯ: 58
  • КПД: 13%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
ВыбратьИзСписка
Возвращаемое значение:

Тип: ЭлементСпискаЗначений; Неопределено.
Выбранный элемент списка или Неопределено, если пользователь отказался от выбора.
/*************************************************/
Получай значение элемента!

вместо{ТС.Тема=ВыбратьИзСписка(Сп,Элементы.ПрограммаТема);}
надо {ТекТема = ВыбратьИзСписка(Сп,Элементы.ПрограммаТема);
        Если ТекТема <> Неопределено Тогда
            ТС.Тема = ТекТема.Значение;
        КонецЕсли;}
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Rnshar

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Респект! и уважуха!! Работает!!!

Оффлайн wise

  • ****
  • Сообщений: 430
  • РЕПУТАЦИЯ: 58
  • КПД: 13%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4586
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 16207
Последний ответ 16 Авг 2012, 12:07
от Will
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7862
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4919
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1664
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
22 Сообщений
alexandr_ll
17 Сообщений
andron81_81
17 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal