Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 01:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Макет с пересекающимися ячейками  (Прочитано 3814 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
Необходима печатная форма с колонками.номер пункт положения (их определенное количество и они выводятся построчно) и потом в зависимости от количества лет колонка год (для каждого года периода)  и в каждом году еще разделение по кварталам года.  Как это можно сделать?


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
предполагаю что СКД вам в этом сильно поможет, создайте СКД на основе объекта в качестве которого передавайте таблицу значений с вашими данными, а в СКД уже настроите макет так как вам нужно

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
Если не сложно можете скинуть ссылку где можно прочитать подробнее

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
"Объектная" Схема компоновки данных в 1С 8.х погуглите може еще найдете, а так же бесплатный курс по СКД вы можете скачать здесь Бесплатные материалы по 1С

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
спасибо
Добавлено: 01 Июл 2013, 16:38

ТабДокумент = Новый ТабличныйДокумент;
   ТабДокумент.Очистить();
   ТабДокумент.ИмяПараметровПечати = "ПланируемыеСведенияДЛЯНПО";
   ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;

   Макет = ПолучитьМакет("ПотребностьСредств1");      
   
   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   
   Если ГодОкончания <> "" Тогда
      КоличествоЛет = ГодОкончания - ГодНачала;
   Иначе
      КоличествоЛет = 0;
   КонецЕсли;   
   
   ОбластьЗаголовок.Параметры.ДочернееОбщество = ЭтотОбъект.Организация;
   ОбластьЗаголовок.Параметры.Период = Строка(Формат(ГодНачала,"ЧГ=0")) + " - " + Строка(Формат(ГодОкончания,"ЧГ=0"));
   ТабДокумент.Вывести(ОбластьЗаголовок);
   
   ОбластьШапка = Макет.ПолучитьОбласть("Шапка|Данные");
   ТабДокумент.Вывести(ОбластьШапка);
   
   Индекс = 0;
   Пока КоличествоЛет > Индекс или КоличествоЛет = Индекс Цикл
      //ОбластьШапка = Макет.ПолучитьОбласть("Шапка|Данные");
      //ТабДокумент.Вывести(ОбластьШапка);
         
      ОбластьШапкаДанные    = Макет.ПолучитьОбласть("Шапка|ПланируемыеДанные");
      ОбластьСтрокаДанные = Макет.ПолучитьОбласть("Строка|Данные");
      ОбластьСтрока       = Макет.ПолучитьОбласть("Строка|ПланируемыеДанные");

      ОбластьШапкаДанные.Параметры.ПланирГод_1 = Строка(Формат(Число(ГодНачала)+Индекс,"ЧГ=0")) + " год";
      ТабДокумент.Присоединить(ОбластьШапкаДанные);

      Отбор = Новый Структура();
      Отбор.Вставить("Год", Строка(Формат(Число(ГодНачала)+Индекс,"ЧГ=0")));
      МассивДокументов = Потребность.НайтиСтроки(Отбор);
      Если  МассивДокументов.Количество() > 0 Тогда
         Для Каждого СтрПотребность из МассивДокументов Цикл             
            СтрокаПункта = СоответствиеСписокФорм.Получить(СтрПотребность.ПунктПоложения);
            Если СтрПотребность.Квартал = "1" Тогда
               ...(заполняем параметры)
            КонецЕсли;   
            
         КонецЦикла;
         //ТабДокумент.Вывести(ОбластьСтрокаДанные);
         //ТабДокумент.Присоединить(ОбластьСтрока);
      КонецЕсли;
      //ТабДокумент.Вывести(ОбластьШапка);
      //ТабДокумент.Присоединить(ОбластьШапкаДанные);

      ТабДокумент.Вывести(ОбластьСтрокаДанные);
      ТабДокумент.Присоединить(ОбластьСтрока);

      Индекс = Индекс + 1;
   КонецЦикла;
   

Добавлено: 01 Июл 2013, 16:39

область Шапка|Планируемые данные должна выводиться каждый раз слева новым столбцом (и соответственно строки), но не как не получается((( может кто подскажет ошибку?

Последний раз редактировалось: Tyshkan; 01 Июл 2013, 16:39. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 184
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal