Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 09:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выборочный запрет на правку ячейки в документе.  (Прочитано 6336 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн АЦЕ

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
  • Профессия: ГлавБух
1с платформа 8.2.  В документе реализация товаров и услуг на закладке дополнительно есть поле "ответственный".  Подскажите, пожалуйста, как сделать это поле для всех пользователей только для чтения, а для группы администратор разрешено править. На сегодня эта ячейка сделана только для чтения для всех групп.


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Процедура ПриОткрытии()
ЭлементыФормы.Ответственный.Доступность = РольДоступна("ПолныеПрава");
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн АЦЕ

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
  • Профессия: ГлавБух
Подставляла в разные места процедуры, все равно только чтение.

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Подскажите, пожалуйста, как сделать это поле для всех пользователей только для чтения, а для группы администратор разрешено править
интересно, если ответственный выбирается из справочника физ лица или сотрудники, то как он будет выбираться при создании документа, необходимо дополнить код, что если документ проведен только в этом случае сделать это поле для всех пользователей только для чтения.

&НаКлиенте
Процедура ПриОткрытии(Отказ)
Если ПроверитьПроведен() Тогда

//сюда вставьет код предложенный Dethmontt

КонецЕсли;
КонецПроцедуры


&НаСервере
Функция ПроверитьПроведен()
ДокОбъект = ДанныеФормыВЗначение(Объект, Тип("ДокументОбъект.ИмяВашегоДокумента"));
Возврат ДокОбъект.Проведен;
КонецФункции // ПроверитьПроведен()

Оффлайн АЦЕ

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
  • Профессия: ГлавБух
Дело в том, что поле ответственный по умолчанию ссылается на того пользователя, под чьим сеансом создается документ. Позднее этот пользователь меняет себя на другого ответственного, но в истории все равно остается тот, под чьим сеансом был создан документ. И получается, что все отчеты по реализации видят того, кто обозначен в документе, а история показывает другого пользователя. Поэтому пришлось сделать в конфигураторе поле ответственный только на чтение. Но иногда требуется поменять это поле принудительно, поэтому администратор должен это право иметь.

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Процедура ПриОткрытии()
ЭлементыФормы.Ответственный.ТолькоПросмотр = НЕ РольДоступна("ПолныеПрава");
КонецПроцедуры

Оффлайн АЦЕ

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
  • Профессия: ГлавБух
У меня получилось проще: я зашла в конфигураторе в раздел "роли" и всем группам, кроме администратора в документе реализация, ячейке ответственный поставила "только просмотр", а администратору оставила право редактирования. Вроде сработало. Теперь только нужно проверить пользователей, кто в какой группе сидит.

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Лучше купите себе программиста, чем вот так вот ограничивать права на реквизиты документа ...

Оффлайн АЦЕ

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
  • Профессия: ГлавБух
У нас их было пять. :) И мы пришли к выводу: если хочешь сделать что-то хорошо, сделай это сам.

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
У нас их было пять. :) И мы пришли к выводу: если хочешь сделать что-то хорошо, сделай это сам.

за 20к рублей были? )

Нормальный программист стоит дорого, а работы раз в 10 уменьшает, если не больше.


Теги:
 

заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3589
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
Заполнение табличной части при выборе реквизита другой табличной части в документе.

Автор Vlad-93Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 310
Последний ответ 25 Окт 2017, 14:15
от Vlad-93
УТ 11.В документе "Заявка на расходование денежных средств" нет кнопки "Печать"!

Автор Valery3103Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3755
Последний ответ 29 Июн 2012, 18:37
от LexaK
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2028
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Не активно поле ПОЛУЧАТЕЛЬ в документе "выдача наличных" и в "кассовых документах"

Автор Masik777Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 913
Последний ответ 31 Авг 2016, 16:02
от Masik777

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 656
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal