Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Май 2018, 19:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение ТЧ  (Прочитано 5199 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlenkaInt

  • ****
  • Сообщений: 266
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-21
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте. Есть внешняя обработка по заполнению табличной части. При ее вызове должно определенным способом меняться поле Содержание в документе РТиУ табличной части Услуги. Не знаю как к этому полю обратиться. Точка останова не срабатывает, а без отладчика у меня не получается.
У меня сейчас вот как то так:
Процедура Инициализировать(мОбъект, ИмяТабличнойЧасти, ТабличноеПолеОбъекта) Экспорт
    Содержание =  ТабличноеПолеОбъекта.ТекущаяСтрока[Содержание];   
    Для каждого Стр из мОбъект[ИмяТабличнойЧасти] Цикл
        Стр[Содержание] = "Тест";
    КонецЦикла;       
КонецПроцедуры

Программа ругается - Заполнение ТЧ не произведено!
Получение элемента по индексу для значения не определено


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Заполнение ТЧ
« Ответ #1: 25 Июн 2013, 22:17 »
Это убери
 Содержание =  ТабличноеПолеОбъекта.ТекущаяСтрока[Содержание];
Добавлено: 25 Июн 2013, 22:18

Процедура Инициализировать(мОбъект, ИмяТабличнойЧасти, ТабличноеПолеОбъекта) Экспорт
    Для каждого Стр из мОбъект[ИмяТабличнойЧасти] Цикл
        Стр["Содержание"] = "Тест";
    КонецЦикла;       
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн AlenkaInt

  • ****
  • Сообщений: 266
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-21
  • Сайт: 
  • Профессия: Программист 1С
Re: Заполнение ТЧ
« Ответ #2: 25 Июн 2013, 22:31 »
Спасибо! А как можно во внешней печатной форме пользоваться отладчиком?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Заполнение ТЧ
« Ответ #3: 25 Июн 2013, 22:40 »
Сделать ей форму для отладки и запускать с формы обработки
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 8590
Последний ответ 16 Авг 2012, 21:50
от Will
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2822
Последний ответ 30 Ноя 2011, 07:10
от has
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 17218
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4770
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1185
Последний ответ 10 Май 2017, 20:44
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
153 Сообщений
oleg-x
69 Сообщений
alex0402
65 Сообщений
AIFrame AIFrame
55 Сообщений
wise wise
39 Сообщений
buketov.av buketov.av
36 Сообщений
KOI8-R
34 Сообщений
ilyay ilyay
29 Сообщений
Alter
27 Сообщений
trialex3
25 Сообщений

* Кто онлайн

  • Точка Гостей: 312
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal