Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 12:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выбор поля ТЧ Документа из ТЧ Справочника  (Прочитано 2726 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rnshar

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Пробую писать на Обучающей программе...
В шапке Формы Документа, поля Программа выбирается элемент справочника ПрограммаОбучения. В поле ТемыПрограммы ТЧ - Расписание необходимо организовать выбор из списка ТЧ соответствующей выбранному элементу
Написал код
 
&НаКлиенте
Процедура РасписаниеТемыПрограммыНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
   СтандартнаяОбработка = Ложь;
   СписокВыбора=МояОбработкаВыбора(Элемент.СписокВыбора,Объект.Программа);
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция МояОбработкаВыбора(Список,ИскомыйЭлемент)
   Для Каждого ТекущаяСтрока Из ИскомыйЭлемент.ТЧПрограммаОбучения Цикл
      Список.Добавить(ТекущаяСтрока.ТемаЗанятий);
   КонецЦикла; 
   Возврат Список;
КонецФункции

СписокВыбора заполняется (проверял в обработчике), но на форме открывается пустой список. Что не так?


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6642
  • РЕПУТАЦИЯ: 783
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
СтандартнаяОбработка = Ложь;

Может из-за вот этого. Зачем отменять стандартную обработку.

Оффлайн Rnshar

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Увы, не помогает!

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6642
  • РЕПУТАЦИЯ: 783
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А галочка в полу выбор из списка стоит?

Оффлайн Rnshar

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Стоит!
Я тут переписал код

&НаКлиенте
Процедура РасписаниеТемыПрограммыНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
   СтандартнаяОбработка = Ложь;
   Список=Элемент.СписокВыбора;
   сп= МояОбработкаВыбора(Список,Объект.Программа);
     РеквизитТемыПрограммы=ВыбратьИзСписка(Сп,Элементы.РасписаниеТемыПрограммы);
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция МояОбработкаВыбора(Список,ИскомыйЭлемент)
   Для Каждого ТекущаяСтрока Из ИскомыйЭлемент.ТЧПрограммаОбучения Цикл
      Список.Добавить(ТекущаяСтрока.ТемаЗанятий);
   КонецЦикла; 
   Возврат Список;
КонецФункции
Теперь список выводит, но после клика мышью - выбора, Значение не запоминается в строке!!! На шаг ближе, но ...
Добавлено: 25 Июн 2013, 18:10

ВООООООООООТ неуч! Осталось выбранное значение присвоить полю!

Последний раз редактировалось: Rnshar; 25 Июн 2013, 18:10. Причина: Объединение сообщений


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4855
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 17220
Последний ответ 16 Авг 2012, 12:07
от Will
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8273
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5520
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1911
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
71 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
buketov.av buketov.av
41 Сообщений
wise wise
39 Сообщений
KOI8-R
34 Сообщений
ilyay ilyay
29 Сообщений
Alter
28 Сообщений
trialex3
25 Сообщений

* Кто онлайн

  • Точка Гостей: 807
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal