Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 06:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выбор поля ТЧ Документа из ТЧ Справочника  (Прочитано 2480 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rnshar

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Пробую писать на Обучающей программе...
В шапке Формы Документа, поля Программа выбирается элемент справочника ПрограммаОбучения. В поле ТемыПрограммы ТЧ - Расписание необходимо организовать выбор из списка ТЧ соответствующей выбранному элементу
Написал код
 
&НаКлиенте
Процедура РасписаниеТемыПрограммыНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
   СтандартнаяОбработка = Ложь;
   СписокВыбора=МояОбработкаВыбора(Элемент.СписокВыбора,Объект.Программа);
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция МояОбработкаВыбора(Список,ИскомыйЭлемент)
   Для Каждого ТекущаяСтрока Из ИскомыйЭлемент.ТЧПрограммаОбучения Цикл
      Список.Добавить(ТекущаяСтрока.ТемаЗанятий);
   КонецЦикла; 
   Возврат Список;
КонецФункции

СписокВыбора заполняется (проверял в обработчике), но на форме открывается пустой список. Что не так?


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6557
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
СтандартнаяОбработка = Ложь;

Может из-за вот этого. Зачем отменять стандартную обработку.

Оффлайн Rnshar

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Увы, не помогает!

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6557
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А галочка в полу выбор из списка стоит?

Оффлайн Rnshar

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-20
  • Сайт: 
  • Профессия: Ученик 1С
Стоит!
Я тут переписал код

&НаКлиенте
Процедура РасписаниеТемыПрограммыНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
   СтандартнаяОбработка = Ложь;
   Список=Элемент.СписокВыбора;
   сп= МояОбработкаВыбора(Список,Объект.Программа);
     РеквизитТемыПрограммы=ВыбратьИзСписка(Сп,Элементы.РасписаниеТемыПрограммы);
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция МояОбработкаВыбора(Список,ИскомыйЭлемент)
   Для Каждого ТекущаяСтрока Из ИскомыйЭлемент.ТЧПрограммаОбучения Цикл
      Список.Добавить(ТекущаяСтрока.ТемаЗанятий);
   КонецЦикла; 
   Возврат Список;
КонецФункции
Теперь список выводит, но после клика мышью - выбора, Значение не запоминается в строке!!! На шаг ближе, но ...
Добавлено: 25 Июн 2013, 18:10

ВООООООООООТ неуч! Осталось выбранное значение присвоить полю!

Последний раз редактировалось: Rnshar; 25 Июн 2013, 18:10. Причина: Объединение сообщений


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4470
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15910
Последний ответ 16 Авг 2012, 12:07
от Will
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7738
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4774
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1580
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 216
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal