Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 09:26
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Программное заполнение Документа Установка Цен Номенклатуры  (Прочитано 17509 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн zakeng

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 1
  • КПД: 25%
  • Регистрация: 2013-05-16
  • Сайт: 
  • Профессия: Ученик 1С
Конфигурация УТ 11.1
Платформа 1С:Предприятие 8.2.17.169

Здравствуйте.
Подскажите пожалуйста может быть кто нибудь уже имел дело с Программным  заполнением Документа УстановкаЦенНоменклатуры в УТ.
Дело в том что документ имеет 2 элемента формы ТаблицаЗначений и ДеревоЗначений в 1ом Устанавливаются Виды цен Во 2ом Номенклатурные позиции и цены.
И Две скрытые Табличные части ВидыЦен() и Товары(Заполняется всеми номенклатурными позициями По строке на каждый вид цен)

Я пытаюсь Программно заполнить Табличные части Затем записываю документ и открываю его:
&НаКлиенте
Процедура УстановкаЦенНоменклатурыСоздать(Команда)
//Форма = ПолучитьФорму("Документ.УстановкаЦенНоменклатуры.ФормаОбъекта");
//ДанныеФормы = Форма.Объект;
ОткрытьЗначение(СерверУстановкаЦенНоменклатурыСоздать());

//КопироватьДанныеФормы(ДанныеФормы,Форма.Объект);
//Форма.Открыть();

КонецПроцедуры

&НаСервере
Функция СерверУстановкаЦенНоменклатурыСоздать()

//Док = ДанныеФормыВЗначение(ДанныеФормы, Тип("ДокументОбъект.УстановкаЦенНоменклатуры")); // КЕ??
Док = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();

Док.Дата = ТекущаяДата();

ВидЦены = Справочники.ВидыЦен.НайтиПоНаименованию("Специальная");
ТЧВидЦены = Док.ВидыЦен.Добавить();
ТЧВидЦены.ВидЦены = ВидЦены;
ТЧВидЦены.НастройкиКомпоновкиДанных.Получить();

ГСЧ = Новый ГенераторСлучайныхЧисел;                     

Для каждого СтрокаТЗ Из Таблица Цикл

ТЧТовары = Док.ТОвары.Добавить();
ТЧТовары.Номенклатура = СтрокаТЗ.Ссылка;
ТЧТовары.ВидЦены = ВидЦены;
ТЧТовары.Цена = ГСЧ.СлучайноеЧисло(1,111);
ТЧТовары.ЦенаИзмененаВручную = Истина;

КонецЦикла;

Док.Записать(РежимЗаписиДокумента.Запись);
    Возврат Док.Ссылка
//ЗначениеВДанныеФормы(Док,ДанныеФормы);


Как следствие Документ не создает движений
Не удаляться шантанными средствами
Реквизит номер в пределах дня принимает значение прим: 653456
Или вообще не отображается

Может быть кто то уже делал заполнение этого документа и подскажет в какую сторону копать?
Заранее спасибо:)


Оффлайн zakeng

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 1
  • КПД: 25%
  • Регистрация: 2013-05-16
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн pozdvv

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-27
  • Сайт: 
  • Профессия: Программист 7.7
Разобрался...:D
Разобрался сам, подскажи другим :)
Тоже сижу с заполнением установки цен и что-то никак.
Может кто подскажет !? или кода образец
Добавлено: 10 Дек 2013, 14:37

  ДокУЦ = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
ДокУЦ.Дата = ТекущаяДата();
ДокУЦ.Согласован = Истина;
ДокУЦ.Ответственный = Пользователи.ТекущийПользователь();

ВидЦены = Справочники.ВидыЦен.НайтиПоНаименованию("Розничные");
ТЧВидЦены = ДокУЦ.ВидыЦен.Добавить();
ТЧВидЦены.ВидЦены = ВидЦены;

Для каждого СтрД Из ТабличноеПоле Цикл
НоваяСтрока = ДокУЦ.Товары.Добавить();
СпрНом = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул",Формат(СтрД.Артикул, "ЧГ="));
НоваяСтрока.Номенклатура = СпрНом;
НоваяСтрока.ВидЦены      = ВидЦены;
НоваяСтрока.Цена         = СтрД.РознЦена;
ДокУЦ.Товары.Свернуть("Номенклатура, ВидЦены, Цена");
    КонецЦикла;

ДокУЦ.Записать();
Добавлено: 10 Дек 2013, 14:41

Вот так работает :zebzdr:
может поможет таким же ищущим, каким и я был буквально час назад :)

Последний раз редактировалось: pozdvv; 10 Дек 2013, 14:41. Причина: Объединение сообщений


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4483
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7757
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4789
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8556
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7347
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 167
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal