Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 08:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с запросом.  (Прочитано 6207 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Silent_Assassin

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-18
  • Сайт: 
  • Профессия: Ученик 1С
Нужно вывести элемент справочника номенклатура, этим элементом является код.
Запрос вроде написал а как правильно вытащить из него элемент со всеми его полями не пойму.
&НаКлиенте  

Процедура МаксимальныйКод(Команда)
     МаксимальныйКодСервер()
КонецПроцедуры

&НаСервере
Процедура МаксимальныйКодСервер()
Запрос = Новый Запрос ("ВЫБРАТЬ
                        | Номенклатруа.Ссылка,
                        | Номенклатруа.ВерсияДанных,
                        | Номенклатруа.ПометкаУдаления,
                        | Номенклатруа.Предопределенный,
                        | Номенклатруа.Код КАК Код,
                        | Номенклатруа.Наименование
                        |ИЗ
                        | Справочник.Номенклатруа КАК Номенклатруа");

Результат = Запрос.Выполнить();


КонецПроцедуры
Как лучше сделать ? Через печатную форму? Можно ли без нее?


Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Тоесть надо получить последний код во всем справочнике номенклатура?

Справочник.Номенклатруа ???? Номенклатруа
Добавлено: 20 Июн 2013, 22:13

&НаКлиенте  
Процедура МаксимальныйКод(Команда)
    Ссылка = МаксимальныйКодСервер() ;
Сообщить(Строка(Ссылка));
КонецПроцедуры

&НаСервере
Функция МаксимальныйКодСервер()
    Запрос = Новый Запрос ("ВЫБРАТЬ
                           | Номенклатруа.Ссылка,
                           | Номенклатруа.ВерсияДанных,
                           | Номенклатруа.ПометкаУдаления,
                           | Номенклатруа.Предопределенный,
                           | Номенклатруа.Код КАК Код,
                           | Номенклатруа.Наименование
                           |ИЗ
                           | Справочник.Номенклатура КАК Номенклатруа
                           |
                           |УПОРЯДОЧИТЬ ПО
                           | Код");
                           
Результат = Запрос.Выполнить().Выбрать();
Если Результат.Следующий() Тогда
Возврат Результат.Ссылка ;
Иначе
Возврат Справочники.Номенклатура.ПустаяСсылка();
КонецЕсли;

КонецФункции
Добавлено: 20 Июн 2013, 22:14

Только там упорядочил не туда :bleh:
Добавлено: 20 Июн 2013, 22:15

|УПОРЯДОЧИТЬ ПО
| Код УБЫВ"

Последний раз редактировалось: GRADUS; 20 Июн 2013, 22:15. Причина: Объединение сообщений

Оффлайн Silent_Assassin

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-18
  • Сайт: 
  • Профессия: Ученик 1С
Справочник.Номенклатруа ???? Номенклатруа
Блин!
GRADUS,
Тема в том что нужно вывести только максимальный элемент.


Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Справочник.Номенклатруа ???? Номенклатруа
Блин!
GRADUS,
Тема в том что нужно вывести только максимальный элемент.

Максимальный по коду? )  Элемента Номенклатруы ? :bleh:
Чем вроторое сообщение не катит? :bleh:

Оффлайн Silent_Assassin

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-18
  • Сайт: 
  • Профессия: Ученик 1С
Я так понял нужно писать обработку?
Поправил чуть
&НаКлиенте  

Процедура МаксимальныйКод(Команда)
     МаксимальныйКодСервер()
КонецПроцедуры

&НаСервере
Процедура МаксимальныйКодСервер()
Запрос = Новый Запрос ("ВЫБРАТЬ
                       | Номенклатура.Ссылка,
                       | Номенклатура.ВерсияДанных,
                       | Номенклатура.ПометкаУдаления,
                       | Номенклатура.Предопределенный,
                       | Номенклатура.Код КАК Код,
                       | Номенклатура.Наименование
                       |ИЗ
                       | Справочник.Номенклатура КАК Номенклатура");

Результат = Запрос.Выполнить();


КонецПроцедуры

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Алло, чувак, второе сообщение темы :bleh:

Оффлайн Silent_Assassin

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-18
  • Сайт: 
  • Профессия: Ученик 1С
Алло, чувак, второе сообщение темы :bleh:
Точняк!:D
Ща элементы выборки буду писать.

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Алло, чувак, второе сообщение темы :bleh:
Точняк!:D
Ща элементы выборки буду писать.

Я верю в тебя :bleh:

А зачем их писать то? xDDD

Оффлайн Silent_Assassin

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-18
  • Сайт: 
  • Профессия: Ученик 1С
Алло, чувак, второе сообщение темы :bleh:
Точняк!:D
Ща элементы выборки буду писать.

Я верю в тебя :bleh:


А зачем их писать то? xDDD

Ну он только название выводит а нужно все реквизиты.

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Ссылка.Ревезит1
Ссылка.Ревезит2
Ссылка.Ревезит3

И так далее


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1241
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4863
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2630
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3441
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3697
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
Artibon
13 Сообщений
LexaK
13 Сообщений

* Кто онлайн

  • Точка Гостей: 565
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal