Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 07:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема С Циклом 1С 8.2  (Прочитано 3157 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Silent_Assassin

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-18
  • Сайт: 
  • Профессия: Ученик 1С
Есть задание, создать обработку которая из трех чисел введенных пользователем выдает среднее из них.

Пока начал делать алгоритм, но не получается вывести число. В чем проблема.
&НаКлиенте
Процедура Среднее(Команда)
ср=0;
Если (Число1 > Число2 ) и (Число1 < Число3)
Тогда
Число1=ср;

   Сообщить(ср)
   
   //ИначеЕсли (Число2 > Число1 ) и (Число2 < Число3)


КонецЕсли;

КонецПроцедуры


Синтаксических ошибок нет, алгоритм не полный.


Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
Если бы ты привел полный алгоритм, то было бы проще понять. Пока же получается так что при определенных условиях ты обнуляешь число1 и выводишь в сообщении ноль. Спрашивается зачем?

Оффлайн Silent_Assassin

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-18
  • Сайт: 
  • Профессия: Ученик 1С
Вот полный код.
Но не работает последнее условие, не пойму пока как реализовать. Может какие операторы неправельные?


&НаКлиенте
Процедура Среднее(Команда)
ср=0;
    Если (Число1 > Число2 ) и (Число1 < Число3)
    Тогда   
   СреднееЧисло=Число1;
     
   Сообщить("а")
   
    ИначеЕсли (Число2 > Число1 ) и (Число2 < Число3)
    Тогда   
    СреднееЧисло=Число2;
     
   Сообщить("б")
   
    ИначеЕсли (Число3 > Число1 ) и (Число3 < Число2)
    Тогда   
    СреднееЧисло=Число3;
     
   Сообщить("в")
ИначеЕсли  Число1 = Число1 и Число2=Число2
   тогда
   Сообщить("нетСтреднегоЧисла")
   
КонецЕсли;   
   
КонецПроцедуры

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Процедура НайтиСреденее(Команда)
Если Число1 = Число2 Или Число1 = Число3 Или Число2 = Число3 Тогда
Среднее = "Средних чисел нет";
ИначеЕсли Число1 > Число2 И Число1 < Число3 Или Число1 < Число2 И Число1 > Число3 Тогда
Среднее = Число1;
ИначеЕсли  Число2 > Число1 И Число2 < Число3 Или Число2 < Число1 И Число2 > Число3 Тогда
Среднее = Число2;
ИначеЕсли  Число3 > Число1 И Число3 < Число2 Или  Число3 < Число1 И Число3 > Число2 Тогда
Среднее = Число3;
КонецЕсли;

Сообщить(Среднее);
КонецПроцедуры

Оффлайн Silent_Assassin

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-18
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо GRADUS :ooifh:
 Я к стати только что свой код дописал, но у меня намного больше строк чем у тебя;)
&НаКлиенте
Процедура Среднее(Команда)
ср=0;
Если (Число1 > Число2 ) и (Число1 < Число3)
    Тогда   
   СреднееЧисло=Число1;
     
   Сообщить("а")
   
      ИначеЕсли (Число1 < Число2 ) и (Число1 > Число3)
    Тогда   
   СреднееЧисло=Число1;
     
   Сообщить("а")

   
    ИначеЕсли (Число2 > Число1 ) и (Число2 < Число3)
    Тогда   
    СреднееЧисло=Число2;
     
   Сообщить("б")
   
   
   
   
        ИначеЕсли (Число2 > Число3 ) и (Число2 < Число3)
    Тогда   
    СреднееЧисло=Число2;
     
   Сообщить("б")


ИначеЕсли (Число1 > Число2 ) и (Число3 < Число2)
    Тогда   
    СреднееЧисло=Число2;
     
   Сообщить("б")

   
   
   
    ИначеЕсли (Число1 > Число2 ) и (Число3 > Число2)
    Тогда   
    СреднееЧисло=Число3;
     
   Сообщить("в")     


ИначеЕсли (Число1 < Число2 ) и (Число3 < Число2)
    Тогда   
    СреднееЧисло=Число3;
     
   Сообщить("в")
   
       ИначеЕсли (Число1 > Число2 ) и (Число3 > Число2)
    Тогда   
    СреднееЧисло=Число3;
     
   Сообщить("в")


   
   
ИначеЕсли  Число1 = Число1 и Число2=Число2
   тогда
   Сообщить("нетСтреднегоЧисла")
   
КонецЕсли;   
   
КонецПроцедуры


Добавлено: 18 Июн 2013, 20:33

Только почему то не работает вывод сообщения.
Добавлено: 18 Июн 2013, 20:39

Ок, понял свою проблему переименовал процедуру и добавил команду сообщить (среднее) все работает.

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Могу в одну строчку написать :D

Оффлайн Silent_Assassin

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-18
  • Сайт: 
  • Профессия: Ученик 1С
Могу в одну строчку написать :D
Не Спасибо Я и так там замучился.


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1177
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4701
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2431
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3323
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3582
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 370
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal