Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 12:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как создавать переменные с переменными частями?  (Прочитано 7322 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vobbl

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-20
  • Сайт: 
  • Профессия: Ученик 1С
Есть переменные - ПервыйВидВремени1 и до ПервыйВидВремени31. Обращение к ним - НоваяСтрока.ПервыйВидВремени1(-31)
Чтобы, например, записать в них одинаковое значение нужно писать
НоваяСтрока.ПервыйВидВремени1 = х
НоваяСтрока.ПервыйВидВремени2 = х
...
НоваяСтрока.ПервыйВидВремени31 = х

Как сделать, чтобы циферку заменить на переменную? Мне кажется, это простейшее действие, но в силу собственной ограниченности, я пока ещё не знаю, как это делать =(
Думал, ПредопределенноеЗначение мне поможет, но нет, не помогло


Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Есть переменные - ПервыйВидВремени1 и до ПервыйВидВремени31. Обращение к ним - НоваяСтрока.ПервыйВидВремени1(-31)
Чтобы, например, записать в них одинаковое значение нужно писать
НоваяСтрока.ПервыйВидВремени1 = х
НоваяСтрока.ПервыйВидВремени2 = х
...
НоваяСтрока.ПервыйВидВремени31 = х

Как сделать, чтобы циферку заменить на переменную? Мне кажется, это простейшее действие, но в силу собственной ограниченности, я пока ещё не знаю, как это делать =(
Думал, ПредопределенноеЗначение мне поможет, но нет, не помогло

ВидВремени = Новый Структура;
Для Счетчик = 1 По 100 Цикл
ВидВремени.Вставить("Номер"+Счетчик,х);
КонецЦикла

Счетчик = 32;
Индекс = "Номер"+Счетчик;
ВидВремени[Индекс] = "АбраКадабра"

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Для Сч=1 По 31 Цикл
   НоваяСтрока["ПервыйВидВремени"+Сч] = 5;
КонецЦикла;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Для Сч=1 По 31 Цикл
   НоваяСтрока["ПервыйВидВремени"+Сч] = 5;
КонецЦикла;
Это слишком просто  :fdbsdfbsd:

Оффлайн vobbl

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-20
  • Сайт: 
  • Профессия: Ученик 1С
чего-то не пашет =(
Пишу:
//НоваяСтрока.ПервыйВидВремени1 = Справочники.КлассификаторИспользованияРабочегоВремени.Работа;
//НоваяСтрока.ПервыйЧасов1 = "8"; // - это было раньше 

    Для Сч=1 По 31 Цикл
   НоваяСтрока["ПервыйВидВремени"+Сч] = Справочники.КлассификаторИспользованияРабочегоВремени.Работа;
   НоваяСтрока["ПервыйЧасов"+Сч] = "8";
    КонецЦикла;
Выдаёт ошибку - Поле объекта не обнаружено ПервыйВидВремени1 :(

ВидВремени = Новый Структура;
Для Счетчик = 1 По 100 Цикл
ВидВремени.Вставить("Номер"+Счетчик,х);
КонецЦикла


Счетчик = 32;
Индекс = "Номер"+Счетчик;
ВидВремени[Индекс] = "АбраКадабра"
- это я совсем не понял, что к чему...  =]

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
НоваяСтрока.ПервыйВидВремени1 = Справочники.КлассификаторИспользованияРабочегоВремени.Работа;

А так работает? :xfbnsdfb:

Что такое "НоваяСтрока", интересует тип

Оффлайн vobbl

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-20
  • Сайт: 
  • Профессия: Ученик 1С
Да да! Вот так работает! Но не писать же все дни месяца, чтобы им присвоить что-либо.
Тип НовойСтроки -
ТабЧасть = Нов1.ОтработанноеВремя;
НоваяСтрока = ТабЧасть.Добавить();
А Нов1 - документы.ТабельУчетаРабВремени

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Да да! Вот так работает! Но не писать же все дни месяца, чтобы им присвоить что-либо.
Тип НовойСтроки -
ТабЧасть = Нов1.ОтработанноеВремя;
НоваяСтрока = ТабЧасть.Добавить();
А Нов1 - документы.ТабельУчетаРабВремени
А так?

НоваяСтрока["ПервыйВидВремени1"] = Справочники.КлассификаторИспользованияРабочегоВремени.Работа;

Оффлайн vobbl

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-20
  • Сайт: 
  • Профессия: Ученик 1С
Нет, не работает =(
Пишет - Переменная не определена (ПервыйВидВремени1)

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Так работает?
ТабЧасть = Нов1.ОтработанноеВремя;
НоваяСтрока = ТабЧасть.Добавить();
НоваяСтрока.ПервыйВидВремени1 = Справочники.КлассификаторИспользованияРабочегоВремени.Работа;

А так нет?
ТабЧасть = Нов1.ОтработанноеВремя;
НоваяСтрока = ТабЧасть.Добавить();
НоваяСтрока["ПервыйВидВремени1"] = Справочники.КлассификаторИспользованияРабочегоВремени.Работа;

Мне кажется вы обманываете... =)
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 865
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal