Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 01:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Дата преобразуется в строку  (Прочитано 3543 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
столкнулся с интересным поведением системы, ситуация такая: на вход процедуры передается два параметра Дата, в процедуре один из параметров перобразуется в строку
&НаКлиенте
Процедура Списать(Команда)
СписаниеТоваров.ОбработкаСписаниеСебестоимости(НачалоПериода, НачалоПериодаПоУмолчанию);// вот эти два параметра
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
НачалоПериодаПоУмолчанию = Последовательности.ОстаткиНоменклатуры.ПолучитьГраницу().Дата;
КонецПроцедуры
передаются в общий модуль
 
Если НачДата = '0001.01.01' Тогда
ПД = НДПоУм;
Иначе
ПД = НачДата;
КонецЕсли;
где в дальнейшем ПД используется как параметр в запросе, нашел выход следующий
	Запрос.УстановитьПараметр("Дата", Дата(ПД));
однако не вполне понятно поведение системы, почему система преобразует при присвоении ПД из значения НДПоУм в строку а ПД из НачДата остается Датой


Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
столкнулся с интересным поведением системы, ситуация такая: на вход процедуры передается два параметра Дата, в процедуре один из параметров перобразуется в строку
&НаКлиенте
Процедура Списать(Команда)
СписаниеТоваров.ОбработкаСписаниеСебестоимости(НачалоПериода, НачалоПериодаПоУмолчанию);// вот эти два параметра
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
НачалоПериодаПоУмолчанию = Последовательности.ОстаткиНоменклатуры.ПолучитьГраницу().Дата;
КонецПроцедуры
передаются в общий модуль
 
Если НачДата = '0001.01.01' Тогда
ПД = НДПоУм;
Иначе
ПД = НачДата;
КонецЕсли;
где в дальнейшем ПД используется как параметр в запросе, нашел выход следующий
	Запрос.УстановитьПараметр("Дата", Дата(ПД));
однако не вполне понятно поведение системы, почему система преобразует при присвоении ПД из значения НДПоУм в строку а ПД из НачДата остается Датой

НДПоУм имеет строковый тип

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
при присвоении переменной ПД значение из типа Дата, в обоих случаях дата преобразуется в строку, интересно, никогда на это не обращал внимание, и в курсах об этом не было ни слова, ну что же, будем знать B)

Оффлайн SlazZy

  • ***
  • Сообщений: 149
  • РЕПУТАЦИЯ: 15
  • КПД: 10%
  • Регистрация: 2012-04-28
  • Сайт: 
  • Профессия: Программист 1С
при присвоении переменной ПД значение из типа Дата, в обоих случаях дата преобразуется в строку, интересно, никогда на это не обращал внимание, и в курсах об этом не было ни слова, ну что же, будем знать B)
я бы на вашем месте более внимательно смотрел в отладчик. Просто так ничего не должно преобразовываться.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 181
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal