Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 12:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите оптимизировать код.  (Прочитано 3626 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlenkaInt

  • ****
  • Сообщений: 266
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-21
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте. Есть задача - Создать обработку, в которой пользователь вводит данные "Наименование", "Телефон", "ИНН", по кнопке создается элемент в справочнике "Контрагенты" и форма этого элемента автоматически открывается.
Я в модуле обработки написала такой код:
&НаКлиенте
Процедура СоздатьЭлемент(Команда)
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("Телефон", Телефон);
    ПараметрыФормы.Вставить("ИНН", ИНН);
    ПараметрыФормы.Вставить("Наименование", Наименование);
    ОткрытьФорму("Справочник.Контрагенты.Форма.ФормаЭлемента1", ПараметрыФормы);
КонецПроцедуры
В модуле формы справочника такой:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Перем Телефон;
    Перем ИНН;
    Перем Наименование;   
    Если Параметры.Свойство("Телефон", Телефон) Тогда
        Объект.Телефон = Телефон;   
    КонецЕсли;
    Если Параметры.Свойство("ИНН", ИНН) Тогда
        Объект.ИНН = ИНН;   
    КонецЕсли;
    Если Параметры.Свойство("Наименование", Наименование) Тогда
        Объект.Наименование = Наименование;   
    КонецЕсли;
КонецПроцедуры
Такой код работает, но не нравится решение, много условных операторов, как то не оптимально. Подскажите, может есть какая то возможность в одном Если все заполнить? Спасибо :-)


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
  Если Не Параметры = Неопределено Тогда
     ЗаполнитьЗначенияСвойств(Объект,Параметры);
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Ну или такой вариант (работает только если у реквизитов установлена галочка "Заполнять из данных заполнения")

	
&НаКлиенте
Процедура СоздатьЭлемент(Команда)
ЗначенияЗаполнения = Новый Структура("ЗначенияЗаполнения");
ПараметрыФормы = Новый Структура;
ПараметрыФормы.Вставить("Телефон", Телефон);
    ПараметрыФормы.Вставить("ИНН", ИНН);
    ПараметрыФормы.Вставить("Наименование", Наименование);

ЗначенияЗаполнения.Вставить("ЗначенияЗаполнения",ПараметрыФормы);
ОткрытьФорму("Справочник.Контрагенты.ФормаОбъекта",ЗначенияЗаполнения);
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн AlenkaInt

  • ****
  • Сообщений: 266
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-21
  • Сайт: 
  • Профессия: Программист 1С
Спасибо! Да, так работает.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4295
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5554
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5892
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4378
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1981
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 270
  • Точка Скрытых: 1
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal