Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 10:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внести ФИОРуководителя в печатную форму  (Прочитано 12097 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Emil Erfurt

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-10
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток, столкнулся с дилеммой - не могу получить значение ФИО-Руководителя. Перекопал интернет. Решения из ТОРГ-12 не работают или же у меня руки просто кривые.
УТ 10.3. 1С 8.2.
Код сейчас такой

       
Подвал = Макет.ПолучитьОбласть("Подвал");
СведенияОКонтрагенте1  = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Ссылка.Организация,  Ссылка.Дата);
  Подвал.Параметры.АдресОрганизации = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОКонтрагенте1, "ЮридическийАдрес");
Подвал.Параметры.ПочтАдресОрганизации = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОКонтрагенте1, "ФактическийАдрес");
        Подвал.Параметры.ИННОрг = Организация.ИНН + " / " + Организация.КПП;
Подвал.Параметры.РасчСчетОрг = Организация.ОсновнойБанковскийСчет.НомерСчета;
Подвал.Параметры.БанкОрг = Организация.ОсновнойБанковскийСчет.Банк;
Подвал.Параметры.КорСчетОрг = Организация.ОсновнойБанковскийСчет.Банк.КоррСчет;
Подвал.Параметры.БикОрг = Организация.ОсновнойБанковскийСчет.Банк.Код;
Подвал.Параметры.ОКПОорг = Организация.КодПоОКПО;
Подвал.Параметры.ОГРНорг = Организация.ОГРН;
Подвал.Параметры.ТелОрг = УправлениеКонтактнойИнформацией.ПолучитьТелефонИзКонтактнойИнформации(Ссылка.Организация);
Руководители = ОбщегоНазначения.ОтветственныеЛица(Руководители, Дата);
Подвал.Параметры.ГенДирОрг = Руководители.РуководительПредставление;

Собственно на последние две строки и ругается. Пробовал по-разному , включая и такой вариант

Руководители = ОбщегоНазначения.ОтветственныеЛица(Шапка.Руководители, Шапка.ДатаДокумента);
ОбластьМакетаПодвал.Параметры.ФИОРуководителя = Руководители.РуководительПредставление;

Посоветуйте пожалуйста, как мне быть. И еще вопрос - я крайне начинающий в 1С 8.2. и никак не могу найти, где прочитать код того же самого ТОРГ-12.

С Уважением и надеждой...


Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
Как именно ругается? где вы получаете область ОбластьМакетаПодвал? точно ли там есть параметр ФИОРуководителя? В коде выше как я поняла у вас область просто Подвал...
Добавлено: 10 Июн 2013, 11:51

Из какого документа печатаете?

Оффлайн Emil Erfurt

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-10
  • Сайт: 
  • Профессия: Ученик 1С
Как именно ругается? где вы получаете область ОбластьМакетаПодвал? точно ли там есть параметр ФИОРуководителя? В коде выше как я поняла у вас область просто Подвал...
Добавлено: 10 Июн 2013, 11:51

Из какого документа печатаете?

Пишет - Метод объекта не обнаружен (ОтветственныеЛица).

Я создал дополнительный макет в ЗаказыПокупателей и привязал к кнопке. Все данные вносит без проблем, но с Руководителем прямо беда.

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
нет редакции 10.3 под рукой. В модуле Общего назначения точно есть функция ОтветственныеЛица? приведите ее пожалуйста
Добавлено: 10 Июн 2013, 12:15

Попробуйте так: Руководители = ОтветственныеЛица(Шапка.Руководители, Шапка.ДатаДокумента);

Оффлайн Emil Erfurt

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-10
  • Сайт: 
  • Профессия: Ученик 1С
нет редакции 10.3 под рукой. В модуле Общего назначения точно есть функция ОтветственныеЛица? приведите ее пожалуйста
Добавлено: 10 Июн 2013, 12:15

Попробуйте так: Руководители = ОтветственныеЛица(Шапка.Руководители, Шапка.ДатаДокумента);

Пишет ошибку:

{Документ.ЗаказПокупателя.Форма.ФормаДокумента.Форма(2536,17)}: Процедура или функция с указанным именем не определена (ОтветственныеЛица)
   Руководители = <<?>>ОтветственныеЛица(Шапка.Руководители, Шапка.ДатаДокумента);    (Проверка: Толстый клиент (обычное приложение))

Руководители = ОтветственныеЛица(Шапка.Руководители, Шапка.ДатаДокумента);	
Подвал.Параметры.ГенДирОрг = Руководители;


Оффлайн pavl_vs

  • *****
  • Сообщений: 1070
  • РЕПУТАЦИЯ: 168
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
нет редакции 10.3 под рукой. В модуле Общего назначения точно есть функция ОтветственныеЛица?

Возможно в конфигурации общий модуль "ОбщегоНазначениЗК", а не "ОбщегоНазначени"; сравнительно недавно в некоторых конфигурациях был образован такой модуль и в него были перенесены многие функции и процедуры.

Пишет - Метод объекта не обнаружен (ОтветственныеЛица).

Я создал дополнительный макет в ЗаказыПокупателей и привязал к кнопке. Все данные вносит без проблем, но с Руководителем прямо беда.

Если такого модуля в "Общие" нет, тогда попробуйте через РегистрСведений.ОтветственныеЛицаУчреждений.

Оффлайн Emil Erfurt

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-10
  • Сайт: 
  • Профессия: Ученик 1С
нет редакции 10.3 под рукой. В модуле Общего назначения точно есть функция ОтветственныеЛица?

Возможно в конфигурации общий модуль "ОбщегоНазначениЗК", а не "ОбщегоНазначени"; сравнительно недавно в некоторых конфигурациях был образован такой модуль и в него были перенесены многие функции и процедуры.

Пишет - Метод объекта не обнаружен (ОтветственныеЛица).

Я создал дополнительный макет в ЗаказыПокупателей и привязал к кнопке. Все данные вносит без проблем, но с Руководителем прямо беда.

Если такого модуля в "Общие" нет, тогда попробуйте через РегистрСведений.ОтветственныеЛицаУчреждений.


Либо я что-то не так делаю, либо просто не понимаю. Напишите, пожалуйста пример кода или исправьте мой.

Заранее благодарен

Оффлайн pavl_vs

  • *****
  • Сообщений: 1070
  • РЕПУТАЦИЯ: 168
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Давайте, без паники.
Вам посоветовали показать или проверить есть ли в "ОбщегоНазначения" функция "ОтветственныеЛица".
Откройте конфигуратор, найдите "Общие модули", распахните ветку и посмотрите что в ней есть: "ОбщегоНазначения" и/или "ОбщегоНазначенияЗК".
А открыв модуль (или модули) проверьте наличие нужного Вам "ОтветственныеЛица".
Допустим нет.
Тогда в окне "Конфигурация" спуститесь вниз и распахните "РегистрСведений". В нем Вы точно найдете требуемое.
Учтите "ОтветственныеЛица" - периодический регистр.

Оффлайн Emil Erfurt

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-10
  • Сайт: 
  • Профессия: Ученик 1С
Давайте, без паники.
Вам посоветовали показать или проверить есть ли в "ОбщегоНазначения" функция "ОтветственныеЛица".
Откройте конфигуратор, найдите "Общие модули", распахните ветку и посмотрите что в ней есть: "ОбщегоНазначения" и/или "ОбщегоНазначенияЗК".
А открыв модуль (или модули) проверьте наличие нужного Вам "ОтветственныеЛица".
Допустим нет.
Тогда в окне "Конфигурация" спуститесь вниз и распахните "РегистрСведений". В нем Вы точно найдете требуемое.
Учтите "ОтветственныеЛица" - периодический регистр.

1. ОбщегоНазначения
2. В регистреСведений все нашлось. Теперь ломаю голову как мне вызвать ФИО Руководителя

Строку такую написал
Подвал.Параметры.ГенДирОрг = РегистрыСведений.ОтветственныеЛица.Выбрать(Организация, "Руководитель");

естественно не работает((((

Добавлено: 10 Июн 2013, 16:44

Помогите, люди добрые....:trhregerhg:

Последний раз редактировалось: Emil Erfurt; 10 Июн 2013, 16:44. Причина: Объединение сообщений

Оффлайн pavl_vs

  • *****
  • Сообщений: 1070
  • РЕПУТАЦИЯ: 168
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Это слишком упрощенно для периодических значений. Вот работающая функция - попробуйте изменить ее под себя.
// Функция ОтветственныеЛицаНаДату(Организация, наДату)
//
Функция ОтветственныеЛицаНаДату(Организация, наДату)
// Запрос по Ответственным лицам Организации
//
ЗапросПоЛицам = Новый Запрос();
ЗапросПоЛицам.УстановитьПараметр("Организация", Организация);
ЗапросПоЛицам.УстановитьПараметр("ДатаСреза", наДату);

ЗапросПоЛицам.Текст =
"ВЫБРАТЬ РАЗРЕШЕННЫЕ
| ОтветственныеЛицаОрганизацийСрезПоследних.ОтветственноеЛицо,
| ОтветственныеЛицаОрганизацийСрезПоследних.ОтветственноеЛицо КАК ФИОГлавныйБухгалтер,
| ОтветственныеЛицаОрганизацийСрезПоследних.Должность.Наименование КАК Должность,
| ЕСТЬNULL(ФИОФизЛицСрезПоследних.Фамилия + ВЫБОР
| КОГДА ПОДСТРОКА(ФИОФизЛицСрезПоследних.Имя, 1, 1) <> """"
| ТОГДА "" "" + ПОДСТРОКА(ФИОФизЛицСрезПоследних.Имя, 1, 1) + "".""
| ИНАЧЕ """"
| КОНЕЦ + ВЫБОР
| КОГДА ПОДСТРОКА(ФИОФизЛицСрезПоследних.Отчество, 1, 1) <> """"
| ТОГДА "" "" + ПОДСТРОКА(ФИОФизЛицСрезПоследних.Отчество, 1, 1) + "".""
| ИНАЧЕ """"
| КОНЕЦ, ОтветственныеЛицаОрганизацийСрезПоследних.ФизическоеЛицо.Наименование) КАК ФИОПолное
|ИЗ
| РегистрСведений.ОтветственныеЛицаОрганизаций.СрезПоследних(&ДатаСреза, СтруктурнаяЕдиница = &Организация) КАК ОтветственныеЛицаОрганизацийСрезПоследних
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ФИОФизЛиц.СрезПоследних(&ДатаСреза, ФизЛицо ССЫЛКА Справочник.ФизическиеЛица) КАК ФИОФизЛицСрезПоследних
| ПО ОтветственныеЛицаОрганизацийСрезПоследних.ФизическоеЛицо = ФИОФизЛицСрезПоследних.ФизЛицо";

Выборка = ЗапросПоЛицам.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
   Если Выборка.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизаций.Руководитель Тогда
      //Результат.Руководитель = Выборка.ФИОПолное;
      //Результат.РуководительДолжность = Выборка.Должность;
  ДолжностьРуководителя = Выборка.Должность;
  ФИОРуководителя = Выборка.ФИОПолное;
   ИначеЕсли Выборка.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизаций.ГлавныйБухгалтер Тогда
      //Результат.ГлавныйБухгалтер = Выборка.ФИОПолное;
  ФИОГлавБуха = Выборка.ФИОПолное;
   ИначеЕсли Выборка.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизаций.Кассир Тогда
      //Результат.Кассир = Выборка.ФИОПолное;
   ИначеЕсли Выборка.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизаций.ОтветственныйЗаНалоговыеРегистры Тогда
      //Результат.ОтветственныйЗаРегистры = Выборка.ФИОПолное;
   КонецЕсли;
КонецЦикла;
КонецФункции

ФИО ответственных лиц -  переменные модуля.


Теги:
 

Как открыть программно открыть форму контрагента?

Автор VzonderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1373
Последний ответ 18 Янв 2017, 12:32
от sertak
Печать штрих кодов на форму печати выводятся 3 штрих кода на принтер выходит только 2.

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 515
Последний ответ 15 Май 2017, 08:59
от ZSS
Передача параметров из ячейки поля табличного документа в форму создания нового документа 1с 8.3

Автор Анна БахановичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 3043
Последний ответ 18 Фев 2016, 12:50
от Анна Баханович
Как программно открыть форму и закрыть с записью, чтобы отработал метод перед записью

Автор con2rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2921
Последний ответ 13 Июн 2017, 12:17
от Whisper
Версия 8.3, при добавлении поля в форму списка не устанавливается вид поля - выпадающий список пустой

Автор Developer.KZРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 344
Последний ответ 22 Июн 2017, 10:50
от Developer.KZ

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
136 Сообщений
AIFrame
66 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal