Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 12:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Удалить строку из табличной части  (Прочитано 13766 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlenkaInt

  • ****
  • Сообщений: 266
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-21
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте. Есть учебное задание - в модуле объекта "Поступления товаров" создайте экспортный метод "Очистить строки с незаполненной ценой". Данный метод должен из табличной части документа удалять строки с реквизитом "Цена" равным нулю. Создайте команду формы, выведите ее в качестве кнопки командной панели. При исполнении команды обеспечьте вызов метода модуля объекта "Очистить незаполненной ценой".

В модуле формы такой код -

&НаКлиенте
Процедура ОчиститьСтрокиСНезаполненнойЦеной(Команда)
ПромежуточнаяСервер();
КонецПроцедуры
&НаСервере
Процедура ПромежуточнаяСервер()
Реквизит=РеквизитФормыВЗначение("Объект");
Реквизит.ОчиститьСтрокиСНезаполненнойЦенойСервер();

КонецПроцедуры

В модуле объекта документа Поступелние товаров
Процедура ОчиститьСтрокиСНезаполненнойЦенойСервер() Экспорт
ПараметрОтбора=Новый Структура("Цена",0);
Массив = Товары.НайтиСтроки(ПараметрОтбора);
  Для Каждого Элемент Из Массив Цикл
  Товары.Удалить(Элемент);
КонецЦикла;
КонецПроцедуры

Почему то все равно не удаляется строка..

Продскажите почему .


Оффлайн AlenkaInt

  • ****
  • Сообщений: 266
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-21
  • Сайт: 
  • Профессия: Программист 1С
Изменила немного код
Процедура ОчиститьСтрокиСНезаполненнойЦенойСервер() Экспорт   
   ПараметрОтбора=Новый Структура("Цена",0);
   Массив = Товары.НайтиСтроки(ПараметрОтбора);
   Для Каждого Строка Из Массив Цикл
      Индекс = 1;
      Товары.Удалить(Индекс);
      Индекс = Индекс + 1;
   КонецЦикла;   
КонецПроцедуры
Теперь строка удаляется, но не удобно. Я нажимаю на кнопку, ничего не происходит, потом закрываю документ. Если я соглашаюсь на сохранение изменений, то выдается сообщение, что документ уже изменен другим пользователем. А если просто закрываю без сохранений и открываю, то строк с нулевой ценой нет.
Как сделать, чтобы удаление строк отбражалось сразу?
Добавлено: 08 Июн 2013, 16:42

Сама разобралась.
Надо было добавить в Процедуру ОчиститьСтрокиСНезаполненнойЦеной(Команда) строку - ЭтаФорма.Прочитать();

Последний раз редактировалось: AlenkaInt; 08 Июн 2013, 16:42. Причина: Объединение сообщений

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Это собеседование что ли? Вы все в одно место устраиваетесь?
Очистить строки с незаполненной ценой
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Сама разобралась.
Надо было добавить в Процедуру ОчиститьСтрокиСНезаполненнойЦеной(Команда) строку - ЭтаФорма.Прочитать();

На самом деле надо было обратно значение в реквизит формы запилить.

Оффлайн AlenkaInt

  • ****
  • Сообщений: 266
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-21
  • Сайт: 
  • Профессия: Программист 1С
Нет, не собеседование. Это домашнее задание к видео-курсу.

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Никогда не понимал, чему могут научить видео курсы?

Для меня учебой являются реальные задания, а после их получения они "шлифуются" книгами и запоминаются.

Толку то, что ты под копирку что то сделаешь...

Оффлайн AlenkaInt

  • ****
  • Сообщений: 266
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-21
  • Сайт: 
  • Профессия: Программист 1С
Одни видеокурсы ничему. Это факт. Я начинала со скаченных из инета курсов, но без домашних заданий. Никакого толка. Потом я купила такой же курс, но с мастер-группой, с отработкой домашних заданий. Это уже было кое что. Потом я устроилась стажером. И параллельно продолжала обучаться. Вот это уже было кое что :-) Мое мнение на этот счет такое, что просто работать и читать книги или просто курсы это полу-мера. Идеально работать и учиться, лучше очно. На этих курсах мне нравится то, что там показывают много всяких фишек, которые существенно упрощают работу, потому что какие то моменты я сама методом проб и ошибок освоила, но можно гораздо быстрее, ну и какая то в голове система появляется, что показывают новые возможности, многие по старинке делают, не знают, что уже появился какой то механизм для упрощения работы. И еще, если что то не получается, то всегда можно задать вопрос. Если вопрос интересный или многие какой то момент не поняли, то снимают отдельное видео.


Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1956
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3064
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3098
Последний ответ 02 Июл 2012, 13:11
от totutotam
Применять ПСН относительно доходов, полученных от субаренды части нежилого помещения, нельзя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 669
Последний ответ 23 Июн 2015, 14:25
от news
отчет с анализом данных таб.части и документа + сумма.Расходы из Остатки.Обороты

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 250
Последний ответ 18 Май 2017, 19:12
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
54 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 288
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal