Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 18:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Инвентарный номер  (Прочитано 12900 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Добрый день всем. В справочнике Основные средства у некоторых объектов нету инвентарного номера. (рис 1).  Само интересно то что когда в сам объект заходишь инвентарный номер есть (рис 2), в документе принятие к учету инвентарные номер выставлен.
Конфигурация Бухгалтерия 2.0.9.7
Платформа 8.2.18.61


P.S нашел обработку в которой можно самому забить инвентарный номер. но это не выход, интересно почему его нет??  Кто-нибудь сталкивался с такой ситуацией?


Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Несколько сумбурно описано. Но я так понял, что вы хотите обратиться к инвентарному номеру в справочнике ОС, а его там нет, хотя реквизит есть.

Предыстория этого явления скорее всего такая: сначала он там был и заполнялся, но с развитием конфигурации 1С решила, что инвентарный номер должен храниться в регистре сведений. Так что ищите его теперь там.

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Регистре сведений он есть

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Добрый день коллеги, уже замучился бороться с этими инвентарными номерами, сразу к делу.
Инвентарные номера попадают в РегистрСведений после того как Документом Принятие к учету принимаем ОС, и в табличной части указываем Инвентарный номер.
В справочник Список ОС как было сказано выше не попадают в колонку Инвентарные номера. 
Использую процедуру ПриПолученииДанных.

Процедура СправочникСписокПриПолученииДанных (Элемент, ОформлениеСтрок)
Запрос = Новый запрос;
Запрос.Текст = "ВЫБРАТЬ
               | ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ОсновноеСредство,
               | ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ИнвентарныйНомер
               |ИЗ
               | РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних КАК ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних
               |ГДЕ
               | ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ОсновноеСредство = &Тип
               | И ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ОсновноеСредство В(&МассивОбъектов)";
Запрос.УстановитьПараметр("Тип", РегистрыСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.ИнвентарныйНомер);

МассивОбъектов = Новый Массив;

Для каждого ОформлениеСтроки Из ОформлениеСтрок Цикл
МассивОбъектов.Добавить(ОформлениеСтроки.ДанныеСтроки.Ссылка);
КонецЦикла;

Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
ТабОбъектов = Запрос.Выполнить().Выгрузить();

Для каждого ОформлениеСтроки Из ОформлениеСтрок Цикл
ИН = ТабОбъектов.Найти(ОформлениеСтроки.ДанныеСтроки.Ссылка, "ОсновноеСредство");
ОформлениеСтроки.Ячейки.ИнвНомер.Значение = ?(ИН <> Неопределено, ИН.ИнвентарныйНомер, "");
КонецЦикла;

КонецПроцедуры

где ИнвНомер это реквизит СправочникаСписка. Тип Строка.

подскажите что не так делаю или где ошибка в запросе, данные в справочник список ОС не попадают :dfbsdfbsdf:

Данные Регистра Сведений рис 1


Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Что за условие такое?

ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ОсновноеСредство = &Тип

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ОсновноеСредство = &Тип
делал по примеру видимо на автомате записал.


Добавлено: 25 Июн 2013, 13:24

Процедура СправочникСписокПриПолученииДанных (Элемент, ОформлениеСтрок)
Запрос = Новый запрос;
Запрос.Текст = "ВЫБРАТЬ
               | ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ИнвентарныйНомер
               |ИЗ
               | РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних КАК ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних
               |ГДЕ
               | ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ИнвентарныйНомер В (&МассивОбъектов)";
Запрос.УстановитьПараметр("МассивОбъектов", РегистрыСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.ИнвентарныйНомер);

МассивОбъектов = Новый Массив;

Для каждого ОформлениеСтроки Из ОформлениеСтрок Цикл
МассивОбъектов.Добавить(ОформлениеСтроки.ДанныеСтроки.Ссылка);
КонецЦикла;

Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
ТабОбъектов = Запрос.Выполнить().Выгрузить();

Для каждого ОформлениеСтроки Из ОформлениеСтрок Цикл
ИН = ТабОбъектов.Найти(ОформлениеСтроки.ДанныеСтроки.Ссылка, "ОсновноеСредство");
ОформлениеСтроки.Ячейки.ИнвНомер.Значение = ?(ИН <> Неопределено, ИН.ИнвентарныйНомер, "");
КонецЦикла;

КонецПроцедуры

переделал, такая же ситуация и осталась!

Последний раз редактировалось: ls600; 25 Июн 2013, 13:24. Причина: Объединение сообщений

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Вы сначала записываете в массив объектов непонятно что, а потом перезаписываете его из ОформленияСтроки ссылками. Как программа должна сопоставить ссылку и инвентарный номер? Это разные типы.

Запрос.УстановитьПараметр("МассивОбъектов", РегистрыСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.ИнвентарныйНомер);
   
    МассивОбъектов = Новый Массив;
   
    Для каждого ОформлениеСтроки Из ОформлениеСтрок Цикл
        МассивОбъектов.Добавить(ОформлениеСтроки.ДанныеСтроки.Ссылка);
    КонецЦикла;
   
    Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Можете написать запрос примерно какой должен быть? если не затруднит

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Что у вас есть и что вы хотите получить?


Теги:
 

При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8508
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
В строке номер "1" табличной части "Состав набора": Не заполнено значение реквиз

Автор ХеляРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 6828
Последний ответ 18 Сен 2011, 16:07
от Хеля
Регламентные задания "Недопустимое значение параметра (параметр номер "1")

Автор pyvfРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 17227
Последний ответ 27 Фев 2013, 11:57
от reshkra
Длина поля "Код" (Таб. номер) в ЗИУП 3.0

Автор igor447Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 693
Последний ответ 15 Фев 2016, 03:49
от cska-fanat-kz
в строке номер документа основания (108)не сохраняется "0"

Автор NadinAstraРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 1557
Последний ответ 04 Май 2016, 14:23
от Игорь Иванов

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 538
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal