Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 02:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: объединение двух запросов..  (Прочитано 2038 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Андрей Щ

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-28
  • Сайт: 
  • Профессия: Ученик 1С
как правильно объединить два запроса?

1)
ДатаОтчета = Дата(dataString);
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ВЫБОР
| КОГДА СостояниеРаботниковОрганизацийСрезПоследних.ПериодЗавершения >= &ДатаОтчета
| ИЛИ СостояниеРаботниковОрганизацийСрезПоследних.ПериодЗавершения = &НулеваяДата
| ТОГДА СостояниеРаботниковОрганизацийСрезПоследних.Состояние
| ИНАЧЕ СостояниеРаботниковОрганизацийСрезПоследних.СостояниеЗавершения
| КОНЕЦ КАК Поле1,
| РаботникиОрганизацийСрезПоследних.Сотрудник
|ИЗ
| РегистрСведений.РаботникиОрганизаций.СрезПоследних(&ДатаОтчета, Сотрудник.Код = &ТабНом) КАК РаботникиОрганизацийСрезПоследних
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.СостояниеРаботниковОрганизаций.СрезПоследних(&ДатаОтчета, Сотрудник.Код = &ТабНом) КАК СостояниеРаботниковОрганизацийСрезПоследних
| ПО (СостояниеРаботниковОрганизацийСрезПоследних.Сотрудник = РаботникиОрганизацийСрезПоследних.Сотрудник)";

Запрос.УстановитьПараметр("ДатаОтчета", ДатаОтчета);
Запрос.УстановитьПараметр("ТабНом", tabNum);
Запрос.УстановитьПараметр("НулеваяДата", '00010101');
Статус =tabNum+"Не работает";
Результат = Запрос.Выполнить();                         
ВыборкаДетальныеЗаписи = Результат.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий()Цикл
Если (ВыборкаДетальныеЗаписи.Сотрудник.ДатаУвольнения >= ДатаОтчета) ИЛИ (ВыборкаДетальныеЗаписи.Сотрудник.ДатаУвольнения = '00010101') Тогда
Если ВыборкаДетальныеЗаписи.Поле1 = null Тогда
Статус =tabNum+"Работает";
Иначе

temp = ВыборкаДетальныеЗаписи.Поле1;
Статус =tabNum+Строка(temp);
КонецЕсли;

КонецЕсли;
КонецЦикла;
Возврат  Статус


2)

 ДатаОтчета = ТекущаяДата();
dataType = ФабрикаXDTO.Тип("http://www.sample-package.org", "Getalldata");
rowType = ФабрикаXDTO.Тип("http://www.sample-package.org", "Getallrow");
data = ФабрикаXDTO.Создать(dataType);

 //списокСотрудников="<a>";
Запрос = Новый Запрос;
Запрос.Текст =     
  "ВЫБРАТЬ
|
| РаботникиОрганизацийСрезПоследних.Должность.Наименование КАК Долж,
| РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации.Наименование КАК Подразд,
| РаботникиОрганизацийСрезПоследних.Сотрудник.Наименование КАК ФИО
|     ИЗ
| РегистрСведений.РаботникиОрганизаций.СрезПоследних КАК РаботникиОрганизацийСрезПоследних";


Результат = Запрос.Выполнить().Выбрать();
//Выборка = Результат.Выбрать()

// Пока Результат.Следующий() Цикл
//списокСотрудников=списокСотрудников+"|"+сокрЛП(Выборка.Должн)+"|"+сокрЛП(Выборка.Подразд)+"|"+сокрЛП(Выборка.ФИО);
// КонецЦикла;

Пока Результат.Следующий() Цикл
item = фабрикаXDTO.Создать(rowType);
item.fio = Строка(Результат.ФИО);
item.dolgnost = Строка(Результат.Долж);
item.podrazdelenie = Строка(Результат.Подразд);
//item.sostoyanie = Строка(Результат.Подразд);
data.items.Добавить(item);

КонецЦикла;



 //списокСотрудников=списокСотрудников+"</a>";
возврат data


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А каким образом вы хотите их обединить? ЧТо должно получиться в результате?


Теги: запросы  
 

Объединение конфигураций "Документооборот гос. учреждения" и "Гос. и муницип. закупки"

Автор Рената МарсельевнаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1564
Последний ответ 19 Янв 2015, 20:02
от дфтын
Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6384
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев
Возможно ли языком запросов без конкатенации текста запроса и без СКД преобразовать строки таблицы в столбцы (колонки) выходной таблицы?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 447
Последний ответ 29 Май 2017, 15:29
от alex0402
Какую консоль запросов используете вы в управляемом приложении или что за консоль в видео?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 393
Последний ответ 17 Апр 2017, 09:40
от LexaK
Объединение организации-кредитора и организации-должника

Автор newsРаздел Новости

Ответов: 0
Просмотров: 860
Последний ответ 11 Авг 2015, 12:26
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 130
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal