Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 02:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: копирование номенклатуры в одной базе 1с 8.2  (Прочитано 11618 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 99format

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-03
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день. Подскажите пожалуйста.
Есть база 1с 8.2 КА, в справочнике номенклатура, необходимо скопировать папку «Производство» (и все, что в ней) допустим в папку «Услуги». Если делать вручную – то приходится копировать (по F9) каждый элемент – что очень, долго и не удобно. Вопрос - есть ли возможность – не прибегаю к написанию кода – выполнить данное действие ???  я пробовал использовать внешнюю обработку ВыгрузкаЗагрузкаДанныхXML82.epf. Выгружал конфигурацию из базы – на ее основе делал новую базу – копировал в нее через обработчик номенклатуру – перемешал данные из каталога «Производство» в каталог «Услуги» - выгружал номенклатуру и загружал в основную базу… проблема в том – что при загрузке номенклатуры – данные в папке «Услуги» появлялись – при этом – в папке «Производство» они исчезают … Пробовал сохранение в Excel с последующим использованием «ЗагрузкаДанныхИзТабличногоДокумента.epf» -  все получается, только как я понял данный метод не работает с подпапками…
Спасибо.


Оффлайн Eugeneer

  • ****
  • Сообщений: 353
  • РЕПУТАЦИЯ: 28
  • КПД: 8%
  • SubSystems.Ru - разработки 1С
  • Регистрация: 2010-03-21
  • Компания: SubSystems.Ru
  • Профессия: Разработчик 1С
Ищите обработки которые грузят с подпапками.
SubSystems.Ru - Автоматическая загрузка прайсов в 1С из Excel

Оффлайн advanter

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-15
  • Сайт: 
  • Профессия: Программист 8.1
Статья о подобном - http://www.advanter.net/?p=1007
Копирование элементов из одной группы в другую (с учетом владельца) - http://katalog.forum-1c.ru/public/16822/

Оффлайн 99format

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-03
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо - сейчас буду пробовать ...
Добавлено: 04 Июн 2013, 12:22

что - то я не понимаю - почему когда я в начале копирую содержимое одной папки номенклатуры в excel - потом с помощью ЗагрузкаДанныхИзТабличногоДокумента.epf хочу загрузить их в другую папку (меняю родителя) - обработчик переносит данные из одной папки в другую, а если меняешь название номенклатуры (допустим ставим 1 вначале) - то все копируется.
 
Добавлено: 04 Июн 2013, 12:54

тему можно закрывать - нашел в интернете следующую процедуру

Процедура КнопкаВыполнитьНажатие(Кнопка)

  КопируемаяГруппа = Справочники.Номенклатура.НайтиПоКоду("000000011");

  СкопированнаяГруппа = КопируемаяГруппа.Скопировать();
  СкопированнаяГруппа.ПометкаУдаления = КопируемаяГруппа.ПометкаУдаления;
  СкопированнаяГруппа.Записать();

  СоответствиеГрупп = Новый Соответствие;
  СоответствиеГрупп.Вставить(КопируемаяГруппа, СкопированнаяГруппа.Ссылка);

  Выборка = Справочники.Номенклатура.ВыбратьИерархически(КопируемаяГруппа);

  Пока Выборка.Следующий() Цикл

   НовыйЭлементСправочника = Выборка.Ссылка.Скопировать();
   НовыйЭлементСправочника.Родитель = СоответствиеГрупп[Выборка.Родитель];
   НовыйЭлементСправочника.ПометкаУдаления = Выборка.ПометкаУдаления;
   НовыйЭлементСправочника.Записать();

   Если Выборка.ЭтоГруппа Тогда
     СоответствиеГрупп.Вставить(Выборка.Ссылка, НовыйЭлементСправочника.Ссылка);
   КонецЕсли;

  КонецЦикла;

КонецПроцедуры

с ней все получилось :-)

Последний раз редактировалось: 99format; 04 Июн 2013, 12:54. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 169
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal