Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 16:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: объединение двух запросов..  (Прочитано 5404 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Андрей Щ

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-28
  • Сайт: 
  • Профессия: Ученик 1С
всем привет! делаю веб-сервис в 1с. получилось так, что необходимо объединить два запроса. Проблема в том, что я не знаю как правильно их нужно объединить т.к. моя программа написанная на си шарпе. выдает ошибку. мол в 15 строке ожидается конец функции, и как раз таки на 15 строке происходит объединение второго запроса.

Функция get_all()Экспорт
ДатаОтчета = Дата(dataString);
списокСотрудников="<a>";
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ

| РаботникиОрганизацийСрезПоследних.Должность.Наименование КАК Долж,
| РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации.Наименование КАК Подразд,
| РаботникиОрганизацийСрезПоследних.Сотрудник.Наименование КАК ФИО
|
    |     ИЗ
| РегистрСведений.РаботникиОрганизаций.СрезПоследних КАК РаботникиОрганизацийСрезПоследних
|
|ОБЪЕДИНИТЬ
|   ВЫБРАТЬ
|      ВЫБОР
| КОГДА СостояниеРаботниковОрганизацийСрезПоследних.ПериодЗавершения >= &ДатаОтчета
| ИЛИ СостояниеРаботниковОрганизацийСрезПоследних.ПериодЗавершения = &НулеваяДата
| ТОГДА СостояниеРаботниковОрганизацийСрезПоследних.Состояние
| ИНАЧЕ СостояниеРаботниковОрганизацийСрезПоследних.СостояниеЗавершения
| КОНЕЦ КАК Поле1,
| РаботникиОрганизацийСрезПоследних.Сотрудник
|ИЗ
| РегистрСведений.РаботникиОрганизаций.СрезПоследних(&ДатаОтчета) КАК РаботникиОрганизацийСрезПоследних
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.СостояниеРаботниковОрганизаций.СрезПоследних(&ДатаОтчета) КАК СостояниеРаботниковОрганизацийСрезПоследних
| ПО (СостояниеРаботниковОрганизацийСрезПоследних.Сотрудник = РаботникиОрганизацийСрезПоследних.Сотрудник)";

Запрос.УстановитьПараметр("ДатаОтчета", ДатаОтчета);
    Запрос.УстановитьПараметр("НулеваяДата", '00010101');
Статус ="Не работает";

Результат = Запрос.Выполнить();
     ВыборкаДетальнойЗаписи = Результат.Выбрать();

Пока ВыборкаДетальнойЗаписи.Следующий() Цикл
  Если (ВыборкаДетальныеЗаписи.Сотрудник.ДатаУвольнения >= ДатаОтчета) ИЛИ (ВыборкаДетальныеЗаписи.Сотрудник.ДатаУвольнения = '00010101') Тогда
Если ВыборкаДетальныеЗаписи.Поле1 = null Тогда
Статус ="Работает";
Иначе

temp = ВыборкаДетальныеЗаписи.Поле1;
Статус =Строка(temp);
КонецЕсли;
КонецЕсли;

  списокСотрудников=списокСотрудников+"<b><c>"+сокрЛП(ВыборкаДетальнойЗаписи.Долж)+"</c></b>"+"<b><c>"+сокрЛП(ВыборкаДетальнойЗаписи.Подразд)+"</c></b>" +"<b><c>"+сокрЛП(ВыборкаДетальнойЗаписи.ФИО)+"</c></b>"+сокрЛП(ВыборкаДетальнойЗаписи.Поле1)+"</c></b>"; 
 КонецЦикла;
 
 списокСотрудников=списокСотрудников+"</a>";
возврат СписокСотрудников

КонецФункции

и езе проблема в том, что данные до этого вернее до объедингения двух запросов выводились в одну строчку. как сделать чтоб данные выводились как в таблице( по колонкам вернее). за это отвечает этот код :
СписокСотрудников=списокСотрудников+"<b><c>"+сокрЛП(ВыборкаДетальнойЗаписи.Долж)+"</c></b>"+"<b><c>"+сокрЛП(ВыборкаДетальнойЗаписи.Подразд)+"</c></b>" +"<b><c>"+сокрЛП(ВыборкаДетальнойЗаписи.ФИО)+"</c></b>"+сокрЛП(ВыборкаДетальнойЗаписи.Поле1)+"</c></b>";  
 КонецЦикла;


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
В объединении запросов главное правило полей выбрано должно быть одинаковое количество во всех объединяемых запросах
Добавлено: 03 Июн 2013, 12:50

Т.е.

Выбрать Сумма, Номенклатура, Контрагент Из Чегото
Объединить
Выбрать Сумма2, Номенклатура2, NULL ИЗ Чегото2


//То поле которого нет во втором запросе заменяем на NULL, ну либо на какое то другое значение, например на "0" (Пример выше)
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги: запросы  
 

Объединение конфигураций "Документооборот гос. учреждения" и "Гос. и муницип. закупки"

Автор Рената МарсельевнаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1564
Последний ответ 19 Янв 2015, 20:02
от дфтын
Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6358
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев
Возможно ли языком запросов без конкатенации текста запроса и без СКД преобразовать строки таблицы в столбцы (колонки) выходной таблицы?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 441
Последний ответ 29 Май 2017, 15:29
от alex0402
Какую консоль запросов используете вы в управляемом приложении или что за консоль в видео?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 390
Последний ответ 17 Апр 2017, 09:40
от LexaK
Объединение организации-кредитора и организации-должника

Автор newsРаздел Новости

Ответов: 0
Просмотров: 857
Последний ответ 11 Авг 2015, 12:26
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 784
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal