Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 20:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Префикс и нумерация в отдельном документе, БП 7.7  (Прочитано 8570 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
Добрый день, столкнулся с проблемой, при создании документам Поступлении товаров авт. заполняется номер документа "ПК1000", пробовал менять его, но следующий документ создается снова с этим же номером. В других документах нумерация совсем другая (бывает даже без префикса). Вот эту фишку БП 7.7 я не понял... в 8ке совсем не так. Подскажите как назначить префикс и запустить авт. нумерацию например "НМ0001" ?
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/


Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Посмотрите, стоит ли в документе признак Автонумерация?

Какая конфигурация?


Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
Посмотрите, стоит ли в документе признак Автонумерация?
подскажите пожалуйста где проверить данный признак...
Какая конфигурация?
Бух учет, ред 4.4 7.70.446
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
подскажите пожалуйста где проверить данный признак...

в конфигураторе, на документе делаете правый клик мыши, пункт Редактировать (НЕ "редактировать форму")
и там будет поле для установки флажка "Автоматическая нумерация".

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
в конфигураторе, на документе делаете правый клик мыши, пункт Редактировать (НЕ "редактировать форму")
и там будет поле для установки флажка "Автоматическая нумерация".
галка "Автоматическая нумерация" стоит, тип - текстовый.
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Каждый раз один и тот же номер "ПК1000"? именно так?
В модуле формы документа, перейдите к процедуре ВводНового()
и пришлите сюда содержимое этой процедуры

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
Каждый раз один и тот же номер "ПК1000"? именно так?
да

Процедура ВводНового(Копирование) //предопределенная

Новый = 1;
УстановитьНовыйНомер("ПК");
ВерсияОбъекта = Константа.НомерРелиза;
Если Копирование = 1 Тогда //копирование документа
    Возврат;
КонецЕсли;

//Для ввода нового документа из журнала "Счета-фактуры выданные"
//в качестве параметра передается контрагент.
    Если ПустоеЗначение(Форма.Параметр) = 0 Тогда
    Контрагент = Форма.Параметр.Получить("Контрагент");
КонецЕсли;

МестоХранения = глЗначениеПоУмолчанию("ОсновнойСклад");
ВидПоступления = 0; //на розничный склад
ЗачитыватьАванс = 0;
ВариантРасчетаНалогов = Константа.ОсновнойВариантРасчетаНалогов;
Если Константа.ОрганизацияЯвляетсяПлательщикомНДС = Нет Тогда
НДСвключатьВСтоимость = 1;
КонецЕсли;
КонецПроцедуры //ВводНового
Добавлено: 03 Июн 2013, 12:13

как я понял, префикс как раз тут задается...
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
как я понял, префикс как раз тут задается...

попробуйте закомментрировать строку УстановитьНовыйНомер("ПК");

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
попробуйте закомментрировать строку УстановитьНовыйНомер("ПК");
попробовал, счет работает нормально. Спасибо! Я как понял это чья то доработка.
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 253
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal