Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 12:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: веб сервис для 1с 8.2  (Прочитано 6673 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Андрей Щ

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-28
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет! Учусь делать веб-сервисы на 1с 8.2. Имеется конфигурация зуп.
Имеется еще один веб-сервис...он мне служит образцом...внутри него есть код вернее запрос:
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ВЫБОР
| КОГДА СостояниеРаботниковОрганизацийСрезПоследних.ПериодЗавершения >= &ДатаОтчета
| ИЛИ СостояниеРаботниковОрганизацийСрезПоследних.ПериодЗавершения = &НулеваяДата
| ТОГДА СостояниеРаботниковОрганизацийСрезПоследних.Состояние
| ИНАЧЕ СостояниеРаботниковОрганизацийСрезПоследних.СостояниеЗавершения
| КОНЕЦ КАК Поле1,
| РаботникиОрганизацийСрезПоследних.Сотрудник
   
|ИЗ

| РегистрСведений.РаботникиОрганизаций.СрезПоследних(&ДатаОтчета, Сотрудник.Код = &ТабНом) КАК РаботникиОрганизацийСрезПоследних
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.СостояниеРаботниковОрганизаций.СрезПоследних(&ДатаОтчета, Сотрудник.Код = &ТабНом) КАК СостояниеРаботниковОрганизацийСрезПоследних
| ПО (СостояниеРаботниковОрганизацийСрезПоследних.Сотрудник = РаботникиОрганизацийСрезПоследних.Сотрудник)";

Запрос.УстановитьПараметр("ДатаОтчета", ДатаОтчета);
Запрос.УстановитьПараметр("ТабНом", tabNum);
Запрос.УстановитьПараметр("НулеваяДата", '00010101');
Статус =tabNum+"Не работает";

Результат = Запрос.Выполнить();                         
ВыборкаДетальныеЗаписи = Результат.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий()Цикл
Если (ВыборкаДетальныеЗаписи.Сотрудник.ДатаУвольнения >= ДатаОтчета) ИЛИ (ВыборкаДетальныеЗаписи.Сотрудник.ДатаУвольнения = '00010101') Тогда
Если ВыборкаДетальныеЗаписи.Поле1 = null Тогда
Статус =tabNum+"Работает";
Иначе

temp = ВыборкаДетальныеЗаписи.Поле1;
Статус =tabNum+Строка(temp);
КонецЕсли;

КонецЕсли;
КонецЦикла;

сейчас сам создал еще один веб-сервис...но загвоздка в коде...(как понял из выше-следующего, буду использовать запрос..для получения нужных мне данных.(мне необходимо запросом извлечь фио всех сотрудников. ). И как запрос создать в самом веб-сервисе? и как проверить правильность запроса? т.е. мне лучше для обучения создать обработку..и в ней забить свой запрос?


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
В инете инфы навалом
http://katalog.forum-1c.ru/public/102172/
http://howknow1c.ru/programmirovanie-1c/web-servisy-1s.html
Добавлено: 28 Май 2013, 10:50

Про мисту забыл
http://kb.mista.ru/article.php?id=473
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги: 1С 8.2 веб 
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4295
Последний ответ 24 Дек 2015, 15:34
от дфтын
Модуль "сервис " на базе 1.С Предприятие 8.0

Автор Vlad-batiskafРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2471
Последний ответ 26 Ноя 2011, 02:58
от Dethmontt
Нужен совет в подключении к системе спутникового мониторинга "renault-trucks(Optifleet)", через web-сервис!

Автор snoop82Раздел Беседка

Ответов: 0
Просмотров: 791
Последний ответ 11 Дек 2015, 06:56
от snoop82
Уважаемые коллеги! Помогите найти брошюру: "ИТС. Памятка сервис инженера"

Автор MixmaisterРаздел Закрытые темы

Ответов: 0
Просмотров: 3075
Последний ответ 09 Янв 2012, 20:36
от Mixmaister
Появился сервис по онлайн проверке корректности заполнения счет-фактур

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1268
Последний ответ 13 Авг 2014, 12:52
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 265
  • Точка Скрытых: 1
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal