Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 10:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получение и изменение данных таблицы  (Прочитано 4587 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн yogi

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-24
  • Сайт: 
Добрый день!

Подскажите как программно изменить данные которые внесены в таблицу на форме Отчета.

У меня есть таблица:
ЭтаФорма.ЭлементыФормы.Товары
Мне надо во всех ячейках колонки СчетРасходов изменить внесенные в нее данные.
Как решать эту задачу, направьте в нужном направление.


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
В отчете?
Таблица какой тип имеет?
Табличный документ? Таблица значений? Табличная часть? ...???????
Добавлено: 24 Май 2013, 22:55

Управляемые или обычные формы? Конфигурация какая? Какой отчет?
Добавлено: 24 Май 2013, 22:56

подробнее описывайте свои задачи, быстрее получите ответ!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн yogi

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-24
  • Сайт: 
В отчете?
Я не точно сказал, это документ:
Документы->ОтчетОРозничныхПродажах
Надо внести изменения в форму: ФормаДокумента,
В две колонки таблицы: "СчетРасходов" и "СчетДоходов" их тип: "ПланСчетовСсылка.Хозрасчетный".
Если в форме выбрать таблицу, то в ее свойствах будет следующий тип:
ДокументТабличнаяЧасть.ОтчетОРозничныхПродажах.Товары

Какая конфигурация не могу сказать, по роду деятельности я далек от мира 1с.
Поэтому вот ссылка на саму конфигурацию: конфигурация

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Процедура КнопкаВыполнить(Кнопка)
  //Инициализация переменных
  СчетРасходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("20.01"); //Счет на который будем менять

  //код программы
  Состояние("Обработка документов...");
  Выборка = Документы.ОтчетОРозничныхПродажах.Выбрать();
  Пока Выборка.Следующий() Цикл
     Объект = Выборка.ПолучитьОбъект();
     Для каждого Стр Из Объект.Товары Цикл
        Стр.СчетРасходов = СчетРасходов;
     КонецЦикла;
     Объект.ОбменДанными.Загрузка = истина;
     Объект.Записать();
  КонецЦикла;
  Состояние();
  Предупреждение("Обработка выполнена");
КонецПроцедуры
Но можно воспользоваться типовой обработкой (Групповая обработка справочников и документов)
Добавлено: 25 Май 2013, 23:06

В этой теме обсуждалась эта обработка - http://forum-1c.ru/index.php?topic=28927.0;msg=86757
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн yogi

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-24
  • Сайт: 
Процедура КнопкаВыполнить(Кнопка)
  //Инициализация переменных
  СчетРасходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("20.01"); //Счет на который будем менять

  //код программы
  Состояние("Обработка документов...");
  Выборка = Документы.ОтчетОРозничныхПродажах.Выбрать();
  Пока Выборка.Следующий() Цикл
     Объект = Выборка.ПолучитьОбъект();
     Для каждого Стр Из Объект.Товары Цикл
        Стр.СчетРасходов = СчетРасходов;
     КонецЦикла;
     Объект.ОбменДанными.Загрузка = истина;
     Объект.Записать();
  КонецЦикла;
  Состояние();
  Предупреждение("Обработка выполнена");
КонецПроцедуры
Но можно воспользоваться типовой обработкой (Групповая обработка справочников и документов)
Добавлено: 25 Май 2013, 23:06

В этой теме обсуждалась эта обработка - http://forum-1c.ru/index.php?topic=28927.0;msg=86757

Большое спасибо!


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7457
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3891
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2127
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7378
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6970
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
52 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 242
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal