Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 23:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: СписокЗначений Добавить интерактивно  (Прочитано 5071 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Березин

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2011-12-31
  • Сайт: 
  • Профессия: Бухгалтер
Есть СписокЗначений: Список.
Он отображается на форме в реквизите: СписокРеквизит.
Кнопкой этого реквизита "Добавить" добавляю в список.
А дальше что?
Как мне этот НОВЫЙ список обратно в код на модуле "загнать"? То есть, чтобы программа подождала пока я добавлю интерактивно, а потом только - по моей отмашке - сработало:

Список = СписокРеквизит?


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ФОРМЫ УПРАВЛЯЕМЫЕ?
Добавлено: 23 Май 2013, 23:05

Платформа 8.0 или 7.7 или 6.0?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Березин

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2011-12-31
  • Сайт: 
  • Профессия: Бухгалтер
ФОРМЫ УПРАВЛЯЕМЫЕ?
Добавлено: 23 Май 2013, 23:05

Платформа 8.0 или 7.7 или 6.0?
8.2 и управляемая форма
ПС
Я вообще стараюсь создать тему в соответстующем разделе.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Пожалуйста, постарайтесь еще писать заранее (не дожидаясь пока спросят) УФ или Обычные формы и вашу конфигурацию!
Добавлено: 23 Май 2013, 23:58

Разумеется конфигурацию нужно указывать если это имеет место быть
Добавлено: 24 Май 2013, 00:23

И так.
Мы разобрались что у вас есть Управляемая форма и на ней список значений (Таблицей или полем)?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Последний раз редактировалось: Dethmontt; 24 Май 2013, 00:23. Причина: Объединение сообщений

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура СписокПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)

Для Каждого Зн Из Список Цикл
Сообщить(Зн.Значение);
КонецЦикла;

КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Березин

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2011-12-31
  • Сайт: 
  • Профессия: Бухгалтер

И так.
Мы разобрались что у вас есть Управляемая форма и на ней список значений (Таблицей или полем)?
У меня реквизит Таблицей с созданными системой колонками.
Процедура СписокПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
   
    Для Каждого Зн Из Список Цикл
        Сообщить(Зн.Значение);
    КонецЦикла;   
   
КонецПроцедуры
А здесь я вообще не вижу с чем мне эту процедуру есть и вообще откуда она взялась.
Но может с утра на свежую голову...

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Эта процедура - Событие списка значений (СПИСОК)
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Березин

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2011-12-31
  • Сайт: 
  • Профессия: Бухгалтер
Процедуру я нашел, но как не кручу не могу сообразить как ей воспользоваться.
Что здесь "элемент"?
Не нашел ее описания во встроенном справочнике.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Ищи по слову - ПриОкончанииРедактирования
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 297
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal