Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 10:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печать ценников.Обработка  (Прочитано 8062 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Всем привет!Озадачился с печатью ценников через обработку.Вывел данные которые мне нужны а как вывести в макет их, недоумеваю.В документах у меня получается а здесь как-то иначе мне кажется.Подскажите пожалуйста. :mellow:



&НаКлиенте
Процедура Заполнить(Команда)
       ЗаполнитьНаСервере()

КонецПроцедуры


&НаСервере
Процедура ЗаполнитьНаСервере()
       //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ЦеныРозничныеСрезПоследних.Номенклатура,
      |   ЦеныРозничныеСрезПоследних.ЦенаРозничная
      |ИЗ
      |   РегистрСведений.ЦеныРозничные.СрезПоследних(
      |         ,
      |         Номенклатура = &И_Номенклатура
      |            И ВидЦены = &И_ВидЦены) КАК ЦеныРозничныеСрезПоследних";

   Запрос.УстановитьПараметр("И_ВидЦены", ВидЦен);
   Запрос.УстановитьПараметр("И_Номенклатура", Товар);

   Результат = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = Результат.Выбрать();

   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      // Вставить обработку выборки ВыборкаДетальныеЗаписи
   КонецЦикла;
   
   

   
   //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

КонецПроцедуры





Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
МАКЕТ = ПолучитьМакет("МойМакет");
//И дальше все по тому же сценарию
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
МАКЕТ = ПолучитьМакет("МойМакет");
//И дальше все по тому же сценарию

Создавать надо новую процедуру или в этой же?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Как вашей душе угодно
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Yura063

  • *****
  • Сообщений: 1050
  • РЕПУТАЦИЯ: 137
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: 
  • Профессия: Программист 1С
Всем привет!Озадачился с печатью ценников через обработку.Вывел данные которые мне нужны а как вывести в макет их, недоумеваю.В документах у меня получается а здесь как-то иначе мне кажется.Подскажите пожалуйста
Все так же, как получить макет вам сказали дальше получаете области и присваиваете значение полученные в запросе параметрам из определенной области. Выводите область на экран.

Помогли, отблагодари!

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Всем спасибо) Понял

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
конструктор запроса с обработкой результата -> выберите Тип обработки  -> Вывод в табличный документ, а там уже настраивайте созданный макет как душе угодно

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
конструктор запроса с обработкой результата -> выберите Тип обработки  -> Вывод в табличный документ, а там уже настраивайте созданный макет как душе угодно

Спасибо)
Добавлено: 20 Май 2013, 16:42

еще такой вопрос. Мне нужно заполнить Табличную часть В ПечатиЦенников. Пытаюсь заполнить а заполняется только Код.

   Запрос = Новый Запрос;
   Запрос.Текст =  "ВЫБРАТЬ
                   |   Номенклатура.Наименование,
                   |   Номенклатура.Код,
                   |   Номенклатура.Аналоги.(
                   |      ЦенаПродажи
                   |   )
                   |ИЗ
                   |   Справочник.Номенклатура КАК Номенклатура";
   Запрос.УстановитьПараметр("Номенклатура",Товар);

   Выборка= Запрос.Выполнить().Выгрузить();
   
   Объект.Отобранные.Загрузить(Выборка);



Последний раз редактировалось: Kostik2013; 20 Май 2013, 16:42. Причина: Объединение сообщений

Оффлайн Yura063

  • *****
  • Сообщений: 1050
  • РЕПУТАЦИЯ: 137
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: 
  • Профессия: Программист 1С
Проверьте соответствие полей!
Добавлено: 20 Май 2013, 16:46

поля в запросе должны соответствовать полям в ТЧ
Помогли, отблагодари!

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Проверьте соответствие полей!
Добавлено: 20 Май 2013, 16:46

поля в запросе должны соответствовать полям в ТЧ

Да нет,все идентично
Добавлено: 20 Май 2013, 19:31

Проверьте соответствие полей!
Добавлено: 20 Май 2013, 16:46

поля в запросе должны соответствовать полям в ТЧ

Да нет,все идентично

:dfbsdfbsdf::dfbsdfbsdf::dfbsdfbsdf:

Последний раз редактировалось: Kostik2013; 20 Май 2013, 19:31. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
oleg-x
56 Сообщений
AIFrame AIFrame
51 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
alexandr_ll
30 Сообщений

* Кто онлайн

  • Точка Гостей: 148
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal