Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 03:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите разобраться с ошибкой в коде  (Прочитано 3127 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
Процедура РассчитатьНачисления(НаборЗаписейРегистра, ТребуемыйВидРасчета, СписокСотрудников)Экспорт
   
   Регистратор=НаборЗаписейРегистра.Отбор.Регистратор.Значение;
   
   //Рассчитать первичные записи
   Если  ТребуемыйВидРасчета=ПланыВидовРасчета.ОсновныеНачисления.Оклад Тогда
      
      Запрос = НовыйЗапрос;
      Запрос.Текст =
      "ВЫБРАТЬ
      |   НачисленияДанныеГрафика.ЗначениеПериодДействия,
      |   НачисленияДанныеГрафика.ЗначениеФактическийПериодДействия,
      |   НачисленияДанныеГрафика.НомерСтроки,
      |ИЗ
      |   РегистрРасчета.Начисления.ДанныеГрафика (Регистатор=&Регистратор И
      |   ВидРасчета=&ВидРасчета И Сотрудник В (&СписокСотрудников))
      |                              КАК НачисленияДанныеГрафика";
      
      Запрос.УстановитьПараметр("Регистратор", Регистратор);
      Запрос.УстановитьПараметр("ВидРасчета", ТребуемыйВидРасчета);
      Запрос.УстановитьПараметр("СписокСотрудников", СписокСотрудников);
      
      ВыборкаРезультата=Запрос.Выполнить().Выбрать();
      
      Для Каждого ЗаписьРегистра Из НаборЗаписейРегистра Цикл
         СтруктураНомер=Новый Структура("НомерСтроки");
         СтруктураНомер.НомерСтроки=ЗаписьРегистра.НомерСтроки;
         ВыборкаРезультата.Сбросить();                       
         Если ВыборкаРезультата.НайтиСледующий(СтруктураНомер) Тогда
            Если ВыборкаРезультата.Норма=0 тогда
               Сообщить("Вид расчета: Оклад - Нет рабочих дней в заданном периоде",);
               ЗаписьРегистра.Результат=0;
            Иначе
               //Рассчитать оклад по фактическому периоду и исходным данным
               ЗаписьРегистра.Результат=(ЗаписьРегистра.ИсходныеДанные/ВыборкаРезультата.Норма)*ВыборкаРезультата.Факт;
               Сообщить("Выполнен расчет"+ЗаписьРегистра.Регистратор + "-" + ЗаписьРегистра.ВидРасчета + "-" +ЗаписьРегистра.Сотрудник,);
            КонецЕсли;
         КонецЕсли;
      КонецЦикла;
      
      
      //Рассчитать вторичные записи
   ИначеЕсли ТребуемыйВидРасчета=ПланыВидовРасчета.ОсновныеНачисления.Премия Тогда
      
      Запрос=НовыйЗапрос;
      Запрос.Текст="ВЫБРАТЬ
      |   НачисленияБазаНачисления.РезультатБаза КАК База,
      |   НачисленияБазаНачисления.НомерСтроки
      |ИЗ
      |   РегистрРасчета.Начисления.БазаНачисления(&ИзмеренияОснового,&ИзмеренияБазвого,Регистратор=&Регистратор И ВидРасчета=&ВидРасчета И
      |   Сотрудник В (&СписокСотрудникоов)) КАК НачисленияБазаНачисления";
      
      
      Измер=НовыйМассив(1);
      Измер[0]="Сотрудник";
      
      Запрос.УстановитьПараметр("ИзмеренияОсновного",Измер);
      Запрос.УстановитьПараметр("ИзмеренияБазового",Измер);
      Запрос.УстановитьПараметр("Регистратор",Регистратор);
      Запрос.УстановитьПараметр("ВидРасчета",ТребуемыйВидРасчета);
      Запрос.УстановитьПараметр("СписокСотрудник",СписокСотрудник);
      
      ВыборкаРезультата=Запрос.Выполнить().Выбрать();
      Для Каждого ЗаписьРегистра Из НаборЗаписейРегистра Цикл
         СтруктураНомер=НовыйСтруктура("НомерСтроки");
         
         СтруктураНомер.НомерСтроки=ЗаписьРегистра.НомерСтроки;
         ВыборкаРезультата.Сбросить();
         Если ВыборкаРезультата.НайтиСледующий(СтруктураНомер)
            Тогда
            ЗаписьРегистра.Результат=ВыборкаРезультата.База* (10/100);
            Сообщить("Выполнен расчет"+ Запись.Регистра.Регистратор+ "-" + ЗаписьРегистра.ВидРасчета + "-" + ЗаписьРегистра.Сотрудник,);
            
            
         КонецЕсли;
         
         
      КонецЕсли;
      
      
      
   КонецПроцедуры
   
   
   


Оффлайн ildarik_58

  • *
  • Сообщений: 43
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-26
  • Сайт: 
  • Профессия: Ученик 1С
вот пишет ошибку {ОбщийМодуль.ПроведениеРасчетов.Модуль(78,3)}: Ожидается ключевое слово 'КонецЦикла' ('EndDo')
      <<?>>КонецЕсли; (Проверка: Толстый клиент (обычное приложение))

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
ВыборкаРезультата=Запрос.Выполнить().Выбрать();
      Для Каждого ЗаписьРегистра Из НаборЗаписейРегистра Цикл //здесь у вас ничинается цикл
         СтруктураНомер=НовыйСтруктура("НомерСтроки");
         
         СтруктураНомер.НомерСтроки=ЗаписьРегистра.НомерСтроки;
         ВыборкаРезультата.Сбросить();
         Если ВыборкаРезультата.НайтиСледующий(СтруктураНомер)
            Тогда
            ЗаписьРегистра.Результат=ВыборкаРезультата.База* (10/100);
            Сообщить("Выполнен расчет"+ Запись.Регистра.Регистратор+ "-" + ЗаписьРегистра.ВидРасчета + "-" + ЗаписьРегистра.Сотрудник,);
         
         КонецЕсли;
      КонецЦикла; //а здесь должен заканчиваться


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4291
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5549
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5884
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4361
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1976
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 236
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal