Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 02:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как достать изображения в УНФ 1.4  (Прочитано 3993 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Начинающий 1с

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-30
  • Сайт: 
  • Профессия: Программист 1С
Платформа 8.2, конфа УНФ 1.4
Подскажите пожалуйста как из справочника файла сохранить картинку на диск?

пользовался этими функциями (РаботаСФайламиСлужебныйВызовСервера.ПолучитьДанныеФайлаДляСохранения);
( РаботаСФайламиКлиент.СохранитьКак);
но ничего не сохраняется


Оффлайн Жукова

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-17
  • Сайт: 
  • Профессия: Программист 1С
А не лежат ли эти картинки в хранилище значений? Если да, то обращаться надо к нему.

Оффлайн Начинающий 1с

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-30
  • Сайт: 
  • Профессия: Программист 1С
СтруктураПоиска =  Новый Структура;
         
Если ЗначениеЗаполнено(ТекСтр.Номенклатура.ФайлКартинки) Тогда
   
СправочникФайлы = Справочники.Файлы.Выбрать();
            
Пока СправочникФайлы.Следующий() Цикл
               СтруктураПоиска.Вставить("Номенклатура", СправочникФайлы.ВладелецФайла);
               
НайденныеСтроки=Результат.Найти(СправочникФайлы.ВладелецФайла,"Номенклатура");
                              Если НайденныеСтроки = Неопределено Тогда                   Продолжить;
КонецЕсли;
                              МестоДляСохранения = КаталогВременныхФайлов();
               
ДанныеФайлаДляСохранения = РаботаСФайламиСлужебныйВызовСервера.ПолучитьДанныеФайлаДляСохранения(ТекСтр.Номенклатура.ФайлКартинки, Неопределено,,МестоДляСохранения);               Картинка =   Новый Картинка;
Картинка.Записать(ДанныеФайлаДляСохранения.ИмяФайлаСПутемВРабочемКаталоге);
                              КартинкаНаПечать  =  Картинка;
                           КонецЦикла;
КонецЕсли;                                           Область.Рисунки.D1.Картинка  = КартинкаНапечать;

вот так писал:
НайденнаяКартинка=
НайденныеСтроки.Номенклатура.ФайлКартинки.ТекущаяВерсия.ФайлХранилище.Получить();
но он там ничего не получает пишет "неопределено"
         

Оффлайн Начинающий 1с

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-30
  • Сайт: 
  • Профессия: Программист 1С
Запрос = Новый Запрос;
         Запрос.Текст =
         "ВЫБРАТЬ
         |   Файлы.Ссылка,
         |   ХранимыеФайлыВерсий.ХранимыйФайл
         |ИЗ
         |   Справочник.Файлы КАК Файлы
         |      ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ВерсииФайлов КАК ВерсииФайлов
         |         ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ХранимыеФайлыВерсий КАК ХранимыеФайлыВерсий
         |         ПО ВерсииФайлов.Ссылка = ХранимыеФайлыВерсий.ВерсияФайла.Ссылка
         |      ПО Файлы.ТекущаяВерсия = ВерсииФайлов.Ссылка
         |ГДЕ
         |   ВерсииФайлов.ТипХраненияФайла = &ТипХраненияФайла";
         Запрос.УстановитьПараметр("ТипХраненияФайла",Перечисления.ТипыХраненияФайлов.ВИнформационнойБазе);   
         Результат = Запрос.Выполнить();
         ВыборкаДетальныеЗаписи = Результат.Выбрать();
         
         Отбор = Новый Структура;
         
         Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            
            Отбор.вставить("Номенклатура", ВыборкаДетальныеЗаписи.Ссылка.ВладелецФайла);   
            
            НайденныеСтроки = Результат2.НайтиСтроки(Отбор);            
            Если НайденныеСтроки.Количество() = 0 Тогда
               Продолжить;
            КонецЕсли;
            
            ИмяВременногоФайла = ПолучитьИмяВременногоФайла("jpg");
            
            Картинка = ВыборкаДетальныеЗаписи.ХранимыйФайл.Получить();
            
            Область.Рисунки.D1.Картинка  = Новый Картинка(ИмяВременногоФайла);
            
            Попытка
               УдалитьФайлы(ИмяВременногоФайла);   
            Исключение
               Сообщить(ОписаниеОшибки());
            КонецПопытки;
            
         КонецЦикла;

         //Проверка границы табличного документа
         Если НЕ ТабДок.ПроверитьПрисоединение(МассивОбластей) тогда
            
            ТабДок.вывести(Область);
         Иначе
            ТабДок.присоединить(Область);
         КонецЕсли;
         Разделитель = Истина;
         
      КонецЦикла;
      
      Возврат ТабДок;

в этой строке "Картинка = ВыборкаДетальныеЗаписи.ХранимыйФайл.Получить();" я получаю картинку, но картинку первую из запроса и получается только с нею работаю,
Подскажите пожалуйста как получить картинку из НайденныхСтрок, т.е картинку той номенклатуры которая есть в запросе ДетальныеЗаписи(запрос на спр файлы) и из запроса: резальтат2(запрос на регистр цены номенкл)



Теги:
 

Подписка на события "ПриЗаписи", как достать измененные категории

Автор blackbeardРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3695
Последний ответ 17 Окт 2014, 09:19
от blackbeard
Очень интересный способ! Как из данных достать текст?

Автор zkolenkoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 18
Просмотров: 13520
Последний ответ 20 Май 2011, 20:26
от zkolenko
Можно ли достать конфиг.УТ с возможностью редактирования

Автор AxOnРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2515
Последний ответ 27 Апр 2011, 17:30
от cska-fanat-kz
Где можно достать готовые макеты для документов??

Автор SpiritDarkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2436
Последний ответ 02 Дек 2011, 14:10
от AntonB
Как достать регламентированный отчет из конфигурации?

Автор Andy63Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 5824
Последний ответ 08 Ноя 2011, 12:36
от comol

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 162
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal