Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 22:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как передать реквизит в табличную часть при вводе на основании?  (Прочитано 7834 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Всем привет! Подскажите пожалуйста как передать реквизит в табличную часть при вводе на основании?Сделал ввод на основании,все передается кроме контрагента а он у меня реквизит и в табличную часть не передается,просто пусто, не заполняется.


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
	Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ВашДокумент") Тогда
// Заполнение шапки
Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл
НоваяСтрока = Товары.Добавить();
НоваяСтрока.Количество = ТекСтрокаТовары.Количество;
НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;
НоваяСтрока.Сумма = ТекСтрокаТовары.Сумма;
НоваяСтрока.Цена = ТекСтрокаТовары.Цена;
             НоваяСтрока.Контрагент = ДанныеЗаполнения.Контрагент;//В этой строке для каждой строки таб части заполняете контрагента
КонецЦикла;
КонецЕсли;

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
   //{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.РасходнаяНакладная") Тогда
      // Заполнение шапки
      Комментарий = ДанныеЗаполнения.Комментарий;
      Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл
         НоваяСтрока = ТабличнаяЧасть1.Добавить();
         НоваяСтрока.Сумма = ТекСтрокаТовары.СуммаГрн;
      КонецЦикла;
   ИначеЕсли ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.Продажа") Тогда
      // Заполнение шапки
      Комментарий = ДанныеЗаполнения.Комментарий;
      Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл
         НоваяСтрока = ТабличнаяЧасть1.Добавить();
         НоваяСтрока.Сумма = ТекСтрокаТовары.Сумма;
      КонецЦикла;
   КонецЕсли;
   //}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
КонецПроцедуры

Добавлено: 16 Май 2013, 15:10

НоваяСтрока.Контрагент = ДанныеЗаполнения.Контрагент;   Так не хочет,пусто...

Последний раз редактировалось: Kostik2013; 16 Май 2013, 15:10. Причина: Объединение сообщений

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
НоваяСтрока.Контрагент = ДанныеЗаполнения.Контрагент;   Так не хочет,пусто...
проверьте тип данных - Контрагент в таб части, должно быть СправочникСсылка.Контрагенты

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
НоваяСтрока.Контрагент = ДанныеЗаполнения.Контрагент;   Так не хочет,пусто...
проверьте тип данных - Контрагент в таб части, должно быть СправочникСсылка.Контрагенты

Так и есть)

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Тогда проверьте приходит ли данные и какие данные из документа основания!
Помогли, отблагодари!

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Тогда проверьте приходит ли данные и какие данные из документа основания!

Проходят все которые берутся именно из ТабЧасти а Контрагент пусто.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Так может в документе "Продажа" или "РасходнаяНакладная" не заполнен реквизит КОНТРАГЕНТ? Или имеет отличный тип
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Помогли, отблагодари!


Теги:
 

Реквизит "ГоловнойКонтрагент" в справочнике "Контрагенты"

Автор SergWolf07Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7138
Последний ответ 28 Авг 2011, 19:12
от SergWolf07
Часть четвертая: переход на «1С» версии «3.0». Где в программе находятся «Параметры учета»? Алгоритм настройки кадрового учета в новой версии программы «1С»

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 3958
Последний ответ 20 Мар 2015, 12:58
от 1cwiki
Реквизит "касса"

Автор AnterKanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2884
Последний ответ 11 Май 2012, 20:51
от AnterKan
Реквизит документа из другого документа

Автор slaviik3Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1531
Последний ответ 02 Ноя 2015, 12:04
от Kironten
1С 8.3 - Как присвоить стандартному реквизиту "Наименование" одного справочника, ссылку на реквизит другого справочника?

Автор АлирзаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 241
Последний ответ 09 Ноя 2017, 08:47
от alex0402

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 335
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal