Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 06:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сравнение данных из поля ввода на форме документа и справочника.  (Прочитано 3890 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн incl

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-14
  • Сайт: 
Здравствуйте!
Помогите, пожалуйста, с одной задачей.
Есть форма документа, на ней поле ввода данных ("формат"), в это поле значение выбирается из справочника Стоимости.
(Есть справочник, где каждому формату соответствует стоимость единицы его изготовления, (полиграфия))
(Стоимости.Формат, Стоимости.СтоимостьПечати).
Так вот, в итоге нужно сравнить данные из поля ввода на форме с данными из справочника, при совпадении "формата" посчитать стоимость(Стоимости.СтоимостьЕд*Тираж)
Бошка кипит, первый раз с 1с работаю.

Пока Стоимости.Следующий() Цикл
   Если Стоимости.Формат = ЭтаФорма.Формат Тогда
      СтоимостьПечати = Стоимости.СтоимостьПечати*Тираж*КолПолос;
   КонецЕсли
КонецЦикла?

Заранее спасибо, объяснил как смог.


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Запрос = Новый Запрос("ВЫБРАТЬ СтоимостьПечати ИЗ Справочник.Стоимости ГДЕ Формат = &Формат");
Запрос.УстановитьПараметр("Формат",Формат);
Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() Тогда
   Сообщить(Выборка.СтоимостьПечати*Тираж*КолПолос);
//Вам для отладки
Иначе
   Сообщить("В справочнике ""Стоимости"" не найдено Стоимости с форматом - "+Формат);
КонецЕсли;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн incl

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-14
  • Сайт: 
Т.е. в итоге при совпадении "формата" на форме с "форматом" из справочника
Стоимость = Выборка.СтоимостьПечати*Тираж*КолПолос;
будет подсчитана именно для "формата" отмеченного на форме документа?

Спасибо большое!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн incl

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-14
  • Сайт: 
Dethmontt, не подскажете, к кому можно обратиться за помощью в написании конфигурации? Уверен, что знающему человеку труда не составит вообще (такое ощущение, что на пару часов дел). Просто голова уже идет кругом, учусь на экономфаке, поэтому пришлось делать на 1с ничерта не разбираясь в нем. Естественно в долгу не останусь.
Ваш ответ загнал в еще больший тупик)

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн incl

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-14
  • Сайт: 


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4489
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15970
Последний ответ 16 Авг 2012, 12:07
от Will
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7760
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4792
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1598
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 223
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal