Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 21:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: СКД  (Прочитано 3815 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
СКД
« Первое сообщение: 08 Май 2013, 12:43 »
Добрый день. Необходимо в отчет вывести  Номенклатуру и 2 последним цены по ней. может кто подскажет. Спасибо


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Re: СКД
« Ответ #1: 08 Май 2013, 13:12 »
соедините две таблицы ЦеныНоменклатурыСрезПоследних и ЦеныНоменклатуры (физическая таблица), по полю номенклатура и выберите из обоих таблиц цену

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
Re: СКД
« Ответ #2: 08 Май 2013, 13:29 »
он выдает несколько строк номенклатуры с разными ценами

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Re: СКД
« Ответ #3: 12 Май 2013, 22:17 »
интересная задачка, с помощью СКД решить не удалось,кому не жалко своего времени - помогите решить
Добавлено: 12 Май 2013, 23:07

вот такой код получился
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЦеныНоменклатурыСрезПоследних.Номенклатура КАК Номенклатура,
| ЦеныНоменклатурыСрезПоследних.Цена КАК ПоследняяЦена,
| ЦеныНоменклатурыСрезПоследних.Период КАК ПоследнийПериод,
| ЦеныНоменклатуры.Цена КАК ПредыдущаяЦена,
| ЦеныНоменклатуры.Период КАК ПредыдущийПериод
|ИЗ
| РегистрСведений.ЦеныНоменклатуры.СрезПоследних(, ) КАК ЦеныНоменклатурыСрезПоследних
| ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры
| ПО ЦеныНоменклатурыСрезПоследних.Номенклатура = ЦеныНоменклатуры.Номенклатура
|ГДЕ
| ЦеныНоменклатуры.Период < ЦеныНоменклатурыСрезПоследних.Период
|
|УПОРЯДОЧИТЬ ПО
| ПредыдущийПериод УБЫВ
|ИТОГИ ПО
| Номенклатура";

РезультатЗапроса = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
ТабДок = РезультатЗапроса.Выгрузить();
Для каждого Строка Из  Табдок Цикл
       Если  Строка.ПредыдущаяЦена = Null Тогда
       Табдок.Удалить(Строка);
   КонецЕсли;
   КонецЦикла;

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
          Номенклатура = Неопределено;
Для каждого Строка Из  Табдок Цикл
Если  Строка.Номенклатура = Номенклатура Тогда
Номенклатура = Строка.Номенклатура;
Табдок.Удалить(Строка);
ВыборкаДетальныеЗаписи.Сбросить();
   Иначе
Номенклатура = Строка.Номенклатура;
             КонецЕсли;      
КонецЦикла;
КонецЦикла;
в ТаюДок попадает та номенклатура у которой хоть раз менялась цена, не попадает номенклатура которая продавалаь один раз, осталось только вывести ТабДок на экран

Последний раз редактировалось: Besart; 12 Май 2013, 23:07. Причина: Объединение сообщений

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: СКД
« Ответ #4: 12 Май 2013, 23:09 »
Через СКД

Добавлено: 13 Май 2013, 02:10

Немного подправил условия соединения
Добавил по характеристикам и типам цен (в принципе почти готовый отчет)

Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Последний раз редактировалось: Dethmontt; 13 Май 2013, 02:10. Причина: Объединение сообщений

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Re: СКД
« Ответ #5: 13 Май 2013, 09:18 »
Через СКД
не работает, так как у вас цена вынесена в ресурсы, то рассчитывается неверно, а если из ресурсов убрать, тогда цены вообще не выходят, я уже так пробовал и не смог победить

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: СКД
« Ответ #6: 13 Май 2013, 09:40 »
Так ты отбор по типу цен поставь.
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Re: СКД
« Ответ #7: 13 Май 2013, 10:13 »
а у меня нету типа цен, а вот рабочий отчет, в отчет не включается один раз проданная номенклатруа, можно было и ее попробовать включить, но надоело возиться


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 293
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal