Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Дек 2017, 01:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение поля цены справочника данными из регистра сведений  (Прочитано 8467 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн zverla3

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-07
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!Помогите пожалуйста новечку.
Создал Документ С реквизитом Товар,цена.При выборе Товара из справочника Номенклатура,нжно,чтобы цена заполнялась автоматически из регистра сведений,по последней дате.Напишете пожалуйста код запроса,и подробности.Очень надо.Заранее благодарен.


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
&НаКлиенте
 Процедура ТоварОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
Объект.Цена = ЦенаНаСервере(ВыбранноеЗначение);
 КонецПроцедуры
 
  &НаСервере
 Функция ЦенаНаСервере(Значение)

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЦеныНоменклатурыСрезПоследних.Цена КАК ЦенаНоменклатуры
|ИЗ
| РегистрСведений.ЦеныНоменклатуры.СрезПоследних КАК ЦеныНоменклатурыСрезПоследних
|ГДЕ
| ЦеныНоменклатурыСрезПоследних.Номенклатура = &Номенклатура";

Запрос.УстановитьПараметр("Номенклатура", Значение);
РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Если    ВыборкаДетальныеЗаписи.ЦенаНоменклатуры = Неопределено Тогда
Возврат 0;
Иначе
Возврат ВыборкаДетальныеЗаписи.ЦенаНоменклатуры;
КонецЕсли;

КонецЦикла;
         
 КонецФункции // ()


Оффлайн zverla3

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-07
  • Сайт: 
  • Профессия: Ученик 1С
Вы не правильно поняли мой вопрос.В Документе я выбираю товар из Справочника Номенклатура цены находяться в регистре сведений.Мне нужно чтобы при выборе товара в документе цена выходила автоматически из регистра сведений

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
так и запрос выбирает последнюю цену на выбранный товар из регистра сведений ЦеныНоменклатуры
цена выходила автоматически из регистра сведений
и затем присваиваете полученную цену реквизиту цена, все как вы хотели, или вы хотели чтобы цена выходила в сообщении?


Оффлайн zverla3

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-07
  • Сайт: 
  • Профессия: Ученик 1С
А немогли бы Вы,сделать код.Для Формы Документа.Товар при изменении и код:




С вашим подходом ошибка выходит.
Регистр Сведений Называется Цены.Нужный мне столбец в нем называется цена

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ЦеныСрезПоследних.Цены КАК ЦенаНоменклатуры
        |ИЗ
        |    РегистрСведений.Цены.СрезПоследних КАК ЦеныСрезПоследних
        |ГДЕ
        |    ЦеныСрезПоследних.Номенклатура = &Номенклатура";

если номенклатура называется по другому, то замените ЦеныСрезПоследних.Номенклатура на ЦеныСрезПоследних.ВашеНазвание, и не забудъте связать процедуру ТоварОбработкаВыбора с соответствующей процедурой из событий поля формы товар

Оффлайн zverla3

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-07
  • Сайт: 
  • Профессия: Ученик 1С
К сожелению не работает.Если можно может вы мою базу посмотрите 2мб всего весит

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1

Оффлайн zverla3

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-05-07
  • Сайт: 
  • Профессия: Ученик 1С
В яндексе не зареган.Мб на майл?

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
В яндексе не зареган.Мб на майл?
да пофигу куда, лишь бы можно было скачать


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6507
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2058
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 278
Последний ответ 12 Окт 2017, 14:02
от wise
Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 7613
Последний ответ 16 Авг 2012, 21:50
от Will
Работа с формой Справочника "Физ.Лица" в ЗУП 2.5

Автор Митя_Просто_МитяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3904
Последний ответ 15 Дек 2011, 00:04
от Vit1501

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
AIFrame
73 Сообщений
alex0402
52 Сообщений
ilyay ilyay
51 Сообщений
andron81_81
44 Сообщений
oleg-x
35 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 188
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal