Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 13:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внешняя печатная форма ТТН для требование накладной  (Прочитано 5295 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн demon3

  • **
  • Сообщений: 93
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2013-04-11
    • Skype: interavto88
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте,подскажите ,не работает внешняя печатная форма, создаю реквизит СсылкаНаОбъект,ищу процедуру печать в требование накладной,оттуда выдергиваю функцию печати требование накладной,в модуле объекта обработки создаю функцию печать с экспортом, и копирую содерживое функции печать из требование накладной! и нифига не работает,говорит не достаточно фактических параметров, и еще ругается на параметры функции печать из требование накладной(Ссылка, ИмяМакета). что с этими параметрами надо сделать,чтобы программа не ругалась на них что переменная не определена!?
Помог ответом, скажи спасибо


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
На сколько я помню надо все ссылки на документ поменять или подставить СсылкаНаОбъект. Например если в коде написано:
док = ссылка; //так сказать присвоение ссылки переменной, то тогда пишем
////////////////////////////////////////////////////////////////////////
док = СсылкаНаОбъект.Ссылка;
Помогли, отблагодари!

Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
что с этими параметрами надо сделать
:D

ссылку замени на СсылкаНаОбъект ну а ИмяМакета напиши СВОЁ
p.s. интересный у тебя подход к программированию ;-)

Добавлено: 07 Май 2013, 09:14

(1)
СсылкаНаОбъект.Ссылка

ссылка на обект - это и так ССЫЛКА! зачем УСЛОЖНЯТЬ ?
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн demon3

  • **
  • Сообщений: 93
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2013-04-11
    • Skype: interavto88
  • Сайт: 
  • Профессия: Программист 1С
Перем мВалютаРегламентированногоУчета Экспорт;

  Функция Печать()  Экспорт
 
  Перем ДополнительныеПараметры;
   
   ДвоичныеДанные = ИсточникМакета.СсылкаНаВнешнююОбработку.Принадлежность[ИсточникМакета.НомерСтроки - 1].ХранилищеВнешнейОбработки.Получить();
   
   // Получить дополнительные параметры внешней обработки
   ИсточникМакета.Свойство("ДополнительныеПараметрыОбработки", ДополнительныеПараметры);
   
   Если ДвоичныеДанные = Неопределено Тогда
      ДвоичныеДанные = ИсточникМакета.СсылкаНаВнешнююОбработку.ХранилищеВнешнейОбработки.Получить();
   КонецЕсли;
   
   Если ДвоичныеДанные = Неопределено Тогда
      Возврат Неопределено;
   КонецЕсли;
   
   ТабДокумент = Неопределено;
   
   ИмяФайла = ПолучитьИмяВременногоФайла("epf");
   Попытка
      ДвоичныеДанные.Записать(ИмяФайла);
      Обработка = ВнешниеОбработки.Создать(ИмяФайла);
      Обработка.СсылкаНаОбъект = Ссылка;
      
      // Передать внешней обработке дополнительные параметры
      Если ДополнительныеПараметры <> Неопределено Тогда
         
         // Если у внешней обработки есть реквизит для дополнительных параметров, присвоить ему значение
         Если НЕ Обработка.Метаданные().Реквизиты.Найти("ДополнительныеПараметры") = Неопределено Тогда
            Обработка.ДополнительныеПараметры = ДополнительныеПараметры;
         КонецЕсли;
         
      КонецЕсли;
      
      ТабДокумент = Обработка.Печать();
      УдалитьФайлы(ИмяФайла);
   Исключение
      ОбщегоНазначения.СообщитьОбОшибке(ОписаниеОшибки(),, "Не удалось сформировать внешнюю печатную форму!");
   КонецПопытки;
   
   Возврат ТабДокумент;

   
 
  КонецФункции // Печать()
   
 
 
 
 
 
мВалютаРегламентированногоУчета = глЗначениеПеременной("ВалютаРегламентированногоУчета");
пишу вот такую штуку,он еще ругается на Источник макета,подскажите правильно ли я делаю!?
Помог ответом, скажи спасибо

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
подскажите правильно ли я делаю!?
НЕТ!

Почитайте сначала Вот хорошая статейка
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Форма "Взнос наличными в банк" где она :)

Автор lefantiy_94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4674
Последний ответ 30 Июн 2015, 03:50
от lefantiy_94
Вопрос по УНФ (форма "Задание на работу")

Автор tantonyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 350
Последний ответ 22 Июн 2017, 18:22
от tantony
Как программно вызывать обработчик ПриИзменении поля табличной части после того, как форма была заполнена программно?

Автор ИстребительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4379
Последний ответ 27 Июл 2015, 06:21
от cska-fanat-kz
Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6404
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев
Шаблон или Форма для заполнения "заказа покупателя"

Автор SandrРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6613
Последний ответ 02 Сен 2013, 14:22
от LordWizard

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
55 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 264
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal