Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 21:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получение цены из регистра  (Прочитано 3383 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Soulidium

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2012-11-04
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Нужно получить цену из регистра сведений, при изменении в табличной части документа.
При попытке выполнения процедуры появляется ошибка:
{Документ.ОказаниеУслуг.Форма.ФормаДокумента.Форма(15)}: Ошибка при вызове метода контекста (ЦенаТарифа)
ЦенаТарифа(ТекДан);
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'param':
форма: Элемент
имя: {http://v8.1c.ru/8.2/managed-application/modules}param
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'ДанныеФормыЭлементКоллекции'
Сам код:
&НаКлиенте
Процедура ПокупкаАбониментаКоличествоТренировокПриИзменении(Элемент)
        ТекДан = Элементы.ПокупкаАбонимента.ТекущиеДанные;
        ЦенаТарифа(ТекДан);
КонецПроцедуры

&НаСервере
Функция ЦенаТарифа(ТекДан) Экспорт
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               | Тарифы.Цена
               |ИЗ
               | РегистрСведений.Тарифы КАК Тарифы
               |ГДЕ
               | Тарифы.ТипАбонимента = &ТипАбонимента
               | И Тарифы.КоличествоТренировок = &КоличествоТренировок";
Запрос.УстановитьПараметр("ТипАбонимента",ТекДан.ТипАбонимента);
Запрос.УстановитьПараметр("КоличествоТренировок",ТекДан.КоличествоТренировок);
Результат = Запрос.Выполнить().Выбрать();
Пока Результат.Следующий() Цикл
ТекДан.Цена = Результат.Цена;
КонецЦикла;
КонецФункции
Пытался сделать через Структуру Отбор, таже самая ошибка. Скажите пожалуйся, что я делаю не правильно?




Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура ПокупкаАбониментаКоличествоТренировокПриИзменении(Элемент)
        ТекДан = Элементы.ПокупкаАбонимента.ТекущиеДанные;
        ТекДан.Цена = ЦенаТарифа(ТекДан.ТипАбонимента,ТекДан.КоличествоТренировок);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ЦенаТарифа(ТипАбонимента,КоличествоТренировок) Экспорт
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    Тарифы.Цена
                   |ИЗ
                   |    РегистрСведений.Тарифы КАК Тарифы
                   |ГДЕ
                   |    Тарифы.ТипАбонимента = &ТипАбонимента
                   |    И Тарифы.КоличествоТренировок = &КоличествоТренировок";
    Запрос.УстановитьПараметр("ТипАбонимента",ТипАбонимента);
    Запрос.УстановитьПараметр("КоличествоТренировок",КоличествоТренировок);
    Цена = 0;
    Результат = Запрос.Выполнить().Выбрать();
    Если Результат.Следующий() Тогда
        Цена = Результат.Цена;   
    КонецЕсли;
    Возврат Цена;       
КонецФункции
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Остатки из бух. регистра в разрезе "добавленного" реквизита.

Автор ef0dinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 134
Последний ответ 20 Апр 2018, 17:06
от ef0din
Можно ли програмно изменить одну из колонок таблицы формы регистра сведений при создании формы

Автор RassvetniyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1605
Последний ответ 21 Фев 2016, 17:00
от vitasw
Запрос к виртуальной таблице регистра накопления: что писать в "Произвольном Выражении"?

Автор Светлана РождественскаяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 324
Последний ответ 27 Окт 2017, 21:02
от MuI_I_Ika
Заполнение регистра сведений "Авансы сотрудникам организаций"

Автор rielter_alРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1949
Последний ответ 02 Дек 2015, 11:50
от rielter_al
Верно ли, что при соединении с виртуальной таблицей остатков регистра накопления отбираются остатки по измерениям, перечисленным в условии соединения таблиц?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1005
Последний ответ 25 Ноя 2016, 11:25
от Zeed

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
173 Сообщений
alex0402
75 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
43 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
32 Сообщений

* Кто онлайн

  • Точка Гостей: 202
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal