Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 23:59
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Перенос цены из прайса  (Прочитано 3562 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет подскажи пожалуйста,не получается перенести номенклатуру и цену из прайса
Процедура СоздатьДокумент(ПутьКФайлу = "") Экспорт
   Попытка
        Эксель = Новый COMОбъект("Excel.Application");
   Исключение
        Сообщить(ОписаниеОшибки());
        Возврат;
   КонецПопытки;
   Документ = Документы.ИзменениеЦен.СоздатьДокумент();
   Документ.ХозОперация = Справочники.ХозОперации.УстановкаЦенКомпании;
   Книга = Эксель.WorkBooks.Open(ПутьКФайлу); 
   Лист = Книга.WorkSheets(1); 
   ВсегоСтрок = Лист.Cells(1,1).SpecialCells(11).Row;
   Для Ит = 2 По ВсегоСтрок Цикл
      КодНоменклатуры = СокрЛП(СтрЗаменить(Лист.Cells(Ит,3).Value," ",""));
      Цена = Число(СтрЗаменить( Лист.Cells(Ит,6).Value," ",""));
      Если СтрДлина(КодНоменклатуры)<10 Тогда
         Пока СтрДлина(КодНоменклатуры)<6 Цикл
            КодНоменклатуры = "0" + КодНоменклатуры;
         КонецЦикла;
      КонецЕсли;         
      Номенклатура = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул",КодНоменклатуры);
      Если Не Номенклатура.Пустая() Тогда
         НовСтр = Документ.Товары.Добавить();
         НовСтр.Номенклатура = Номенклатура;
         НовСтр.ЕдиницаИзмерения = Номенклатура.ОсновнаяЕдиницаИзмерения;
         НовСтр.Коэффициент = Номенклатура.ОсновнаяЕдиницаИзмерения.Коэффициент;
         НовСтр.Цена = Цена;
      КонецЕсли;   
      //Если Ит > 100 Тогда
      //   Прервать;
      //КонецЕсли;
      
   КонецЦикла;
   
   Форма = Документ.ПолучитьФорму();
   Форма.Открыть();
Эксель.Application.Quit();

документ создаётся а не чего не переносится .


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Вот же условие по которому в табличную часть добавляются строки Если Не Номенклатура.Пустая() Тогда

Номенклатуру не на ходит по АРТИКУЛУ
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Вот же условие по которому в табличную часть добавляются строки Если Не Номенклатура.Пустая() Тогда

Номенклатуру не на ходит по АРТИКУЛУ

Ну я думал ,как это работает,если номерклатуры такой нету то добавляется новая,или я не так понимаю?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Где она добавляется новая? В коде такого нету!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Где она добавляется новая? В коде такого нету!

А не подскажите что дописать чтоб добавлялась?Тут я понял добавляется толька та которая уже есть.


Теги:
 

Перенос товаров из д-та "Поступление Т и У" в "Отчет о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 5155
Последний ответ 01 Июн 2011, 16:31
от Eugeneer
Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7438
Последний ответ 06 Дек 2014, 17:40
от дфтын
КД, Перенос Реквизита справочника (7.7) в ТЧ справочника 8.2.

Автор EvgenyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3656
Последний ответ 17 Сен 2014, 13:39
от Kironten
Перенос контактов в "нет в базе" на следующий день.

Автор IsodemosРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1743
Последний ответ 25 Июн 2014, 16:28
от Isodemos
Запрос на перенос срока задачи НЕ автору задачи, а другому пользователю. Помогите с конфигурированием!

Автор juli777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1836
Последний ответ 18 Ноя 2014, 21:14
от sertak

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 240
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal