Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Янв 2018, 22:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: v8: создание элемента "переключатель" в форме документа!!!!!!!!!!  (Прочитано 5738 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн annaost

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-21
  • Сайт: 
  • Профессия: Программист 1С
Есть реквизит "Регистрация" документа "Справка", который имеет тип "ПеречислениеСсылка.ЗарегистрированВЦЗН"( 2 значения: Зарегистрирован и НеЗарегистрирован) .
В форме документа создала:
1) переключатель1
имя= Зарегистрирован
Заголовок=  был(а) зарегистрирован(а)
данные = Регистрация
Первый в группе
При изменении -> см. процедуру:

Процедура зарегистрированПриИзменении(Элемент)
 Если Элемент.Значение = Перечисления.ЗарегистрированВЦЗН.Зарегистрирован Тогда
 Регистрация = Перечисления.ЗарегистрированВЦЗН.Зарегистрирован;
ИначеЕсли Элемент.Значение = Перечисления.ЗарегистрированВЦЗН.НеЗарегистрирован Тогда
 Регистрация = Перечисления.ЗарегистрированВЦЗН.НеЗарегистрирован;
Иначе
 Предупреждение("Проверьте регистрацию в ЦЗН!");
КонецЕсли;
КонецПроцедуры

 2) переключатель2
 имя = НеЗарегистрирован
заголовок = не был(а) зарегистрирован(а)

Вопрос: почему условие "если" в процедуре не работает, в частности не передается значение Элемент.Значение ? Что я делаю не так? ПОМОГИТЕ!!!


Оффлайн pavl_vs

  • *****
  • Сообщений: 1089
  • РЕПУТАЦИЯ: 171
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Должно быть так:
Если Зарегистрирован = 1 Тогда
    //Код обработки 1
ИначеЕсли Зарегистрирован = 2 Тогда
    //Код обработки 2
Иначе
    //Код обработки 3
КонецЕсли;
А имя второго переключателя пишут для общности, если хотите, для самоуспокоения.

Оффлайн annaost

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-21
  • Сайт: 
  • Профессия: Программист 1С
{Документ.ДТСРкраткая.Форма.ФормаДокумента.Форма(34,6)}: Переменная не определена (Зарегистрирован)
Если <<?>>Зарегистрирован = 1 Тогда (Проверка: Толстый клиент (обычное приложение))


Что-то не так....

Оффлайн pavl_vs

  • *****
  • Сообщений: 1089
  • РЕПУТАЦИЯ: 171
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Для первого элемента группы установите тип значения "Число", длина 1, точность 0, выбираемое значение 1, а данные "Зарегистрирован", т.е. Данные = имени первого в группе элемента; для второго ничего менять не надо, но добавить выбираемое значение 2; Перем Регистрация // переменная модуля (можно не определять).

Вместо "Число" при 2-х положениях переключателя удобнее использовать Булевы переменные.


 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4580
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 16182
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4301
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 735
Последний ответ 10 Май 2017, 20:44
от ilnur75
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1662
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
109 Сообщений
AIFrame
105 Сообщений
alex0402
30 Сообщений
pavl_vs
19 Сообщений
alexandr_ll
19 Сообщений
kiksi
19 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
BuhRust
13 Сообщений

* Кто онлайн

  • Точка Гостей: 384
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal