Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Автоматически выходило ФИО в Реквизите  (Прочитано 3417 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Здравствуйте ! Подскажите пожалуйста как сделать так чтобы ФИО в Реквизите сразу выходило автоматически есть код рабочий:



&НаКлиенте
Процедура СотрудникНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
   
  Если объект.Сотрудникавтоматизации.Пустая() Тогда
    СтандартнаяОбработка=Ложь;
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ТекущаяСтрока", ПоискРодителяСотрудники("Иванов И.И."));
    ФормаВыбора = ПолучитьФорму("Справочник.Сотрудники.ФормаВыбора", ПараметрыФормы,Элемент);
    ФормаВыбора.ОткрытьМодально();
  КонецЕсли;


КонецПроцедуры




&НаСервере
Функция ПоискРодителяСотрудники(НаименованиеГр)
   Спр=Справочники.Сотрудники.НайтиПоНаименованию(НаименованиеГр);
   Возврат Спр;
КонецФункции


Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
никто не знает ? :(

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
не вполне понятно чего вы хотите, если вам необходимо чтобы в форме выбора сотрудника выводились какие-то дополнительные реквизиты, то измените форму выбора

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Да собственно хочу чтобы при открытии формы в Реквизите автоматически отображалсь его Ф.И.О.

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
создайте форму выбора и вытащите ФИО на форму, а форма управляемая?

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
создайте форму выбора и вытащите ФИО на форму, а форма управляемая?
Да управляемая.


Теги:
 

Как при вставке текста запроса с консоли запроса ив программный код конфигурации автоматически добавлять прямую черту в начале каждой строки

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2067
Последний ответ 16 Ноя 2015, 08:12
от KrivosheevEV
Как объединить объект в реквизите формы с типом "ДокументОбъект" и объект формы, созданной через "ПолучитьФорму()"?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 242
Последний ответ 06 Авг 2017, 21:22
от alex0402
подскажите как сделать так,чтобы в макете в нужных графах автоматически подставлялась текущая дата.

Автор MikhailDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1488
Последний ответ 12 Авг 2015, 19:26
от SkyNetYar
Как автоматически заполнить поле табличной части при выборе другого поля

Автор tepes666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 9594
Последний ответ 13 Авг 2010, 16:27
от fonbaron
Автоматически получать курсы валют ЦБ РФ сразу после торгов в 1С 7.7

Автор danishРаздел Закрытые темы

Ответов: 0
Просмотров: 4155
Последний ответ 10 Дек 2009, 16:48
от danish

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 220
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal