Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 03:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Автоматически выходило ФИО в Реквизите  (Прочитано 3817 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cobra77777

  • ***
  • Сообщений: 176
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Здравствуйте ! Подскажите пожалуйста как сделать так чтобы ФИО в Реквизите сразу выходило автоматически есть код рабочий:



&НаКлиенте
Процедура СотрудникНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
   
  Если объект.Сотрудникавтоматизации.Пустая() Тогда
    СтандартнаяОбработка=Ложь;
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ТекущаяСтрока", ПоискРодителяСотрудники("Иванов И.И."));
    ФормаВыбора = ПолучитьФорму("Справочник.Сотрудники.ФормаВыбора", ПараметрыФормы,Элемент);
    ФормаВыбора.ОткрытьМодально();
  КонецЕсли;


КонецПроцедуры




&НаСервере
Функция ПоискРодителяСотрудники(НаименованиеГр)
   Спр=Справочники.Сотрудники.НайтиПоНаименованию(НаименованиеГр);
   Возврат Спр;
КонецФункции


Оффлайн cobra77777

  • ***
  • Сообщений: 176
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
никто не знает ? :(

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
не вполне понятно чего вы хотите, если вам необходимо чтобы в форме выбора сотрудника выводились какие-то дополнительные реквизиты, то измените форму выбора

Оффлайн cobra77777

  • ***
  • Сообщений: 176
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Да собственно хочу чтобы при открытии формы в Реквизите автоматически отображалсь его Ф.И.О.

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
создайте форму выбора и вытащите ФИО на форму, а форма управляемая?

Оффлайн cobra77777

  • ***
  • Сообщений: 176
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
создайте форму выбора и вытащите ФИО на форму, а форма управляемая?
Да управляемая.


Теги:
 

Как при вставке текста запроса с консоли запроса ив программный код конфигурации автоматически добавлять прямую черту в начале каждой строки

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2449
Последний ответ 16 Ноя 2015, 08:12
от KrivosheevEV
После "Выборка = Запрос.Выполнить().Выбрать()" строка в выборке автоматически переключается сама

Автор RuslerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 215
Последний ответ 30 Мар 2018, 05:05
от Luzer1C
какая программа делает автоматически перевод из обычного интерфейса в управляемый интерфейс? как называется программа?

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 272
Последний ответ 02 Мар 2018, 21:35
от Св Ч
Как объединить объект в реквизите формы с типом "ДокументОбъект" и объект формы, созданной через "ПолучитьФорму()"?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 460
Последний ответ 06 Авг 2017, 21:22
от alex0402
подскажите как сделать так,чтобы в макете в нужных графах автоматически подставлялась текущая дата.

Автор MikhailDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1818
Последний ответ 12 Авг 2015, 19:26
от SkyNetYar

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
54 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 77
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal