Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 19:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обороты по счетам за период без аналитики  (Прочитано 7493 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
вот получился такой код:

Запрос = Новый Запрос;
   Запрос.Текст ="ВЫБРАТЬ
   |   ХозрасчетныйОбороты.Счет КАК Счет,
   |   ХозрасчетныйОбороты.СуммаОборот КАК СуммаОборот,
   |   ХозрасчетныйОбороты.СуммаОборотДт КАК СуммаОборотДт,
   |   ХозрасчетныйОбороты.СуммаОборотКт КАК СуммаОборотКт
   |ИЗ
   |   РегистрБухгалтерии.Хозрасчетный.Обороты(&ДатаНачала, &ДатаОкончания, , , , , , ) КАК ХозрасчетныйОбороты
   |" + ?(ЗначениеЗаполнено(МассивСчетов),"ГДЕ ХозрасчетныйОбороты.Счет В ИЕРАРХИИ(&Счета)","");
   Запрос.Текст =Запрос.Текст +"
   |
   |УПОРЯДОЧИТЬ ПО
   |   Счет";                             
   
   Запрос.УстановитьПараметр("Счета",МассивСчетов);
   Запрос.УстановитьПараметр("ДатаОкончания",КонецДня(ДатаОкончания));
   Запрос.УстановитьПараметр("ДатаНачала",ДатаНачала);
   
   Результат = Запрос.Выполнить().Выбрать();
   ТЗ = Новый ТаблицаЗначений;
   ТЗ.Колонки.Добавить("Счет");
   ТЗ.Колонки.Добавить("СуммаОборотов");
   Пока Результат.Следующий() Цикл
      Строка = ТЗ.Добавить();
      Если Результат.Счет.Родитель.Пустая() Тогда
         Строка.Счет = Результат.Счет;
      ИначеЕсли Результат.Счет.Родитель.Родитель.Пустая() Тогда
         Строка.Счет = Результат.Счет.Родитель.Код;
      ИначеЕсли Результат.Счет.Родитель.Родитель.Родитель.Пустая() Тогда
         Строка.Счет = Результат.Счет.Родитель.Родитель.Код;
      КонецЕсли;
      Строка.СуммаОборотов = Формат(Результат.СуммаОборот,"ЧДЦ=2");
   КонецЦикла;   
   
   ТЗ.Свернуть("Счет","СуммаОборотов");
   Для Каждого стр из ТЗ Цикл
      Строка = ТД.Добавить();
      Строка.Счет = стр.Счет;
      Строка.СуммаОборотов = Формат(Результат.СуммаОборот,"ЧДЦ=2");
   КонецЦикла;   
      
Что не так делаю??? Он мне по каждому счету одну и ту же сумму проставляет(


Оффлайн Msoul

  • **
  • Сообщений: 74
  • РЕПУТАЦИЯ: 6
  • КПД: 8%
  • Регистрация: 2010-04-19
  • Сайт: 
Все правильно тебе и показывает одну сумму. Ты же по таблице проходишься и подставляешь последнюю сумму из выборки Результат.СуммаОборот

   ТЗ.Свернуть("Счет","СуммаОборотов");
   Для Каждого стр из ТЗ Цикл
      Строка = ТД.Добавить();
      Строка.Счет = стр.Счет;
      Строка.СуммаОборотов = Формат(стр.СуммаОборот,"ЧДЦ=2");
   КонецЦикла;   

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
как сделать чтобы он суммировал суммы по счетам и их выводил?

Оффлайн Msoul

  • **
  • Сообщений: 74
  • РЕПУТАЦИЯ: 6
  • КПД: 8%
  • Регистрация: 2010-04-19
  • Сайт: 
как сделать чтобы он суммировал суммы по счетам и их выводил?
Общий итог по всем счетам? Так:
 
    Итог = 0;
     ТЗ.Свернуть("Счет","СуммаОборотов");
   Для Каждого стр из ТЗ Цикл
      Строка = ТД.Добавить();
      Строка.Счет = стр.Счет;
      Строка.СуммаОборотов = Формат(стр.СуммаОборот,"ЧДЦ=2");
       Итог = Итог + Строка.СуммаОборотов;
   КонецЦикла;   

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
нет, по каждому счету отдельно

Оффлайн Msoul

  • **
  • Сообщений: 74
  • РЕПУТАЦИЯ: 6
  • КПД: 8%
  • Регистрация: 2010-04-19
  • Сайт: 
Запрос = Новый Запрос;
   Запрос.Текст ="ВЫБРАТЬ
   |   ХозрасчетныйОбороты.Счет КАК Счет,
   |   ХозрасчетныйОбороты.СуммаОборот КАК СуммаОборот
   |ИЗ
   |   РегистрБухгалтерии.Хозрасчетный.Обороты(&ДатаНачала, &ДатаОкончания, , , , , , ) КАК ХозрасчетныйОбороты
   |" + ?(ЗначениеЗаполнено(МассивСчетов),"ГДЕ ХозрасчетныйОбороты.Счет В ИЕРАРХИИ(&Счета)","");
   Запрос.Текст =Запрос.Текст +"
   |
   |УПОРЯДОЧИТЬ ПО
   |   Счет";                             
   
   Запрос.УстановитьПараметр("Счета",МассивСчетов);
   Запрос.УстановитьПараметр("ДатаОкончания",КонецДня(ДатаОкончания));
   Запрос.УстановитьПараметр("ДатаНачала",ДатаНачала);
   
   Результат = Запрос.Выполнить().Выбрать();
   ТД = Запрос.Выполнить().Выгрузить();
 

При получении из виртуальной таблицы автоматически будет сумма по каждому счету

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
просто мне нужны счета без аналитики!!

Оффлайн Msoul

  • **
  • Сообщений: 74
  • РЕПУТАЦИЯ: 6
  • КПД: 8%
  • Регистрация: 2010-04-19
  • Сайт: 
Что значит без аналитики?

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
ну сумма должна быть по 01, а не мо 01.01 и т.д

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Ппц. Вот это трактовка!!!

(На будущее: Сказанное тобой тут - "ну сумма должна быть по 01, а не мо 01.01 и т.д" называется по группе счетов!) Советую прежде чем что то пытаться сделать для бухгалтерского учета - сначала почитать что это такое!
Что такое план счетов в 1С и Регистры бухгалтерии (дабы не задавать в будущем "Глупые" вопросы).

Змени в запросе условие "В ИЕРАРХИИ(&Счета)" на "В (&Счета)"
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

"Период не может быть пустым..."

Автор alexbelРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 4707
Последний ответ 25 Янв 2015, 20:17
от alexbel
Флаг "Запомнить выбранный период" на стандартной форме

Автор Екатерина ВершининаРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 462
Последний ответ 13 Дек 2016, 10:30
от Екатерина Вершинина
Как сделать простой отчет "Отработано выходных дней за период"

Автор NewbieDinaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 263
Последний ответ 06 Окт 2017, 12:25
от alex0402
Страховые взносы, которые были начислены в период применения УСН, теперь можно учесть для целей налога на прибыль

Автор newsРаздел Новости

Ответов: 0
Просмотров: 673
Последний ответ 06 Фев 2015, 12:51
от news
Сотрудники, приостановившие работу в связи с задержкой выплаты зарплаты, должны получать средний заработок в период простоя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1000
Последний ответ 23 Дек 2015, 14:18
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
71 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 321
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal