Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 20:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите сделать дату, чтоб отбор был за текущий месяц...  (Прочитано 6900 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alex_Us

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-26
  • Сайт: 
  • Профессия: Ученик 1С
нужно чтоб отбор был за месяц, то есть брал документы реализацию товаров и услуг, только за месяц!
не могу понять как сделать чтоб он понимал что именно за этот месяц нам надо.
допустим вормирую документ 30 числа апреля месяца и он мне подбирает документы реализациятоваровуслуг только за этот месяц.



Процедура ЗаполнитьРеализациюНажатие(Элемент)
       НачалоПериода = Дата(...,месяц);
        КонецПериода = Дата(...,месяц);
         СсылкаНаГруппу= Справочники.Контрагенты.НайтиПоНаименованию("ТорговыеТочки");

                 
Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    РеализацияТоваровУслуг.Ссылка,
        |    РеализацияТоваровУслуг.Дата,
        |    РеализацияТоваровУслуг.Контрагент
        |ИЗ
        |    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
        |ГДЕ
        |     РеализацияТоваровУслуг.Дата <= &КонецПериода
        |    И РеализацияТоваровУслуг.Дата >= &НачалоПериода
      |И РеализацияТоваровУслуг.Контрагент В ИЕРАРХИИ(&СсылкаНаГруппу)";
      // |   И РеализацияТоваровУслуг.Дата МЕЖДУ НАЧАЛОПЕРИОДА(&ДатаНач, МЕСЯЦ) И КОНЕЦПЕРИОДА(&ДатаКон, МЕСЯЦ)
   
    Запрос.УстановитьПараметр("КонецПериода", КонецПериода);
    Запрос.УстановитьПараметр("НачалоПериода", НачалоПериода);
   Запрос.УстановитьПараметр("СсылкаНаГруппу",СсылкаНаГруппу);

    РезультатЗапроса = Запрос.Выполнить();
    
      Выборка = РезультатЗапроса.Выбрать();
      
         Пока Выборка.Следующий() Цикл
         СтрокаТабличнойЧасти = ДокументыОснования.Добавить();
         СтрокаТабличнойЧасти.ДокументОснование = Выборка.Ссылка;
       КонецЦикла;
     //Объект = Объект.ДокументОснование.Загрузить(Запрос.Выполнить().Выгрузить());
          //Объект = Документы.СчетФактураВыданный.ПолучитьОбъект(ЭтотОбъект);
          //Объект.Записать();
    КонецПроцедуры






Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
отдельной процедурой сделай выбор даты
Процедура Кнопка1Нажатие(Элемент)
НастройкаПериода = Новый НастройкаПериода;
НастройкаПериода.УстановитьПериод(ДатаНач, ?(ДатаКон='0001-01-01', ДатаКон, КонецДня(ДатаКон)));
НастройкаПериода.РедактироватьКакИнтервал = Истина;
НастройкаПериода.РедактироватьКакПериод = Истина;
НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
НастройкаПериода.Редактировать();
ДатаНач = НастройкаПериода.ПолучитьДатуНачала();
ДатаКон = НастройкаПериода.ПолучитьДатуОкончания();
КонецПроцедуры



Оффлайн Alex_Us

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-26
  • Сайт: 
  • Профессия: Ученик 1С
а можно как то в этой процедуре? через НачалоПериода и КонецПериода...???

Оффлайн Msoul

  • **
  • Сообщений: 74
  • РЕПУТАЦИЯ: 6
  • КПД: 8%
  • Регистрация: 2010-04-19
  • Сайт: 
Попробуй:
    Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(КонецПериода));
    Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(НачалоПериода));

Оффлайн Alex_Us

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-26
  • Сайт: 
  • Профессия: Ученик 1С
почему то нет((( не идет... как будто ее объявить надо что ли...(((

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
а вы откуда дату берете? как вариант можно сделать так
Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(ТекущаяДата()));
Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(ТекущаяДата()));
но тогда в следующем месяце вы не сможете формировать нужные вам документы за предыдущий месяц, создайте на форме реквизит дата и тогда
Запрос.УстановитьПараметр("КонецПериода", КонецМесяца(Дата));
Запрос.УстановитьПараметр("НачалоПериода", НачалоМесяца(Дата));

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Alex_Us, вы опять просите готовый вариант! Вы так никогда не научитесь думать сами!

Besart подсказал вам готовое решение
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4289
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5544
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5879
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4359
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1975
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 343
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal