Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 16:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: В одномерном массиве найти максимальное кратное 10 число и его номер  (Прочитано 3557 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн julia89

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-21
  • Сайт: 
  • Профессия: Ученик 1С
 Подскажите, пожалуйста,что нужно сделать чтобы программа выводила номер этого числа!!!
Перем Кол, ЧислоХ;

НашМассив = Новый Массив;
ВвестиЧисло(Кол, "Введите количество элементов массива");
Для Сч = 1 По Кол Цикл
ВвестиЧисло (ЧислоХ, "Введите элемент массива");
НашМассив.Добавить(ЧислоХ);
КонецЦикла;

Крат10 = НашМассив[0];
Для Сч = 1 По Кол Цикл
     Если НашМассив[Сч-1]%10 = 0 Тогда
Крат10 = НашМассив[Сч-1];
     КонецЕсли;
 КонецЦикла;
 
МаксКрат10 = Крат10 ;

Для Сч = 1 По Кол Цикл
Если ЧислоХ > Крат10 Тогда
МаксКрат10 = ЧислоХ ;
КонецЕсли;
КонецЦикла;
Предупреждение("Максимальное кратное 10 число -  "  + МаксКрат10 );


Оффлайн pavl_vs

  • *****
  • Сообщений: 1070
  • РЕПУТАЦИЯ: 168
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Подскажите, пожалуйста,что нужно сделать чтобы программа выводила номер этого числа!!!
Ваша программа не выполняет и основной задачи, т.е. она не находит того самого числа - неверно написаны условия и определения во втором (основном) цикле.
Позицию искомого числа определяем в основном цикле (последний цикл в Вашем варианте не нужен) и программка выглядит следующим образом.

Перем Кол, ЧислоХ;
НашМассив = Новый Массив;
ВвестиЧисло(Кол, "Введите количество элементов массива");
Для Сч = 1 По Кол Цикл
    ВвестиЧисло (ЧислоХ, "Введите элемент массива");
    НашМассив.Добавить(ЧислоХ);
КонецЦикла;
Индекс = 0;    // позиция кратного 10 числа
МаксКрат10 = 0;
Для Сч = 1 По Кол Цикл
    Если НашМассив[Сч-1]%10 = 0 Тогда
        Крат10 = НашМассив[Сч-1];
        Если НашМассив[Сч-1] > МаксКрат10 Тогда
            МаксКрат10 = НашМассив[Сч-1];
            Индекс = Сч;
        КонецЕсли;
    КонецЕсли;
КонецЦикла;

Предупреждение("Максимальное кратное 10 число -  "  + МаксКрат10 +
", номер: " + Индекс);


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 592
  • Точка Скрытых: 1
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal