Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2018, 02:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: загрузка из xml в 1с  (Прочитано 5374 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн edzie

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-31
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, подскажите как изменить или какие 2 строчки надо добавить, чтобы из xml файла при его загрузке у сотрудников организации записывался их адрес и телефон?
&НаСервере
Процедура ЗагрузитьXML(Файлик)
   НовыйОбъектОрганизации = NULL;
   НовыйОбъектСотрудника = NULL;
   СпрОрг = Справочники.Организации;
   СпрСотр = Справочники.Сотрудники;
   ЗагXML = Новый ЧтениеXML;
   ЗагXML.ОткрытьФайл(Файлик);                       
   Пока ЗагXML.Прочитать() Цикл
      Если ЗагXML.Имя = "Организация" И ЗагXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
      ИначеЕсли ЗагXML.Имя = "Организация" И ЗагXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
              РезультатПоиска = СпрОрг.НайтиПоКоду(ЗагXML.ПолучитьАтрибут("Код"));
         Если РезультатПоиска.Пустая() Тогда
               НовыйОбъектОрганизации = СпрОрг.СоздатьЭлемент();
               НовыйОбъектОрганизации.Код = ЗагXML.ПолучитьАтрибут("Организация Код");
               НовыйОбъектОрганизации.Наименование = ЗагXML.ПолучитьАтрибут("Наименование");
               НовыйОбъектОрганизации.Записать();
      КонецЕсли;
           
      ИначеЕсли ЗагXML.Имя = "Сотрудник" И ЗагXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
               РезультатПоиска = СпрСотр.НайтиПоКоду(ЗагXML.ПолучитьАтрибут("Код"));
         Если РезультатПоиска.Пустая() Тогда
               НовыйОбъектСотрудника = СпрСотр.СоздатьЭлемент();
               НовыйОбъектСотрудника.Код = ЗагXML.ПолучитьАтрибут("Код");
               НовыйОбъектСотрудника.Наименование = ЗагXML.ПолучитьАтрибут("Наименование");
               НовыйОбъектСотрудника.паспорт = ЗагXML.ПолучитьАтрибут("Паспорт");
               НовыйОбъектМестоРаботыСотрудника = НовыйОбъектСотрудника.Организации.Добавить();
               НовыйОбъектМестоРаботыСотрудника.Организация = СпрОрг.НайтиПоКоду(ЗагXML.ПолучитьАтрибут("Организация"));
               НовыйОбъектКонтактыСотрудника = НовыйОбъектСотрудника.Адрес.Добавить();
               НовыйОбъектКонтактыСотрудника.телефон = ЗагXML.ПолучитьАтрибут("Телефон");
               НовыйОбъектКонтактыСотрудника.адрес = ЗагXML.ПолучитьАтрибут("Адрес");//
               НовыйОбъектСотрудника.Записать();
            КонецЕсли;
      КонецЕсли;
   КонецЦикла;
ЗагXML.Закрыть();
КонецПроцедуры

http://rghost.ru/45534314.view - структура xml
http://rghost.ru/45534309.view


Оффлайн Yura063

  • *****
  • Сообщений: 1050
  • РЕПУТАЦИЯ: 137
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: 
  • Профессия: Программист 1С
Посмотрите может эта информация хранится в подчиненном справочнике! тогда нужно создать объект этого справочника!
Помогли, отблагодари!


 

Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 9319
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
загрузка из "клиента банка"

Автор miximlРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3013
Последний ответ 19 Июн 2012, 09:49
от miximl
Загрузка в 1С Управление Торговлей 11.1.5.16 электронных выписок из клиент банка "Альфа-Банк"

Автор regnusРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 13369
Последний ответ 11 Июл 2014, 17:22
от regnus
Проблема с внешней обработкой "Загрузка банк-клиент.erp"

Автор razielРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 2598
Последний ответ 24 Сен 2015, 20:13
от Kironten
Загрузка из "нестандартного" табличного документа (exel) в справочник

Автор uchenichokРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1290
Последний ответ 03 Июн 2016, 07:15
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
139 Сообщений
alex0402
64 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
53 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
37 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
trialex3
30 Сообщений

* Кто онлайн

  • Точка Гостей: 196
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal