Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 06:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Контроль дней задолжености  (Прочитано 4167 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
Может кто подскажет. Стандартный механизм КА по контролю задолженности. Не устраивает такой момент, что когда у клиента долг 50000 на 01.01. он вносит платеж на 10000 01.04. отсчет дней начинается с этого момента, а не с 01.01. Как сделать чтобы отсчет дней оставался с 01.01.?? Спасибо


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
В договоре контрагента должна устанавливаться отсрочка
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
если не сложно поподробнее...что она дает и как устанавливается??

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
все правильно, контрагент оплатил часть долга и просрочка и пени на оставшуюся сумму считаются с этого момента, если у вас нестандартные условия договора, то тогда надо править механизм контроля задолженности

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
если не сложно поподробнее...что она дает и как устанавливается??
К сожалению у меня нету КА, не могу вам больше ничего подсказать...

Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
Сделала вот такой код:
Если ДоговорКонтрагента.КонтролироватьЧислоДнейЗадолженности = Истина Тогда
         СуммаДолга = УправлениеВзаиморасчетами.ТекущийДолг(ДоговорКонтрагента, Сделка, Ссылка);
         Если СуммаДолга > 0  Тогда
            Запрос = Новый Запрос;
            Запрос.Текст =
               "ВЫБРАТЬ ПЕРВЫЕ 1
               |   ВЫБОР
               |      КОГДА ВзаиморасчетыСКонтрагентамиОстатки.СуммаВзаиморасчетовОстаток > 0
               |         ТОГДА РАЗНОСТЬДАТ(РеализацияТоваровУслуг.Дата, ВзаиморасчетыСКонтрагентамиОбороты.Регистратор.Дата, ДЕНЬ) - 1
               |      ИНАЧЕ 0
               |   КОНЕЦ КАК ДатаДок,
               |   ВзаиморасчетыСКонтрагентамиОбороты.Регистратор.Ссылка,
               |   РеализацияТоваровУслуг.Дата,
               |   РеализацияТоваровУслуг.ДоговорКонтрагента.ДопустимоеЧислоДнейЗадолженности КАК Задолженность
               |ИЗ
               |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
               |      ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрНакопления.ВзаиморасчетыСКонтрагентами.Обороты(, , Регистратор, ) КАК ВзаиморасчетыСКонтрагентамиОбороты
               |      ПО РеализацияТоваровУслуг.ДоговорКонтрагента.Ссылка = ВзаиморасчетыСКонтрагентамиОбороты.ДоговорКонтрагента.Ссылка
               |      ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрНакопления.ВзаиморасчетыСКонтрагентами.Остатки КАК ВзаиморасчетыСКонтрагентамиОстатки
               |      ПО РеализацияТоваровУслуг.ДоговорКонтрагента.Ссылка = ВзаиморасчетыСКонтрагентамиОстатки.ДоговорКонтрагента.Ссылка
               |ГДЕ
               |   РеализацияТоваровУслуг.Ссылка = &Ссылка
               |
               |УПОРЯДОЧИТЬ ПО
               |   ДатаДок ";

            Запрос.УстановитьПараметр("Ссылка", Ссылка);

            Результат = Запрос.Выполнить().Выгрузить();
            Если Результат.Количество()> 0 Тогда
               Для каждого стр из Результат цикл
                  Дни = -(стр.ДатаДок);
                  Если Дни > стр.Задолженность Тогда
                     Число = дни-стр.Задолженность;
                     Сообщить("Долг просрочен на " + Строка(Число)+ " дней");
                     Отказ = Истина;
                  КонецЕсли;   
               КонецЦикла;   
            КонецЕсли;
         КонецЕсли;
      КонецЕсли;   

Теперь проблема как получить Дату последнего долга. Т.е. 25.01 появился долг - 26.01 его закрыли. 27.01 опять появился долг и его не закрыли и 28.01 тоже не закрытый долг, вот как получить дату 27.01??


Теги:
 

Отчет "Контроль цен"

Автор dronspartak9@gmail.comРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3015
Последний ответ 21 Май 2014, 17:40
от Eugeneer
Контроль заполнения реквизита в справочкнике "Номенклатура"

Автор c_andreyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 932
Последний ответ 08 Сен 2015, 13:18
от c_andrey
Контроль остатков товаров в документе "Корректировка реализации"

Автор LadyGaGa2012Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2384
Последний ответ 14 Май 2014, 12:29
от LadyGaGa2012
Если при проведении контроль остатков осуществляется после проведения.. Блок?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2032
Последний ответ 06 Май 2012, 21:29
от DirecTwiX
выводит ошибку при проведении документа "Оплаты праздничных и выходных дней"

Автор bannovРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2554
Последний ответ 06 Июл 2010, 14:46
от bannov

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 269
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal