Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 08:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как сложить элементы массива  (Прочитано 9281 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн MidnightKiller

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-15
  • Сайт: 
Добрый вечер.

Хочу написать обработку, которая при нажатии кнопки сообщала бы сумму всех элементов массива.
Помогите, как это реализовать а то всю голову уже сломал.

Я понимаю что надо задать цикл для каждого элемента массива, а реализовать увы не получается  :fdbsdfbsd:



Процедура КнопкаВыполнитьНажатие(Кнопка)

А = Новый Массив(5);

c[0] = 1;
c[1] = 2;
c[2] = 9;
c[3] = 8;

Для каждого C[0] из Новый Массив(5)
Цикл

КонецЦикла;





Сообщить();


КонецПроцедуры


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Сумма = 0;
Для каждого Элемент из Массив Цикл

    Сумма = Сумма + Элемент;

КонецЦикла;

Оффлайн MidnightKiller

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-15
  • Сайт: 
Спасибо за совет. Вот что получается, синтаксических ошибок нету, но ругается: "Преобразование к типу число не может быть выполнено."


Процедура КнопкаВыполнитьНажатие(Кнопка)
   
   А = Новый Массив(5);
   
    а[0] = 1;
   а[1] = 2;
   а[2] = 9;
   а[3] = 8;
   
   
            
      Сумма = 0;
      
Для каждого а из Новый Массив(5) Цикл

    Д = Сумма + а;

   
КонецЦикла;
         
      Сообщить(Д);
   
   
КонецПроцедуры

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
1С-овский код регистро-независим а=А=Истина!.
И приучайтесь с самого начала переменные называть своими именами...
МойМассив = Новый Массив(5); //Создание массива размерностью 5
   
   МойМассив[0] = 1;
   МойМассив[1] = 2;
   МойМассив[2] = 9;
   МойМассив[3] = 8;
   //Числами проинициализированы первые 4 элемента массива (Т.е. 5й элемент остался не инициализированным)
         
Д = 0;     
Для каждого эл из МойМассив Цикл
   
   Если ТипЗнч(эл) = Тип("Число") Тогда //Проверим что элемент массива является числом для математической операции сложения
      Д = Сумма + эл;
   КонецЕсли;
   
КонецЦикла;
         
Сообщить(Д);
     
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн MidnightKiller

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-15
  • Сайт: 
Спасибо огромное, но пришлось немного поправить чтобы заработало и суммировало элементы массива между собой. Так как в данном случае оно не считает сумму а почему то выдает 3, это 4ый элемент массива.
Все равно огромное спасибо. Если интересно, то в результате я сделал так:




Процедура КнопкаВыполнитьНажатие(Кнопка)

МойМассив = Новый Массив(5); //Создание массива размерностью 5
   
   МойМассив[0] = 10;
   МойМассив[1] = 1;
   МойМассив[2] = 2;
   МойМассив[3] = 3;
   //Числами проинициализированы первые 4 элемента массива (Т.е. 5й элемент остался не инициализированным)
         
Сумма = 0;     

Для каждого эл из МойМассив Цикл
   
   Если ТипЗнч(эл) = Тип("Число") Тогда //Проверим что элемент массива является числом для математической операции сложения
      Сумма = Сумма + эл;
   КонецЕсли;
   
КонецЦикла;
         
Сообщить(Сумма);
     
КонецПроцедуры


Оффлайн pavl_vs

  • *****
  • Сообщений: 1070
  • РЕПУТАЦИЯ: 168
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Ошибка сложения "Преобразование к типу число не может быть выполнено" возникала из-за неопределенности в типе неинициализированного (5-го) элемента массива; т.е. если его инициализировать или ограничить размерность массива (например, МойМассив = Новый Массив(4)), то отпадет необходимость проверки типа значения.



Теги:
 

При обновлении на последние релизы в документе "Начисление зарплаты" не работают элементы формы

Автор Ольга166Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 1179
Последний ответ 12 Июн 2017, 00:43
от дфтын
Элементы Формы (Программное создание таблицы на форме и ручное заполнение)

Автор SpiriTMan777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 8188
Последний ответ 02 Авг 2011, 13:41
от sergejK74
Как найти элементы справочника в которых не указан строковый реквизит?

Автор СтафРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2076
Последний ответ 28 Ноя 2009, 12:42
от Никитина
Можно ли добавлять элементы в справочник, используя форму списка? 8.2

Автор maxkovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2504
Последний ответ 11 Дек 2011, 13:48
от maxkov
Странно обновляется конфигурация БД - на форме недоступны элементы управления

Автор DoomychРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 968
Последний ответ 11 Мар 2015, 12:00
от Doomych

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 181
  • Точка Скрытых: 1
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal