Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 18:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: не заполняет документ!  (Прочитано 8748 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alex_Us

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-26
  • Сайт: 
  • Профессия: Ученик 1С
написала запрос, чтоб заполнял табличную часть документа счет-фактура выданный, документами реализация товаров и услуг. но по нажатию кнопки заполнить реализацию, он ничего не заполняет(((( в чем моя ошибка???

Процедура ЗаполнитьРеализациюНажатие(Элемент)
Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    РеализацияТоваровУслуг.Ссылка,
        |    РеализацияТоваровУслуг.Дата,
        |    РеализацияТоваровУслуг.Контрагент
        |ИЗ
        |    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
        |ГДЕ
        |     РеализацияТоваровУслуг.Дата <= &КонецПериода
        |    И РеализацияТоваровУслуг.Дата >= &НачалоПериода
      |И РеализацияТоваровУслуг.Контрагент В ИЕРАРХИИ(&СсылкаНаГруппу)";
      
    Запрос.УстановитьПараметр("КонецПериода", КонецПериода);
    Запрос.УстановитьПараметр("НачалоПериода", НачалоПериода);
   Запрос.УстановитьПараметр("СсылкаНаГруппу",СсылкаНаГруппу);

    РезультатЗапроса = Запрос.Выполнить();
    
      Выборка = РезультатЗапроса.Выбрать();
   
      Пока Выборка.Следующий() Цикл
         СтрокаТабличнойЧасти = ДокументыОснования.Добавить();
         СтрокаТабличнойЧасти.ДокументОснование = Выборка.Ссылка;
         Дата = Выборка.Дата;
         Контрагент = Выборка.Контрагент;
    КонецЦикла;
      
        Объект = Документы.СчетФактураВыданный.ПолучитьОбъект(ЭтотОбъект);
        Объект.Записать();
    КонецПроцедуры


Оффлайн Kat_v

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 4
  • КПД: 21%
  • Регистрация: 2013-03-06
  • Сайт: 
  • Профессия: Консультант 1С
сначала надо получить объект и только после этого в писать в табличную часть значения...

Оффлайн Alex_Us

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-26
  • Сайт: 
  • Профессия: Ученик 1С
можете помочь ? как это сделать? уже все перепробовала... не получается все никак((((

Оффлайн Kat_v

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 4
  • КПД: 21%
  • Регистрация: 2013-03-06
  • Сайт: 
  • Профессия: Консультант 1С
ваш текст....
Выборка = РезультатЗапроса.Выбрать();
   
    Объект = Документы.СчетФактураВыданный.ПолучитьОбъект(ЭтотОбъект);

  Пока Выборка.Следующий() Цикл
         СтрокаТабличнойЧасти = ДокументыОснования.Добавить();
         СтрокаТабличнойЧасти.ДокументОснование = Выборка.Ссылка;
         Дата = Выборка.Дата;
         Контрагент = Выборка.Контрагент;
    КонецЦикла;
       
       
        Объект.Записать();
    КонецПроцедуры

как-то вот так...

Оффлайн Alex_Us

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-26
  • Сайт: 
  • Профессия: Ученик 1С
нет все равно ничего не заполняет(((

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Объект = Документы.СчетФактураВыданный.ПолучитьОбъект(ЭтотОбъект);
Зачем вообще получать объект?
Добавлено: 22 Апр 2013, 09:26

Alex_Us, у вас правильный код
Удалите только эти строки
Объект = Документы.СчетФактураВыданный.ПолучитьОбъект(ЭтотОбъект);
        Объект.Записать();
Добавлено: 22 Апр 2013, 09:27

Они не нужны.

Проверьте запрос возвращает результат? (Воспользуйтесь консолью запросов)
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Alex_Us

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-26
  • Сайт: 
  • Профессия: Ученик 1С
удалила, все равно ничего не работает! а как же без этих строк? ведь записать то все это как то надо....

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Зачем записывать? Ты же в в форме счет фактуры это делаешь! Твоя задача заполнить табличную часть, а записывать или нет, пусть пользователь решает!
Добавлено: 22 Апр 2013, 09:36

Повторюсь...

Проверь запрос!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Alex_Us

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-26
  • Сайт: 
  • Профессия: Ученик 1С
все проверила, вроде се верно, а все равно не заполняет........

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
а на какой форме у вас эта кнопка заполнения расположена? на форме документа "Счет-фактура выданный"?


Теги:
 

не находить контрагента (Выбрать * Из Документ ГДЕ контрагент = "имя контрагента")

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 235
Последний ответ 23 Окт 2017, 23:14
от Ivan94
Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4398
Последний ответ 25 Ноя 2008, 10:43
от DDD
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9341
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3915
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
Как программно открыть документ программно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 19031
Последний ответ 10 Ноя 2010, 14:08
от Lexius

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 603
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal