Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 20:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проверка введены ли данные в поле  (Прочитано 4320 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн korvindeson

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-16
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! За тупость вопроса ногами умоляю не бить. Программирование в 1С не изучал, на основе имеющихся обработок сделал внешнюю обработку для выгрузки файла в банк. Только не нашёл как сделать проверку введены ли данные в поле формы (как обозвать не знаю, в скриншоте).
Нужен примерно такой алгоритм

    Если НомерВедомости = "" Тогда
//Вывести диалог с возможностью ввести или просто вывести ошибку, мол введите
    КонецЕсли;

Заранее благодарен :D


Оффлайн korvindeson

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-16
  • Сайт: 
  • Профессия: Ученик 1С
И ещё вопрос.
Если Выборка.СпособВыплаты = Перечисления.СпособыВыплатыЗарплаты.ЧерезБанк Тогда
//собственно код
КонецЕсли;
Как тут уточнить какой именно банк я хочу?

PS Справка в 1С-ке жутко стрёмная

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Если тип поля - строка, то подойдет ваш вариант:
    Если НомерВедомости = "" Тогда
//Вывести диалог с возможностью ввести или просто вывести ошибку, мол введите
    КонецЕсли;
Есть универсальный метод ЗначениеЗаполнено(), т.е. проверка на пустое значение будет выглядеть так:
Если НЕ ЗначениеЗаполнено(НомерВедомости) Тогда
//Вывести диалог с возможностью ввести или просто вывести ошибку, мол введите
КонецЕсли;
Как тут уточнить какой именно банк я хочу?
надо видеть структуру данных целиком. покажите хотя бы полностью запрос.

Оффлайн korvindeson

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-16
  • Сайт: 
  • Профессия: Ученик 1С
Мixqn, благодарю. Что вы имеете ввиду под "надо видеть структуру данных целиком" не вполне понятно, так что чёрт с ним если что, код процедуры ниже. Главное сделано, а про банк так, красивость.

Процедура КоманднаяПанель1Заполнить(Кнопка)

Если Не ЗначениеНеЗаполнено(Организация) Тогда
ПолучитьКодНажатие(Кнопка);
КонецЕсли;


СписокДокументов.Очистить();
Выборка = Документы.ЗарплатаКВыплатеОрганизаций.Выбрать(ДатаНачала, ДатаОкончания);

Пока Выборка.Следующий() Цикл

Если Выборка.ПометкаУдаления Тогда
Продолжить;
КонецЕсли;

Если Не ЗначениеНеЗаполнено(Организация) Тогда
Если Выборка.Организация <> Организация Тогда
Продолжить;
КонецЕсли;
КонецЕсли;

Если Выборка.СпособВыплаты = Перечисления.СпособыВыплатыЗарплаты.ЧерезКассу Тогда
Продолжить;
КонецЕсли;

//Если Выборка.СпособВыплаты = Перечисления.СпособыВыплатыЗарплаты.ЧерезБанк Тогда --> Тут бы выбрать банк
    Стр = СписокДокументов.Добавить();
        Стр.Дата            = Выборка.Дата;
    Стр.Комментарий     = Выборка.Банк;
    Стр.МесяцНачисления = Выборка.ПериодРегистрации;
                    ПроцедурыУправленияПерсоналом.ЗаполнитьКраткийСоставДокумента(Выборка.Зарплата,"Физлицо");
              Стр.Номер           = Выборка.Номер;
    Стр.Организация     = Выборка.Организация;
    Стр.Документ        = Выборка.Ссылка;
        //КонецЕсли;
КонецЦикла;
КонецПроцедуры

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Сообщить(Выборка.Банк);
Добавлено: 16 Апр 2013, 23:50

И вообще эту строку лучше заменить на запрос
Выборка = Документы.ЗарплатаКВыплатеОрганизаций.Выбрать(ДатаНачала, ДатаОкончания);

Тогда не нужны будут эти куски
Если Выборка.ПометкаУдаления Тогда
            Продолжить;
        КонецЕсли;   
       
        Если Не ЗначениеНеЗаполнено(Организация) Тогда
            Если Выборка.Организация <> Организация Тогда
                Продолжить;           
            КонецЕсли;   
        КонецЕсли;   
       
        Если Выборка.СпособВыплаты = Перечисления.СпособыВыплатыЗарплаты.ЧерезКассу Тогда
            Продолжить;
        КонецЕсли;
И в запросе сразу можно будет отобрать данные по нужному банку!!!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Поле не найдено"ЗаказПокупателя.Услуги.Ссылка"<<?>>ЗаказПокупателя.Услуги.Ссылка

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 6940
Последний ответ 05 Дек 2013, 00:01
от romanprogrammist
{Форма.Форма.Форма(11)}: Поле объекта не обнаружено

Автор OksРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2286
Последний ответ 09 Дек 2015, 19:33
от Oks
Вывод информации: если поле не заполнено, то вывод иной информации. Новичок

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 311
Последний ответ 10 Окт 2017, 12:33
от kiksi
Поле "ВаловаяПрибыль" не может быть использовано в группировке "Store" СКД

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6407
Последний ответ 10 Июл 2014, 15:16
от virtus
Не заполняется поле "Цена" при формировании документа "Пересчет товаров"

Автор InnakechaРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 1081
Последний ответ 29 Дек 2016, 09:54
от Innakecha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 324
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal